summaryrefslogtreecommitdiff
path: root/dev-ros/rosunit/rosunit-1.15.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rosunit/rosunit-1.15.8.ebuild')
-rw-r--r--dev-ros/rosunit/rosunit-1.15.8.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/rosunit/rosunit-1.15.8.ebuild b/dev-ros/rosunit/rosunit-1.15.8.ebuild
new file mode 100644
index 000000000000..5e1930ae53d6
--- /dev/null
+++ b/dev-ros/rosunit/rosunit-1.15.8.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Unit-testing package for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
+ dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]") )
+"