summaryrefslogtreecommitdiff
path: root/dev-ros/rostopic/rostopic-1.15.11.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rostopic/rostopic-1.15.11.ebuild')
-rw-r--r--dev-ros/rostopic/rostopic-1.15.11.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/rostopic/rostopic-1.15.11.ebuild b/dev-ros/rostopic/rostopic-1.15.11.ebuild
new file mode 100644
index 000000000000..9ea612e200ff
--- /dev/null
+++ b/dev-ros/rostopic/rostopic-1.15.11.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tool for displaying debug information about ROS Topics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosbag[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ )
+"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}