summaryrefslogtreecommitdiff
path: root/dev-ros/rosservice/rosservice-1.15.11.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rosservice/rosservice-1.15.11.ebuild')
-rw-r--r--dev-ros/rosservice/rosservice-1.15.11.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/rosservice/rosservice-1.15.11.ebuild b/dev-ros/rosservice/rosservice-1.15.11.ebuild
new file mode 100644
index 000000000000..a7c61cee1d7d
--- /dev/null
+++ b/dev-ros/rosservice/rosservice-1.15.11.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tool for listing and querying ROS Services"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosgraph[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rosmsg[${PYTHON_SINGLE_USEDEP}]
+"
+DEPEND="${RDEPEND}"