summaryrefslogtreecommitdiff
path: root/dev-ros/rosserial_xbee/rosserial_xbee-0.9.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rosserial_xbee/rosserial_xbee-0.9.2.ebuild')
-rw-r--r--dev-ros/rosserial_xbee/rosserial_xbee-0.9.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/rosserial_xbee/rosserial_xbee-0.9.2.ebuild b/dev-ros/rosserial_xbee/rosserial_xbee-0.9.2.ebuild
new file mode 100644
index 000000000000..0c7384c1e7c8
--- /dev/null
+++ b/dev-ros/rosserial_xbee/rosserial_xbee-0.9.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-drivers/rosserial"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Tools to do communicate between rosserial nodes connected to an xbee"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/pyserial[\${PYTHON_USEDEP}]")
+ dev-ros/rosserial_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosserial_python[${PYTHON_SINGLE_USEDEP}]
+"
+DEPEND="${RDEPEND}"