summaryrefslogtreecommitdiff
path: root/dev-ros/rosclean/rosclean-1.15.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rosclean/rosclean-1.15.8.ebuild')
-rw-r--r--dev-ros/rosclean/rosclean-1.15.8.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-ros/rosclean/rosclean-1.15.8.ebuild b/dev-ros/rosclean/rosclean-1.15.8.ebuild
new file mode 100644
index 000000000000..ab620eea3d8f
--- /dev/null
+++ b/dev-ros/rosclean/rosclean-1.15.8.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Cleanup filesystem resources (e.g. log files)"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="$(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")"
+DEPEND="${RDEPEND}
+ test? ( $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]") )
+"