summaryrefslogtreecommitdiff
path: root/dev-ros/rosbag_storage/rosbag_storage-1.15.11.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rosbag_storage/rosbag_storage-1.15.11.ebuild')
-rw-r--r--dev-ros/rosbag_storage/rosbag_storage-1.15.11.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-ros/rosbag_storage/rosbag_storage-1.15.11.ebuild b/dev-ros/rosbag_storage/rosbag_storage-1.15.11.ebuild
new file mode 100644
index 000000000000..98d1abfadea8
--- /dev/null
+++ b/dev-ros/rosbag_storage/rosbag_storage-1.15.11.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Set of tools for recording from and playing back ROS message"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/console_bridge
+
+ dev-ros/cpp_common
+ >=dev-ros/pluginlib-1.13.0-r2:=
+ dev-ros/roscpp_serialization
+ dev-ros/roscpp_traits
+ dev-ros/rostime
+ dev-ros/roslz4
+
+ dev-libs/boost:=
+ app-arch/bzip2
+ dev-libs/console_bridge:=
+ dev-libs/tinyxml2:=
+
+ dev-libs/openssl:0=
+ app-crypt/gpgme
+"
+DEPEND="${RDEPEND}
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ test? (
+ dev-ros/rostest
+ dev-cpp/gtest
+ )
+"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ export CATKIN_PREFIX_PATH="${BUILD_DIR}/devel/:${CATKIN_PREFIX_PATH}"
+ ros-catkin_src_test
+}