summaryrefslogtreecommitdiff
path: root/dev-ros/poco_vendor/poco_vendor-1.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/poco_vendor/poco_vendor-1.2.1.ebuild')
-rw-r--r--dev-ros/poco_vendor/poco_vendor-1.2.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-ros/poco_vendor/poco_vendor-1.2.1.ebuild b/dev-ros/poco_vendor/poco_vendor-1.2.1.ebuild
new file mode 100644
index 000000000000..8665d91b1561
--- /dev/null
+++ b/dev-ros/poco_vendor/poco_vendor-1.2.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_7,3_8} )
+
+inherit cmake python-any-r1
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ros2/poco_vendor"
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/ros2/poco_vendor/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="CMake shim over the poco library"
+HOMEPAGE="https://github.com/ros2/poco_vendor"
+
+LICENSE="Apache-2.0 Boost-1.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ PROPERTIES="live"
+else
+ KEYWORDS="~amd64"
+fi
+IUSE=""
+
+DEPEND="
+ >=dev-libs/poco-1.6.1
+ dev-libs/libpcre
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ $(python_gen_any_dep 'ros-meta/ament_cmake[${PYTHON_USEDEP}]')
+ ${PYTHON_DEPS}
+"
+
+python_check_deps() {
+ has_version "ros-meta/ament_cmake[${PYTHON_USEDEP}]"
+}