summaryrefslogtreecommitdiff
path: root/dev-ros/pcl_ros/pcl_ros-1.7.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/pcl_ros/pcl_ros-1.7.2.ebuild')
-rw-r--r--dev-ros/pcl_ros/pcl_ros-1.7.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-ros/pcl_ros/pcl_ros-1.7.2.ebuild b/dev-ros/pcl_ros/pcl_ros-1.7.2.ebuild
new file mode 100644
index 000000000000..afd8b02fd200
--- /dev/null
+++ b/dev-ros/pcl_ros/pcl_ros-1.7.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-perception/perception_pcl"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="PCL (Point Cloud Library) ROS interface stack"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/rosbag
+ dev-ros/rosconsole
+ dev-ros/roslib
+ dev-ros/dynamic_reconfigure[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/message_filters
+ >=dev-cpp/eigen-3.2.5:3
+ dev-ros/pluginlib
+ dev-libs/console_bridge:=
+ dev-ros/tf
+ dev-ros/tf2
+ dev-ros/tf2_ros
+ dev-ros/tf2_eigen
+ dev-ros/nodelet
+ dev-ros/nodelet_topic_tools
+ sci-libs/pcl:=[qhull]
+ >=dev-ros/pcl_conversions-0.2.1-r1
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}
+ dev-ros/pcl_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ test? (
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-cpp/gtest
+ )
+"
+PATCHES=( "${FILESDIR}/tests.patch" )