summaryrefslogtreecommitdiff
path: root/dev-ros/openni2_camera/openni2_camera-1.5.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/openni2_camera/openni2_camera-1.5.1.ebuild')
-rw-r--r--dev-ros/openni2_camera/openni2_camera-1.5.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/openni2_camera/openni2_camera-1.5.1.ebuild b/dev-ros/openni2_camera/openni2_camera-1.5.1.ebuild
new file mode 100644
index 000000000000..ee182d23620f
--- /dev/null
+++ b/dev-ros/openni2_camera/openni2_camera-1.5.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-drivers/openni2_camera"
+CATKIN_HAS_MESSAGES=yes
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS drivers for the Asus Xtion and Primesense Devices"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/image_transport
+ dev-ros/camera_info_manager
+ dev-ros/dynamic_reconfigure[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/nodelet
+ dev-libs/console_bridge:=
+ dev-ros/roscpp
+ dev-libs/OpenNI2
+ dev-libs/boost:=[threads(+)]
+"
+DEPEND="${RDEPEND}
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"