summaryrefslogtreecommitdiff
path: root/dev-ros/mavros_msgs/mavros_msgs-1.8.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/mavros_msgs/mavros_msgs-1.8.0.ebuild')
-rw-r--r--dev-ros/mavros_msgs/mavros_msgs-1.8.0.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-ros/mavros_msgs/mavros_msgs-1.8.0.ebuild b/dev-ros/mavros_msgs/mavros_msgs-1.8.0.ebuild
new file mode 100644
index 000000000000..11b0de2bd004
--- /dev/null
+++ b/dev-ros/mavros_msgs/mavros_msgs-1.8.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/mavlink/mavros"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/geographic_msgs dev-ros/geometry_msgs dev-ros/sensor_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Messages for MAVROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"