summaryrefslogtreecommitdiff
path: root/dev-ros/mavros/mavros-1.8.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/mavros/mavros-1.8.0.ebuild')
-rw-r--r--dev-ros/mavros/mavros-1.8.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ros/mavros/mavros-1.8.0.ebuild b/dev-ros/mavros/mavros-1.8.0.ebuild
new file mode 100644
index 000000000000..b2927fcf9bd2
--- /dev/null
+++ b/dev-ros/mavros/mavros-1.8.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/mavlink/mavros"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="MAVLink extendable communication node for ROS"
+LICENSE="GPL-3 LGPL-3 BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_updater
+ dev-ros/pluginlib
+ dev-libs/tinyxml2:=
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/angles
+ dev-ros/libmavconn
+ dev-ros/rosconsole_bridge
+ dev-libs/boost:=
+ dev-ros/eigen_conversions
+ sci-geosciences/GeographicLib
+ >=dev-ros/mavlink-gbp-release-2020.9.10
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ >=dev-ros/mavros_msgs-${PV}[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/trajectory_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"