summaryrefslogtreecommitdiff
path: root/dev-ros/imu_complementary_filter/imu_complementary_filter-1.2.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/imu_complementary_filter/imu_complementary_filter-1.2.3.ebuild')
-rw-r--r--dev-ros/imu_complementary_filter/imu_complementary_filter-1.2.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/imu_complementary_filter/imu_complementary_filter-1.2.3.ebuild b/dev-ros/imu_complementary_filter/imu_complementary_filter-1.2.3.ebuild
new file mode 100644
index 000000000000..6d1597fea89e
--- /dev/null
+++ b/dev-ros/imu_complementary_filter/imu_complementary_filter-1.2.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ccny-ros-pkg/imu_tools"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Fuses angular velocities, accelerations, and magnetic readings from an IMU"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/message_filters
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+BDEPEND="
+ dev-ros/cmake_modules
+"