summaryrefslogtreecommitdiff
path: root/dev-ros/image_geometry/image_geometry-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/image_geometry/image_geometry-9999.ebuild')
-rw-r--r--dev-ros/image_geometry/image_geometry-9999.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/dev-ros/image_geometry/image_geometry-9999.ebuild b/dev-ros/image_geometry/image_geometry-9999.ebuild
index 4b65c37fb167..e1195646cedd 100644
--- a/dev-ros/image_geometry/image_geometry-9999.ebuild
+++ b/dev-ros/image_geometry/image_geometry-9999.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros-perception/vision_opencv"
KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python2_7 )
ROS_SUBDIR=${PN}
inherit ros-catkin
@@ -16,7 +15,12 @@ IUSE=""
RDEPEND="
media-libs/opencv:=
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}] dev-cpp/gtest )"
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ test? (
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ dev-cpp/gtest
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ )"