summaryrefslogtreecommitdiff
path: root/dev-ros/hector_mapping/hector_mapping-0.5.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/hector_mapping/hector_mapping-0.5.2.ebuild')
-rw-r--r--dev-ros/hector_mapping/hector_mapping-0.5.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/hector_mapping/hector_mapping-0.5.2.ebuild b/dev-ros/hector_mapping/hector_mapping-0.5.2.ebuild
new file mode 100644
index 000000000000..f3266ab2140e
--- /dev/null
+++ b/dev-ros/hector_mapping/hector_mapping-0.5.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/nav_msgs dev-ros/visualization_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="SLAM that can be used without odometry and on platforms that exhibit roll/pitch"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/message_filters
+ dev-ros/laser_geometry
+ dev-ros/tf_conversions
+ dev-libs/boost:=[threads(+)]
+"
+DEPEND="${RDEPEND}
+ dev-cpp/eigen:3"