summaryrefslogtreecommitdiff
path: root/dev-ros/hector_mapping/files/boost170.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/hector_mapping/files/boost170.patch')
-rw-r--r--dev-ros/hector_mapping/files/boost170.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/dev-ros/hector_mapping/files/boost170.patch b/dev-ros/hector_mapping/files/boost170.patch
new file mode 100644
index 000000000000..89bc05d2f7da
--- /dev/null
+++ b/dev-ros/hector_mapping/files/boost170.patch
@@ -0,0 +1,13 @@
+Index: hector_mapping/CMakeLists.txt
+===================================================================
+--- hector_mapping.orig/CMakeLists.txt
++++ hector_mapping/CMakeLists.txt
+@@ -7,7 +7,7 @@ project(hector_mapping)
+ find_package(catkin REQUIRED COMPONENTS roscpp nav_msgs visualization_msgs tf message_filters laser_geometry tf_conversions message_generation)
+
+ ## System dependencies are found with CMake's conventions
+-find_package(Boost REQUIRED COMPONENTS thread signals)
++find_package(Boost REQUIRED COMPONENTS thread)
+ include_directories(${Boost_INCLUDE_DIRS})
+
+ # Find Eigen3 (from http://wiki.ros.org/jade/Migration)