summaryrefslogtreecommitdiff
path: root/dev-ros/hardware_interface/hardware_interface-0.19.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/hardware_interface/hardware_interface-0.19.5.ebuild')
-rw-r--r--dev-ros/hardware_interface/hardware_interface-0.19.5.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-ros/hardware_interface/hardware_interface-0.19.5.ebuild b/dev-ros/hardware_interface/hardware_interface-0.19.5.ebuild
new file mode 100644
index 000000000000..3cbf6c2cb246
--- /dev/null
+++ b/dev-ros/hardware_interface/hardware_interface-0.19.5.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-controls/ros_control"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Hardware Interface base class"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/roscpp"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest dev-ros/rostest )"