summaryrefslogtreecommitdiff
path: root/dev-ros/gmapping
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/gmapping')
-rw-r--r--dev-ros/gmapping/Manifest5
-rw-r--r--dev-ros/gmapping/gmapping-1.3.8.ebuild25
-rw-r--r--dev-ros/gmapping/gmapping-9999.ebuild25
-rw-r--r--dev-ros/gmapping/metadata.xml11
4 files changed, 66 insertions, 0 deletions
diff --git a/dev-ros/gmapping/Manifest b/dev-ros/gmapping/Manifest
new file mode 100644
index 000000000000..0f65f1d64f12
--- /dev/null
+++ b/dev-ros/gmapping/Manifest
@@ -0,0 +1,5 @@
+DIST slam_gmapping-1.3.8.tar.gz 20533 SHA256 027e31fbe6d8768a746b0eeb93238459b295b15efc0f43f9410afc57d71385d1 SHA512 d7b054296f286a5e61e5f952a29ccff2165503123ab6a89724ec34180fb0f4c452fc0ae81ec853cac170b304095e62cef420431e5aca85a262febc2b5ab5ccf2 WHIRLPOOL ced3e8b2c1f3887afd6df6ea780d3a9a111b29f20db0dedf6af497737e9b2f7c089ce3f673ba309262271c2741a1b73474c2412bbe89c84937c706bad0d95b15
+EBUILD gmapping-1.3.8.ebuild 528 SHA256 9efb248d246ded84e3e2ef49f18ac6d07138d946351748d04458989dcada2394 SHA512 92d31dccbad5f5e345b011779d386e3e4ea670f7447a566fc1628ef586d409e8b4d2bf07074ebb4899505ce8d131d8d80b5751501c4c87622c2ce32b276b93c2 WHIRLPOOL 23b010036825eae2e198f493ee4b7b640c5e3c2d72dd05da3b99d8a6314128ac2a2785ae8354e75258f374cae663224d9376542f47aa9297c6a7c24af0338e27
+EBUILD gmapping-9999.ebuild 528 SHA256 9efb248d246ded84e3e2ef49f18ac6d07138d946351748d04458989dcada2394 SHA512 92d31dccbad5f5e345b011779d386e3e4ea670f7447a566fc1628ef586d409e8b4d2bf07074ebb4899505ce8d131d8d80b5751501c4c87622c2ce32b276b93c2 WHIRLPOOL 23b010036825eae2e198f493ee4b7b640c5e3c2d72dd05da3b99d8a6314128ac2a2785ae8354e75258f374cae663224d9376542f47aa9297c6a7c24af0338e27
+MISC ChangeLog 1282 SHA256 05394e2a117a5cbce7c51198e60c604278f25f7212c12c08c62695e045afaa2c SHA512 60b6f49330becb6f049d3aaf224a82ab93f655abdfe66fa53ff86b6e2e0816d9fb71f4fc62a631ba81a7c13221d48502051d96ec3b5be8ee2b3866f879a7c3a8 WHIRLPOOL 0a4eb464b7728a1b8066c73426fd2af99674082711a1921dcae707fdb15d90c73eda1440f57d5656bc915917b2b6086b14b0b106bdaa25c567da161d315e65fb
+MISC metadata.xml 342 SHA256 ebb581e87be9c72c6de396c597ff6c586884626f4d00fd461fb1253464b586ba SHA512 2a5beef664e8c79b9e4d858d0dc093068c6e462456ae6066ea637f4b725e5c7184dd65769906c34e55eb6b03949e957edba34b84a587e1daec784e1f74ea287c WHIRLPOOL 85164a9d14d47128903fc36c818da15d46484dceb573efeeed27d7c6796fa5b59a39848493a4cc0297ef746a57941c629b7de563e6b22db1fa29048027ade81a
diff --git a/dev-ros/gmapping/gmapping-1.3.8.ebuild b/dev-ros/gmapping/gmapping-1.3.8.ebuild
new file mode 100644
index 000000000000..5c4afd8f8aa4
--- /dev/null
+++ b/dev-ros/gmapping/gmapping-1.3.8.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/slam_gmapping"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS wrapper for OpenSlam's Gmapping"
+LICENSE="CC-BY-NC-SA-2.5"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/openslam_gmapping
+ dev-ros/rosbag_storage
+"
+DEPEND="${RDEPEND}
+ dev-ros/rostest"
diff --git a/dev-ros/gmapping/gmapping-9999.ebuild b/dev-ros/gmapping/gmapping-9999.ebuild
new file mode 100644
index 000000000000..5c4afd8f8aa4
--- /dev/null
+++ b/dev-ros/gmapping/gmapping-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/slam_gmapping"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS wrapper for OpenSlam's Gmapping"
+LICENSE="CC-BY-NC-SA-2.5"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/openslam_gmapping
+ dev-ros/rosbag_storage
+"
+DEPEND="${RDEPEND}
+ dev-ros/rostest"
diff --git a/dev-ros/gmapping/metadata.xml b/dev-ros/gmapping/metadata.xml
new file mode 100644
index 000000000000..a45ed347785d
--- /dev/null
+++ b/dev-ros/gmapping/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-perception/slam_gmapping</remote-id>
+ </upstream>
+</pkgmetadata>