summaryrefslogtreecommitdiff
path: root/dev-ros/genpy/genpy-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/genpy/genpy-9999.ebuild')
-rw-r--r--dev-ros/genpy/genpy-9999.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-ros/genpy/genpy-9999.ebuild b/dev-ros/genpy/genpy-9999.ebuild
index 68c34049dcc0..29c86a165741 100644
--- a/dev-ros/genpy/genpy-9999.ebuild
+++ b/dev-ros/genpy/genpy-9999.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros/genpy"
KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python{2_7,3_6} pypy3 )
inherit ros-catkin
@@ -22,3 +21,4 @@ DEPEND="${RDEPEND}
dev-python/nose[${PYTHON_USEDEP}]
)
"
+PATCHES=( "${FILESDIR}/yaml.patch" )