summaryrefslogtreecommitdiff
path: root/dev-ros/genpy/genpy-0.6.11.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/genpy/genpy-0.6.11.ebuild')
-rw-r--r--dev-ros/genpy/genpy-0.6.11.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/genpy/genpy-0.6.11.ebuild b/dev-ros/genpy/genpy-0.6.11.ebuild
new file mode 100644
index 000000000000..29c86a165741
--- /dev/null
+++ b/dev-ros/genpy/genpy-0.6.11.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/genpy"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Python ROS message and service generators"
+HOMEPAGE="http://wiki.ros.org/genpy"
+LICENSE="BSD"
+SLOT="0/${PV}"
+IUSE=""
+
+RDEPEND="dev-ros/genmsg[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+PATCHES=( "${FILESDIR}/yaml.patch" )