summaryrefslogtreecommitdiff
path: root/dev-ros/gencpp/gencpp-0.6.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/gencpp/gencpp-0.6.5.ebuild')
-rw-r--r--dev-ros/gencpp/gencpp-0.6.5.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-ros/gencpp/gencpp-0.6.5.ebuild b/dev-ros/gencpp/gencpp-0.6.5.ebuild
new file mode 100644
index 000000000000..87b3e6abb207
--- /dev/null
+++ b/dev-ros/gencpp/gencpp-0.6.5.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/gencpp"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="ROS C++ message definition and serialization generators"
+HOMEPAGE="http://wiki.ros.org/gencpp"
+LICENSE="BSD"
+SLOT="0/${PV}"
+IUSE=""
+
+RDEPEND="dev-ros/genmsg[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"