summaryrefslogtreecommitdiff
path: root/dev-ros/gencpp/gencpp-0.6.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/gencpp/gencpp-0.6.2.ebuild')
-rw-r--r--dev-ros/gencpp/gencpp-0.6.2.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-ros/gencpp/gencpp-0.6.2.ebuild b/dev-ros/gencpp/gencpp-0.6.2.ebuild
new file mode 100644
index 000000000000..7da44afd03eb
--- /dev/null
+++ b/dev-ros/gencpp/gencpp-0.6.2.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/gencpp"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_5,3_6} pypy{,3} )
+
+inherit ros-catkin
+
+DESCRIPTION="ROS C++ message definition and serialization generators"
+HOMEPAGE="http://wiki.ros.org/gencpp"
+LICENSE="BSD"
+SLOT="0/${PV}"
+IUSE=""
+
+RDEPEND="dev-ros/genmsg[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"