summaryrefslogtreecommitdiff
path: root/dev-ros/fake_localization/fake_localization-1.17.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/fake_localization/fake_localization-1.17.1-r1.ebuild')
-rw-r--r--dev-ros/fake_localization/fake_localization-1.17.1-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/fake_localization/fake_localization-1.17.1-r1.ebuild b/dev-ros/fake_localization/fake_localization-1.17.1-r1.ebuild
new file mode 100644
index 000000000000..30d6188cb635
--- /dev/null
+++ b/dev-ros/fake_localization/fake_localization-1.17.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="A ROS node that simply forwards odometry information"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-ros/angles:0
+ dev-ros/roscpp
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rosconsole
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/tf2_ros
+ dev-ros/message_filters
+"
+DEPEND="${RDEPEND}
+ dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"