summaryrefslogtreecommitdiff
path: root/dev-ros/dwa_local_planner/dwa_local_planner-1.17.1-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/dwa_local_planner/dwa_local_planner-1.17.1-r2.ebuild')
-rw-r--r--dev-ros/dwa_local_planner/dwa_local_planner-1.17.1-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ros/dwa_local_planner/dwa_local_planner-1.17.1-r2.ebuild b/dev-ros/dwa_local_planner/dwa_local_planner-1.17.1-r2.ebuild
new file mode 100644
index 000000000000..4b1dd66aea9a
--- /dev/null
+++ b/dev-ros/dwa_local_planner/dwa_local_planner-1.17.1-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Dynamic Window Approach to local robot navigation on a plane"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/angles:0
+ dev-ros/base_local_planner
+ dev-ros/costmap_2d
+ dev-ros/dynamic_reconfigure[${PYTHON_SINGLE_USEDEP}]
+ dev-cpp/eigen:3
+ dev-ros/nav_core
+ dev-ros/pluginlib
+ dev-ros/roscpp
+
+ dev-ros/tf2
+ dev-ros/tf2_ros
+
+ dev-libs/boost:=[threads(+)]
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"