summaryrefslogtreecommitdiff
path: root/dev-ros/cv_bridge/files/ocv_leak.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/cv_bridge/files/ocv_leak.patch')
-rw-r--r--dev-ros/cv_bridge/files/ocv_leak.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-ros/cv_bridge/files/ocv_leak.patch b/dev-ros/cv_bridge/files/ocv_leak.patch
new file mode 100644
index 000000000000..32b3fafbe074
--- /dev/null
+++ b/dev-ros/cv_bridge/files/ocv_leak.patch
@@ -0,0 +1,20 @@
+Index: cv_bridge/CMakeLists.txt
+===================================================================
+--- cv_bridge.orig/CMakeLists.txt
++++ cv_bridge/CMakeLists.txt
+@@ -17,14 +17,7 @@ else()
+ find_package(Boost REQUIRED)
+ endif()
+
+-set(_opencv_version 4)
+-find_package(OpenCV 4 QUIET)
+-if(NOT OpenCV_FOUND)
+- message(STATUS "Did not find OpenCV 4, trying OpenCV 3")
+- set(_opencv_version 3)
+-endif()
+-
+-find_package(OpenCV ${_opencv_version4} REQUIRED
++find_package(OpenCV 4 REQUIRED
+ COMPONENTS
+ opencv_core
+ opencv_imgproc