summaryrefslogtreecommitdiff
path: root/dev-ros/cv_bridge/files/boostpython.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/cv_bridge/files/boostpython.patch')
-rw-r--r--dev-ros/cv_bridge/files/boostpython.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/dev-ros/cv_bridge/files/boostpython.patch b/dev-ros/cv_bridge/files/boostpython.patch
new file mode 100644
index 000000000000..72fac8087363
--- /dev/null
+++ b/dev-ros/cv_bridge/files/boostpython.patch
@@ -0,0 +1,17 @@
+Index: cv_bridge/CMakeLists.txt
+===================================================================
+--- cv_bridge.orig/CMakeLists.txt
++++ cv_bridge/CMakeLists.txt
+@@ -5,11 +5,7 @@ find_package(catkin REQUIRED COMPONENTS
+
+ if(NOT ANDROID)
+ find_package(PythonLibs)
+- if(PYTHONLIBS_VERSION_STRING VERSION_LESS 3)
+- find_package(Boost REQUIRED python)
+- else()
+- find_package(Boost REQUIRED python3)
+- endif()
++ find_package(Boost REQUIRED python${PYTHON_VERSION_MAJOR}${PYTHON_VERSION_MINOR})
+ else()
+ find_package(Boost REQUIRED)
+ endif()