summaryrefslogtreecommitdiff
path: root/dev-ros/control_toolbox/control_toolbox-1.18.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/control_toolbox/control_toolbox-1.18.2-r1.ebuild')
-rw-r--r--dev-ros/control_toolbox/control_toolbox-1.18.2-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/control_toolbox/control_toolbox-1.18.2-r1.ebuild b/dev-ros/control_toolbox/control_toolbox-1.18.2-r1.ebuild
new file mode 100644
index 000000000000..83cfabc81f04
--- /dev/null
+++ b/dev-ros/control_toolbox/control_toolbox-1.18.2-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-controls/control_toolbox"
+KEYWORDS="~amd64"
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Modules that are useful across all controllers"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/dynamic_reconfigure
+ dev-ros/realtime_tools
+ dev-libs/boost:=[threads(+)]
+ dev-libs/tinyxml
+"
+DEPEND="${RDEPEND}
+ dev-ros/control_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ test? ( dev-cpp/gtest )
+"