summaryrefslogtreecommitdiff
path: root/dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-9999.ebuild')
-rw-r--r--dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-9999.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-9999.ebuild b/dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-9999.ebuild
index d4ef693e9dd2..97f465fd4872 100644
--- a/dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-9999.ebuild
+++ b/dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-9999.ebuild
@@ -1,25 +1,28 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros-perception/image_transport_plugins"
KEYWORDS="~amd64 ~arm"
ROS_SUBDIR=${PN}
-PYTHON_COMPAT=( python2_7 )
inherit ros-catkin
-DESCRIPTION="Plugin to image_transport for transparently sending depth images using PNG compression"
+DESCRIPTION="Plugin for transparently sending depth images using PNG compression"
LICENSE="BSD"
SLOT="0"
IUSE=""
RDEPEND="
dev-ros/cv_bridge
- dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/dynamic_reconfigure[${PYTHON_SINGLE_USEDEP}]
dev-ros/image_transport
media-libs/opencv:=
dev-libs/boost:=
dev-libs/console_bridge:=
"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ test? (
+ dev-cpp/gtest
+ )
+"