summaryrefslogtreecommitdiff
path: root/dev-ros/combined_robot_hw/combined_robot_hw-0.19.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/combined_robot_hw/combined_robot_hw-0.19.5.ebuild')
-rw-r--r--dev-ros/combined_robot_hw/combined_robot_hw-0.19.5.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/combined_robot_hw/combined_robot_hw-0.19.5.ebuild b/dev-ros/combined_robot_hw/combined_robot_hw-0.19.5.ebuild
new file mode 100644
index 000000000000..d1ef9a1b84bc
--- /dev/null
+++ b/dev-ros/combined_robot_hw/combined_robot_hw-0.19.5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-controls/ros_control"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Combined Robot HW class"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-ros/hardware_interface-0.15
+ dev-ros/pluginlib
+ dev-libs/tinyxml2:=
+ dev-ros/roscpp
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}"