summaryrefslogtreecommitdiff
path: root/dev-ros/camera_calibration_parsers/files/boostpython.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/camera_calibration_parsers/files/boostpython.patch')
-rw-r--r--dev-ros/camera_calibration_parsers/files/boostpython.patch2
1 files changed, 1 insertions, 1 deletions
diff --git a/dev-ros/camera_calibration_parsers/files/boostpython.patch b/dev-ros/camera_calibration_parsers/files/boostpython.patch
index 8e2b868ec452..02019d6458f7 100644
--- a/dev-ros/camera_calibration_parsers/files/boostpython.patch
+++ b/dev-ros/camera_calibration_parsers/files/boostpython.patch
@@ -14,7 +14,7 @@ Index: camera_calibration_parsers/CMakeLists.txt
-else()
- find_package(Boost REQUIRED COMPONENTS filesystem python3)
-endif()
-+find_package(Boost REQUIRED COMPONENTS filesystem python)
++find_package(Boost REQUIRED COMPONENTS filesystem python${PYTHON_VERSION_MAJOR}${PYTHON_VERSION_MINOR})
include_directories(include ${catkin_INCLUDE_DIRS} ${Boost_INCLUDE_DIRS} ${PYTHON_INCLUDE_DIRS})
catkin_python_setup()