summaryrefslogtreecommitdiff
path: root/dev-ros/ament_pep257/ament_pep257-0.11.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/ament_pep257/ament_pep257-0.11.2.ebuild')
-rw-r--r--dev-ros/ament_pep257/ament_pep257-0.11.2.ebuild17
1 files changed, 5 insertions, 12 deletions
diff --git a/dev-ros/ament_pep257/ament_pep257-0.11.2.ebuild b/dev-ros/ament_pep257/ament_pep257-0.11.2.ebuild
index d68cc9cf4ecc..92564bbd5e52 100644
--- a/dev-ros/ament_pep257/ament_pep257-0.11.2.ebuild
+++ b/dev-ros/ament_pep257/ament_pep257-0.11.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{3_7,3_8} )
+PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -12,11 +12,11 @@ ROS_PN="ament_lint"
if [ "${PV#9999}" != "${PV}" ] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ament/ament_lint"
- SRC_URI=""
- S=${WORKDIR}/${P}/${PN}
+ S="${WORKDIR}/${P}/${PN}"
else
SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+ KEYWORDS="~amd64"
fi
DESCRIPTION="Checks code against style conventions in PEP 8 and generate test result files"
@@ -24,23 +24,16 @@ HOMEPAGE="https://github.com/ament/ament_lint"
LICENSE="Apache-2.0"
SLOT="0"
-if [ "${PV#9999}" != "${PV}" ] ; then
- PROPERTIES="live"
-else
- KEYWORDS="~amd64"
-fi
-IUSE="test"
RDEPEND="
dev-ros/ament_lint[${PYTHON_USEDEP}]
dev-python/pydocstyle[${PYTHON_USEDEP}]
"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
test? (
dev-ros/ament_flake8[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
)
"
-BDEPEND=""
distutils_enable_tests pytest