summaryrefslogtreecommitdiff
path: root/dev-ros/ament_cpplint/ament_cpplint-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/ament_cpplint/ament_cpplint-9999.ebuild')
-rw-r--r--dev-ros/ament_cpplint/ament_cpplint-9999.ebuild18
1 files changed, 4 insertions, 14 deletions
diff --git a/dev-ros/ament_cpplint/ament_cpplint-9999.ebuild b/dev-ros/ament_cpplint/ament_cpplint-9999.ebuild
index c8856b376bb5..fd0a411550bc 100644
--- a/dev-ros/ament_cpplint/ament_cpplint-9999.ebuild
+++ b/dev-ros/ament_cpplint/ament_cpplint-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{3_7,3_8} )
+PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -12,11 +12,11 @@ ROS_PN="ament_lint"
if [ "${PV#9999}" != "${PV}" ] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ament/ament_lint"
- SRC_URI=""
- S=${WORKDIR}/${P}/${PN}
+ S="${WORKDIR}/${P}/${PN}"
else
SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+ KEYWORDS="~amd64"
fi
DESCRIPTION="The ability to check code against the Google style conventions using cpplint"
@@ -24,23 +24,13 @@ HOMEPAGE="https://github.com/ament/ament_lint"
LICENSE="Apache-2.0"
SLOT="0"
-if [ "${PV#9999}" != "${PV}" ] ; then
- PROPERTIES="live"
-else
- KEYWORDS="~amd64"
-fi
-IUSE="test"
-RDEPEND="
-"
-DEPEND="${RDEPEND}
+BDEPEND="
test? (
dev-ros/ament_copyright[${PYTHON_USEDEP}]
dev-ros/ament_flake8[${PYTHON_USEDEP}]
dev-ros/ament_pep257[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
)
"
-BDEPEND=""
distutils_enable_tests pytest