summaryrefslogtreecommitdiff
path: root/dev-ros/ament_cppcheck/ament_cppcheck-0.10.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/ament_cppcheck/ament_cppcheck-0.10.4.ebuild')
-rw-r--r--dev-ros/ament_cppcheck/ament_cppcheck-0.10.4.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-ros/ament_cppcheck/ament_cppcheck-0.10.4.ebuild b/dev-ros/ament_cppcheck/ament_cppcheck-0.10.4.ebuild
index 2dbf9430dfe6..1ec0564cee82 100644
--- a/dev-ros/ament_cppcheck/ament_cppcheck-0.10.4.ebuild
+++ b/dev-ros/ament_cppcheck/ament_cppcheck-0.10.4.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{3_7,3_8} )
+PYTHON_COMPAT=( python{3_8,3_9,3_10} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -36,3 +36,8 @@ RDEPEND="
"
DEPEND=""
BDEPEND=""
+
+# pytest.ini is there but no tests are ran causing it to fail
+RESTRICT="test"
+
+distutils_enable_tests pytest