summaryrefslogtreecommitdiff
path: root/dev-ros/ament_cmake_test/ament_cmake_test-1.1.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/ament_cmake_test/ament_cmake_test-1.1.4.ebuild')
-rw-r--r--dev-ros/ament_cmake_test/ament_cmake_test-1.1.4.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-ros/ament_cmake_test/ament_cmake_test-1.1.4.ebuild b/dev-ros/ament_cmake_test/ament_cmake_test-1.1.4.ebuild
new file mode 100644
index 000000000000..bb59c0de949c
--- /dev/null
+++ b/dev-ros/ament_cmake_test/ament_cmake_test-1.1.4.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_7,3_8} )
+
+inherit cmake python-r1
+
+ROS_PN="ament_cmake"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_cmake"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="The ability to add tests in the ament buildsystem"
+HOMEPAGE="https://github.com/ament/ament_cmake"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ PROPERTIES="live"
+else
+ KEYWORDS="~amd64"
+fi
+IUSE=""
+
+DEPEND="
+ dev-ros/ament_cmake_core
+ dev-python/ament_package[${PYTHON_USEDEP}]
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]
+ dev-ros/ament_cmake_python
+ ${PYTHON_DEPS}
+"
+RDEPEND="${DEPEND}"
+BDEPEND="${DEPEND}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_configure() {
+ python_foreach_impl cmake_src_configure
+}
+
+src_compile() {
+ python_foreach_impl cmake_src_compile
+}
+
+src_test() {
+ python_foreach_impl cmake_src_test
+}
+
+src_install() {
+ python_foreach_impl cmake_src_install
+ python_foreach_impl python_optimize
+}