summaryrefslogtreecommitdiff
path: root/dev-qt/qtwayland/qtwayland-5.15.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qtwayland/qtwayland-5.15.2-r1.ebuild')
-rw-r--r--dev-qt/qtwayland/qtwayland-5.15.2-r1.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-qt/qtwayland/qtwayland-5.15.2-r1.ebuild b/dev-qt/qtwayland/qtwayland-5.15.2-r1.ebuild
deleted file mode 100644
index d042284d7177..000000000000
--- a/dev-qt/qtwayland/qtwayland-5.15.2-r1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit qt5-build
-
-DESCRIPTION="Wayland platform plugin for Qt"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~riscv ~sparc x86"
-fi
-
-IUSE="vulkan X"
-
-DEPEND="
- >=dev-libs/wayland-1.6.0
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtdeclarative-${PV}
- ~dev-qt/qtgui-${PV}[egl,libinput,vulkan=]
- media-libs/mesa[egl]
- >=x11-libs/libxkbcommon-0.2.0
- vulkan? ( dev-util/vulkan-headers )
- X? (
- ~dev-qt/qtgui-${PV}[-gles2-only]
- x11-libs/libX11
- x11-libs/libXcomposite
- )
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}"/${P}-qtwaylandscanner-avoid-dangling-pointers.patch )
-
-src_configure() {
- local myqmakeargs=(
- --
- $(qt_use vulkan feature-wayland-vulkan-server-buffer)
- $(qt_use X feature-xcomposite-egl)
- $(qt_use X feature-xcomposite-glx)
- )
- qt5-build_src_configure
-}