summaryrefslogtreecommitdiff
path: root/dev-qt/qttools
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qttools')
-rw-r--r--dev-qt/qttools/Manifest1
-rw-r--r--dev-qt/qttools/qttools-6.6.9999.ebuild153
2 files changed, 0 insertions, 154 deletions
diff --git a/dev-qt/qttools/Manifest b/dev-qt/qttools/Manifest
index a23122e52aeb..ea554a02e13d 100644
--- a/dev-qt/qttools/Manifest
+++ b/dev-qt/qttools/Manifest
@@ -3,7 +3,6 @@ DIST qttools-everywhere-src-6.6.3.tar.xz 8596272 BLAKE2B 375a018d3fff0ef52e7e8e3
DIST qttools-everywhere-src-6.7.0-rc2.tar.xz 9013380 BLAKE2B f6b9b83af390f3c2f851dc8e99ae6a045752a77f9878a1c096c35a034515680d27e65ca3ccf6d558de74804eb82f1a1c2e92377db1de014581685f44d05cb5ce SHA512 23b8a88397f89d1aaf80495d15bc34d3ebc54ef14097065bb2c013d4c408407a24fcc901b0c2691c2bec758309bea8f3c53be551960e58255b2e3858b817e3af
EBUILD qttools-6.6.2.ebuild 4542 BLAKE2B 97b1c6bc9be1c42bbea95bbfc1f16793050aa919103fff63a7be786301bd396f16a00a76817feedeace43f766a3d9bba4ad9d9d1c99e4655c62483b392725843 SHA512 a6380a6dfe0d156e03ad68caa350aad1e7d72c1d9cd7f808ae1d27538d79e0d4ad8fe06f6a03532f848bd0bb3093d76d7a1d9323658ba516fce686b8d9d2c706
EBUILD qttools-6.6.3.ebuild 4617 BLAKE2B 43df100437250e26e3a42d89c9debc0306fdd197881844ba9ba356c3af3de37570c49ef7c3c6083edeeaadd5747c8f7a39a9d653cc6647446cb3a7b3a9a48ab0 SHA512 67740fa1ba6776955b6b08b965342589068f8d8313e29e8073ab87f5759a38cdce4a9ff04797e0837d220cd89006bb2de9d78bc69b2d92b32018a1380d85527a
-EBUILD qttools-6.6.9999.ebuild 4617 BLAKE2B 43df100437250e26e3a42d89c9debc0306fdd197881844ba9ba356c3af3de37570c49ef7c3c6083edeeaadd5747c8f7a39a9d653cc6647446cb3a7b3a9a48ab0 SHA512 67740fa1ba6776955b6b08b965342589068f8d8313e29e8073ab87f5759a38cdce4a9ff04797e0837d220cd89006bb2de9d78bc69b2d92b32018a1380d85527a
EBUILD qttools-6.7.0_rc2.ebuild 4647 BLAKE2B afebd788adca5f69928e1133b31bbd62868f9faed44672490573fc45ab001df93410247c699b017a952f9f597aebc1c297eef3bedc4af4775cbc0ecc3aeb79ac SHA512 7cfac939d123eca6572166b2db8eeeb8e8bb6a6f89bb9f9a1a1cadd618dd8ba9e09c3889c10e65b37fffa5c103bb37e8189847dcbebd6f07839d6a3a3342ffa1
EBUILD qttools-6.7.9999.ebuild 4647 BLAKE2B afebd788adca5f69928e1133b31bbd62868f9faed44672490573fc45ab001df93410247c699b017a952f9f597aebc1c297eef3bedc4af4775cbc0ecc3aeb79ac SHA512 7cfac939d123eca6572166b2db8eeeb8e8bb6a6f89bb9f9a1a1cadd618dd8ba9e09c3889c10e65b37fffa5c103bb37e8189847dcbebd6f07839d6a3a3342ffa1
EBUILD qttools-6.9999.ebuild 4647 BLAKE2B afebd788adca5f69928e1133b31bbd62868f9faed44672490573fc45ab001df93410247c699b017a952f9f597aebc1c297eef3bedc4af4775cbc0ecc3aeb79ac SHA512 7cfac939d123eca6572166b2db8eeeb8e8bb6a6f89bb9f9a1a1cadd618dd8ba9e09c3889c10e65b37fffa5c103bb37e8189847dcbebd6f07839d6a3a3342ffa1
diff --git a/dev-qt/qttools/qttools-6.6.9999.ebuild b/dev-qt/qttools/qttools-6.6.9999.ebuild
deleted file mode 100644
index db9c412f9118..000000000000
--- a/dev-qt/qttools/qttools-6.6.9999.ebuild
+++ /dev/null
@@ -1,153 +0,0 @@
-# Copyright 2021-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LLVM_COMPAT=( {15..18} )
-LLVM_OPTIONAL=1
-inherit desktop llvm-r1 optfeature qt6-build
-
-DESCRIPTION="Qt Tools Collection"
-
-if [[ ${QT6_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
-fi
-
-IUSE="
- +assistant clang designer distancefieldgenerator gles2-only
- +linguist opengl pixeltool +qdbus qdoc qml qtattributionsscanner
- qtdiag qtplugininfo vulkan +widgets zstd
-"
-# note that some tools do not *require* widgets but will skip a sub-tool
-# if not enabled (e.g. linguist gives lrelease but not the GUI linguist6)
-REQUIRED_USE="
- assistant? ( widgets )
- clang? ( ${LLVM_REQUIRED_USE} )
- designer? ( qml widgets )
- distancefieldgenerator? ( qml widgets )
- pixeltool? ( widgets )
- qdoc? ( clang qml )
-"
-
-# behaves very badly when qttools is not already installed, also
-# other more minor issues (clang tests flaky depending on version,
-# and 3rdparty/ tries to FetchContent gtest)
-RESTRICT="test"
-
-RDEPEND="
- ~dev-qt/qtbase-${PV}:6[network,widgets?]
- assistant? ( ~dev-qt/qtbase-${PV}:6[sql,sqlite] )
- clang? (
- $(llvm_gen_dep '
- sys-devel/clang:${LLVM_SLOT}=
- sys-devel/llvm:${LLVM_SLOT}=
- ')
- )
- designer? (
- ~dev-qt/qtbase-${PV}:6[xml,zstd=]
- zstd? ( app-arch/zstd:= )
- )
- qdbus? ( ~dev-qt/qtbase-${PV}:6[dbus,xml] )
- qml? ( ~dev-qt/qtdeclarative-${PV}:6[widgets?] )
- qtdiag? ( ~dev-qt/qtbase-${PV}:6[gles2-only=,vulkan=] )
- widgets? ( ~dev-qt/qtbase-${PV}:6[opengl=] )
-"
-DEPEND="
- ${RDEPEND}
- qtdiag? (
- vulkan? ( dev-util/vulkan-headers )
- )
-"
-
-pkg_setup() {
- use clang && llvm-r1_pkg_setup
-}
-
-src_configure() {
- local mycmakeargs=(
- # prevent the clang test as it can abort due to bug #916098
- $(cmake_use_find_package clang WrapLibClang)
- $(cmake_use_find_package qml Qt6Qml)
- $(cmake_use_find_package widgets Qt6Widgets)
- $(qt_feature assistant)
- $(qt_feature clang)
- $(qt_feature designer)
- $(qt_feature distancefieldgenerator)
- $(qt_feature linguist)
- $(qt_feature pixeltool)
- $(qt_feature qdbus)
- $(qt_feature qdoc)
- $(qt_feature qtattributionsscanner)
- $(qt_feature qtdiag)
- $(qt_feature qtplugininfo)
-
- # TODO?: package litehtml, but support for latest releases seem
- # to lag behind and bundled may work out better for now
- # https://github.com/litehtml/litehtml/issues/266
- $(usev assistant -DCMAKE_DISABLE_FIND_PACKAGE_litehtml=ON)
-
- $(usev designer -DQT_UNITY_BUILD=OFF) # fails to build (QTBUG-122634)
- )
-
- qt6-build_src_configure
-}
-
-src_install() {
- qt6-build_src_install
-
- if use widgets; then #914766
- use designer || use distancefieldgenerator || use pixeltool &&
- newicon src/designer/src/designer/images/designer.png designer6.png
-
- if use assistant; then
- make_desktop_entry assistant6 'Qt 6 Assistant' assistant6 \
- 'Qt;Development;Documentation' \
- 'Comment=Tool for viewing online documentation in Qt help file format'
- newicon src/assistant/assistant/images/assistant-128.png assistant6.png
- fi
-
- if use designer; then
- make_desktop_entry designer6 'Qt 6 Designer' designer6 \
- 'Qt;Development;GUIDesigner' \
- 'Comment=WYSIWYG tool for designing and building graphical user interfaces with QtWidgets'
- fi
-
- if use distancefieldgenerator; then
- # no icon, sharing with designer which fits letter-wise
- make_desktop_entry qdistancefieldgenerator6 'Qt 6 Distance Field Generator' designer6 \
- 'Qt;Development' \
- 'Comment=Tool for pregenerating the font cache of Qt applications'
- fi
-
- if use linguist; then
- make_desktop_entry linguist6 'Qt 6 Linguist' linguist6 \
- 'Qt;Development;Translation' \
- 'Comment=Tool for translating Qt applications'
- newicon src/linguist/linguist/images/icons/linguist-128-32.png linguist6.png
- fi
-
- if use pixeltool; then
- # no icon, not fitting but share with designer for now
- make_desktop_entry pixeltool6 'Qt 6 Pixel Tool' designer6 \
- 'Qt;Development' \
- 'Comment=Tool for zooming in the desktop area pointed by the cursor'
- fi
-
- if use qdbus; then
- make_desktop_entry qdbusviewer6 'Qt 6 QDBusViewer' qdbusviewer6 \
- 'Qt;Development' \
- 'Comment=Tool that lets introspect D-Bus objects and messages'
- newicon src/qdbus/qdbusviewer/images/qdbusviewer-128.png qdbusviewer6.png
- fi
-
- # hack: make_destop_entry does not support overriding DESCRIPTION
- find "${ED}" -type f -name "*.desktop" \
- -exec sed -i "/^Comment=${DESCRIPTION}/d" -- {} + || die
- fi
-}
-
-pkg_postinst() {
- use assistant &&
- optfeature "Qt documentation viewable in assistant" \
- 'dev-qt/qt-docs:6[qch]' #602296
-}