summaryrefslogtreecommitdiff
path: root/dev-qt/qtsql/qtsql-5.15.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qtsql/qtsql-5.15.2.ebuild')
-rw-r--r--dev-qt/qtsql/qtsql-5.15.2.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-qt/qtsql/qtsql-5.15.2.ebuild b/dev-qt/qtsql/qtsql-5.15.2.ebuild
index 97938c24fdbf..c48f5e3479d6 100644
--- a/dev-qt/qtsql/qtsql-5.15.2.ebuild
+++ b/dev-qt/qtsql/qtsql-5.15.2.ebuild
@@ -2,10 +2,13 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
QT5_MODULE="qtbase"
inherit qt5-build
DESCRIPTION="SQL abstraction library for the Qt5 framework"
+SRC_URI+=" https://dev.gentoo.org/~asturm/distfiles/qtbase-${PV}-gcc11.patch.xz"
+
SLOT=5/$(ver_cut 1-3) # bug 639140
if [[ ${QT5_BUILD_TYPE} == release ]]; then
@@ -38,6 +41,8 @@ QT5_GENTOO_PRIVATE_CONFIG=(
:sql
)
+PATCHES=( "${WORKDIR}/qtbase-${PV}-gcc11.patch" ) # bug 752012
+
src_configure() {
local myconf=(
$(qt_use freetds sql-tds plugin)