summaryrefslogtreecommitdiff
path: root/dev-qt/qtspeech/qtspeech-5.15.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qtspeech/qtspeech-5.15.2-r1.ebuild')
-rw-r--r--dev-qt/qtspeech/qtspeech-5.15.2-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-qt/qtspeech/qtspeech-5.15.2-r1.ebuild b/dev-qt/qtspeech/qtspeech-5.15.2-r1.ebuild
new file mode 100644
index 000000000000..c2273fe433d1
--- /dev/null
+++ b/dev-qt/qtspeech/qtspeech-5.15.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt5-build
+
+DESCRIPTION="Text-to-speech library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+IUSE="alsa flite"
+
+RDEPEND="
+ >=app-accessibility/speech-dispatcher-0.8.7
+ ~dev-qt/qtcore-${PV}
+ flite? (
+ >=app-accessibility/flite-2[alsa?]
+ ~dev-qt/qtmultimedia-${PV}[alsa?]
+ alsa? ( media-libs/alsa-lib )
+ )
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ qt_use_disable_config flite flite \
+ src/plugins/tts/tts.pro
+
+ qt_use_disable_config alsa flite_alsa \
+ src/plugins/tts/flite/flite.pro
+
+ qt5-build_src_prepare
+}