summaryrefslogtreecommitdiff
path: root/dev-qt/qtopengl/qtopengl-5.15.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qtopengl/qtopengl-5.15.2-r1.ebuild')
-rw-r--r--dev-qt/qtopengl/qtopengl-5.15.2-r1.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-qt/qtopengl/qtopengl-5.15.2-r1.ebuild b/dev-qt/qtopengl/qtopengl-5.15.2-r1.ebuild
deleted file mode 100644
index 916bc3174710..000000000000
--- a/dev-qt/qtopengl/qtopengl-5.15.2-r1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-QT5_MODULE="qtbase"
-VIRTUALX_REQUIRED="test"
-inherit qt5-build
-
-DESCRIPTION="OpenGL support library for the Qt5 framework (deprecated)"
-SRC_URI+=" https://dev.gentoo.org/~asturm/distfiles/qtbase-${PV}-gcc11.patch.xz"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~riscv ~sparc x86"
-fi
-
-IUSE="gles2-only"
-
-DEPEND="
- ~dev-qt/qtcore-${PV}:5=
- ~dev-qt/qtgui-${PV}[gles2-only=]
- ~dev-qt/qtwidgets-${PV}[gles2-only=]
- !gles2-only? ( virtual/opengl )
-"
-RDEPEND="${DEPEND}"
-
-QT5_TARGET_SUBDIRS=(
- src/opengl
-)
-
-PATCHES=( "${WORKDIR}/qtbase-${PV}-gcc11.patch" ) # bug 752012
-
-src_configure() {
- local myconf=(
- -opengl $(usex gles2-only es2 desktop)
- )
- qt5-build_src_configure
-}