summaryrefslogtreecommitdiff
path: root/dev-qt/qthelp/qthelp-5.15.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qthelp/qthelp-5.15.5.ebuild')
-rw-r--r--dev-qt/qthelp/qthelp-5.15.5.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-qt/qthelp/qthelp-5.15.5.ebuild b/dev-qt/qthelp/qthelp-5.15.5.ebuild
new file mode 100644
index 000000000000..c4a559956981
--- /dev/null
+++ b/dev-qt/qthelp/qthelp-5.15.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+QT5_MODULE="qttools"
+inherit qt5-build
+
+DESCRIPTION="Qt5 module for integrating online documentation into applications"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+IUSE=""
+
+DEPEND="
+ =dev-qt/qtcore-${QT5_PV}*:5=
+ =dev-qt/qtgui-${QT5_PV}*
+ =dev-qt/qtsql-${QT5_PV}*[sqlite]
+ =dev-qt/qtwidgets-${QT5_PV}*
+"
+RDEPEND="${DEPEND}"
+
+# https://invent.kde.org/qt/qt/qttools/-/merge_requests/2
+PATCHES=( "${FILESDIR}/${PN}-5.15.4-bogusdep.patch" )
+
+QT5_TARGET_SUBDIRS=(
+ src/assistant/help
+ src/assistant/qcollectiongenerator
+ src/assistant/qhelpgenerator
+)