summaryrefslogtreecommitdiff
path: root/dev-qt/qthelp/qthelp-5.15.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qthelp/qthelp-5.15.3.ebuild')
-rw-r--r--dev-qt/qthelp/qthelp-5.15.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-qt/qthelp/qthelp-5.15.3.ebuild b/dev-qt/qthelp/qthelp-5.15.3.ebuild
new file mode 100644
index 000000000000..65aac11da704
--- /dev/null
+++ b/dev-qt/qthelp/qthelp-5.15.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+QT5_KDEPATCHSET_REV=1
+QT5_MODULE="qttools"
+inherit qt5-build
+
+DESCRIPTION="Qt5 module for integrating online documentation into applications"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+IUSE=""
+
+DEPEND="
+ =dev-qt/qtcore-${QT5_PV}*:5=
+ =dev-qt/qtgui-${QT5_PV}*
+ =dev-qt/qtsql-${QT5_PV}*[sqlite]
+ =dev-qt/qtwidgets-${QT5_PV}*
+"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/assistant/help
+ src/assistant/qcollectiongenerator
+ src/assistant/qhelpgenerator
+)