summaryrefslogtreecommitdiff
path: root/dev-qt/qtbase/qtbase-6.5.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qtbase/qtbase-6.5.9999.ebuild')
-rw-r--r--dev-qt/qtbase/qtbase-6.5.9999.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/dev-qt/qtbase/qtbase-6.5.9999.ebuild b/dev-qt/qtbase/qtbase-6.5.9999.ebuild
index c6249d69533c..9511c2c54404 100644
--- a/dev-qt/qtbase/qtbase-6.5.9999.ebuild
+++ b/dev-qt/qtbase/qtbase-6.5.9999.ebuild
@@ -130,6 +130,7 @@ PDEPEND="
"
PATCHES=(
+ "${FILESDIR}"/${PN}-6.5.2-hppa-forkfd-grow-stack.patch
"${FILESDIR}"/${PN}-6.5.2-no-symlink-check.patch
)
@@ -294,9 +295,13 @@ src_test() {
tst_qglyphrun
tst_qvectornd
tst_rcc
- # similarly, but on armv7 (bug #914028)
+ # similarly, but on armv7 and potentially others (bug #914028)
tst_qlineedit
tst_qpainter
+ # likewise, known failing at least on BE arches (bug #914033,914371)
+ tst_qimagereader
+ tst_qimagewriter
+ tst_qpluginloader
# partially broken on llvm-musl, needs looking into but skip to have
# a baseline for regressions (like above, rest of dev-qt is fine)
$(usev elibc_musl '
@@ -305,6 +310,11 @@ src_test() {
tst_qimagereader
tst_qimage
')
+ # fails due to hppa's NaN handling, needs looking into (bug #914371)
+ $(usev hppa '
+ tst_qcborvalue
+ tst_qnumeric
+ ')
# note: for linux, upstream only really runs+maintains tests for amd64
# https://doc.qt.io/qt-6/supported-platforms.html
)