summaryrefslogtreecommitdiff
path: root/dev-qt/qt-creator/qt-creator-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qt-creator/qt-creator-9999.ebuild')
-rw-r--r--dev-qt/qt-creator/qt-creator-9999.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/dev-qt/qt-creator/qt-creator-9999.ebuild b/dev-qt/qt-creator/qt-creator-9999.ebuild
index f28f40dcec29..b47f014ce15a 100644
--- a/dev-qt/qt-creator/qt-creator-9999.ebuild
+++ b/dev-qt/qt-creator/qt-creator-9999.ebuild
@@ -34,7 +34,7 @@ HOMEPAGE="https://www.qt.io/product/development-tools"
LICENSE="GPL-3"
SLOT="0"
IUSE="
- +clang designer doc +help plugin-dev qmldesigner
+ +clang designer doc +help keyring plugin-dev qmldesigner
serialterminal +svg test +tracing webengine
"
REQUIRED_USE="clang? ( ${LLVM_REQUIRED_USE} )"
@@ -45,7 +45,7 @@ QT_PV=6.2.0:6 # IDE_QT_VERSION_MIN
# := is used where Qt's private APIs are used for safety
COMMON_DEPEND="
>=dev-qt/qt5compat-${QT_PV}
- >=dev-qt/qtbase-${QT_PV}=[concurrent,gui,network,widgets,xml]
+ >=dev-qt/qtbase-${QT_PV}=[concurrent,dbus,gui,network,widgets,xml]
>=dev-qt/qtdeclarative-${QT_PV}=
clang? (
dev-cpp/yaml-cpp:=
@@ -56,6 +56,10 @@ COMMON_DEPEND="
>=dev-qt/qttools-${QT_PV}[assistant]
webengine? ( >=dev-qt/qtwebengine-${QT_PV} )
)
+ keyring? (
+ app-crypt/libsecret
+ dev-libs/glib:2
+ )
qmldesigner? (
>=dev-qt/qtquick3d-${QT_PV}=
>=dev-qt/qtsvg-${QT_PV}
@@ -78,7 +82,7 @@ DEPEND="${COMMON_DEPEND}"
BDEPEND="
${PYTHON_DEPS}
>=dev-qt/qttools-${QT_PV}[linguist]
- doc? ( >=dev-qt/qttools-${QT_PV}[qdoc] )
+ doc? ( >=dev-qt/qttools-${QT_PV}[qdoc,qtattributionsscanner] )
"
PATCHES=(
@@ -158,6 +162,10 @@ src_configure() {
# not packaged, but allow using if found
#-DCMAKE_DISABLE_FIND_PACKAGE_LibDDemangle=yes
#-DCMAKE_DISABLE_FIND_PACKAGE_LibRustcDemangle=yes
+
+ # for bundled qtkeychain (no switch to unbundle right now)
+ # reminder: if ever unbundled/optional, qtbase[dbus] can be removed
+ -DLIBSECRET_SUPPORT=$(usex keyring)
)
cmake_src_configure