summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin261696 -> 262183 bytes
-rw-r--r--dev-python/bottleneck/Manifest2
-rw-r--r--dev-python/bottleneck/bottleneck-1.3.5-r1.ebuild (renamed from dev-python/bottleneck/bottleneck-1.3.5.ebuild)7
-rw-r--r--dev-python/httpx-socks/Manifest3
-rw-r--r--dev-python/httpx-socks/httpx-socks-0.7.5.ebuild43
-rw-r--r--dev-python/httpx-socks/metadata.xml13
-rw-r--r--dev-python/hypercorn/Manifest4
-rw-r--r--dev-python/hypercorn/files/hypercorn-0.14.3-tomli.patch106
-rw-r--r--dev-python/hypercorn/hypercorn-0.14.3-r1.ebuild51
-rw-r--r--dev-python/hypercorn/metadata.xml13
-rw-r--r--dev-python/python-socks/Manifest2
-rw-r--r--dev-python/python-socks/python-socks-2.1.0.ebuild45
-rw-r--r--dev-python/starlette/Manifest4
-rw-r--r--dev-python/starlette/metadata.xml1
-rw-r--r--dev-python/starlette/starlette-0.23.1.ebuild2
-rw-r--r--dev-python/tiny-proxy/Manifest3
-rw-r--r--dev-python/tiny-proxy/metadata.xml13
-rw-r--r--dev-python/tiny-proxy/tiny-proxy-0.1.1.ebuild39
18 files changed, 347 insertions, 4 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index b97efa15fb39..87e693a18531 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/bottleneck/Manifest b/dev-python/bottleneck/Manifest
index e7415ffe3f06..d9508190b728 100644
--- a/dev-python/bottleneck/Manifest
+++ b/dev-python/bottleneck/Manifest
@@ -1,3 +1,3 @@
DIST bottleneck-1.3.5.gh.tar.gz 118989 BLAKE2B 5b9338a77cb3f0253348f45e641dca9fce11b50fb632e697272203870dd604730c08f1adc94ebf9c6c21f551e3f06b5492bcb036d6f40eaec8853d08ca298873 SHA512 9a0f224337fd9d5c741a1e469197be26923eaffb143eddfe0969128ddc233c799da6a5f2ba4ef22f6267cf93e7f748c140fbb16f57149ad327c47fe87ffc3346
-EBUILD bottleneck-1.3.5.ebuild 760 BLAKE2B a8b3242ccefd8ee88403581d830074475a685d59f82183a4a914353d7e26e48252c4f00d6b65069bccff0b6482c93f8a2cbe984fc4730b359dc9f1d59a9a694a SHA512 e1a58eb7d53b5256444e62cc7bb045874c06ccf89f508927d21f438e9e1535a32124f9754dd43ec15b534755b24421f99f2b32547c5621da5e3a75f9c234bf06
+EBUILD bottleneck-1.3.5-r1.ebuild 913 BLAKE2B d13c689ac380ff96e6c94ee2ab5070d10ca2bee6fc2b30bf77f593820002ffe09799b00d586e6f5f29df7c192149b3e3351e93cbaab25e3b085710a4d43534f4 SHA512 847e4572c1c473808adf2eb58ab1e7ed24c5ce40e414b533071ccd8f1c326cb9d7dcbe5b42ab47a4b7673bc925c075ba9de91c77aa40aa763b730f5251428030
MISC metadata.xml 519 BLAKE2B 5e5e712122fb0bbc898942cbae15c7cf623aa8462257f063f65a06bc9caae6662c373963f0945f99c5fffe01270e2792e8e5d01af93b49a04f5c3c22cd3a30f7 SHA512 55d2c03dedaa48c8f802d1e4d1d7db4e829fe7357b501c3b2955d28da501eae00675b2775ab36d1131cf2ef0a3d037183bde8df4c85e986d81510df4e234b0ae
diff --git a/dev-python/bottleneck/bottleneck-1.3.5.ebuild b/dev-python/bottleneck/bottleneck-1.3.5-r1.ebuild
index d1a52a75700d..9f919ab05ef5 100644
--- a/dev-python/bottleneck/bottleneck-1.3.5.ebuild
+++ b/dev-python/bottleneck/bottleneck-1.3.5-r1.ebuild
@@ -31,6 +31,13 @@ DEPEND="
distutils_enable_tests pytest
+src_prepare() {
+ # don't overwrites user's optimization level
+ sed -e '/extra_compile_args=\["-O2"\]/d' -i setup.py || die
+
+ distutils-r1_src_prepare
+}
+
python_test() {
cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
epytest
diff --git a/dev-python/httpx-socks/Manifest b/dev-python/httpx-socks/Manifest
new file mode 100644
index 000000000000..18e6c48fa78d
--- /dev/null
+++ b/dev-python/httpx-socks/Manifest
@@ -0,0 +1,3 @@
+DIST httpx-socks-0.7.5.gh.tar.gz 24847 BLAKE2B 9c119b756bf493df47a1bc9c36339508a2192d2bd4392113955fed6929d7c79654f17c069f9d952a11d8c95cf210cdf54af1bb59f47dc50b26b180f0915d3fe9 SHA512 df921af0c5fd0e8b4cb127cd13d5285ae57eb6ff9bc95f9422c02c79771ef55f345ef1618156fd0887467ed81cad2081ea9f2a56a03dc1d80948ed9eabe67aee
+EBUILD httpx-socks-0.7.5.ebuild 1101 BLAKE2B 71b5918b4d0a035e8f635ff6005423d5c293292f2311b5e63e7793af27f16e9f72ae553d741afa034857af6b0ae0a78f9d24bee72dd9b3c040f914d168271459 SHA512 97b537cfa1cc5ce7c3f463847048ad9de609776c515e1e9412af53a4b29dfde1da9e6012e9b237fd87d675495cd3fa390a1a8c64377e6f5542608d802d94bda3
+MISC metadata.xml 400 BLAKE2B b244ebd9f79b1c3313797b0384339d17df61913473cd26ab01c8490fe02cbe735609dbd2b2d76e7b1b7f716bbb3038590517481a05c1b7886ad49905f171f5e3 SHA512 3cb1600426cdc5b9ec3bd5d18b547dedb961bbc341891293f828e70d5156d845c8676ba25244804d32c702fab40134c39237e5ce4fc518104a969a8f8ffb282f
diff --git a/dev-python/httpx-socks/httpx-socks-0.7.5.ebuild b/dev-python/httpx-socks/httpx-socks-0.7.5.ebuild
new file mode 100644
index 000000000000..75a293c0fe07
--- /dev/null
+++ b/dev-python/httpx-socks/httpx-socks-0.7.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Proxy (HTTP, SOCKS) transports for httpx"
+HOMEPAGE="
+ https://github.com/romis2012/httpx-socks/
+ https://pypi.org/project/httpx-socks/
+"
+SRC_URI="
+ https://github.com/romis2012/httpx-socks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ <dev-python/httpx-0.24.0[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.21.0[${PYTHON_USEDEP}]
+ <dev-python/httpcore-0.17.0[${PYTHON_USEDEP}]
+ >=dev-python/httpcore-0.14.0[${PYTHON_USEDEP}]
+ >=dev-python/python-socks-2.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/hypercorn-0.12.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18.3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-trio-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/starlette-0.19.1[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.18.0[${PYTHON_USEDEP}]
+ >=dev-python/yarl-1.6.3[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/httpx-socks/metadata.xml b/dev-python/httpx-socks/metadata.xml
new file mode 100644
index 000000000000..649fc743ec3a
--- /dev/null
+++ b/dev-python/httpx-socks/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">httpx-socks</remote-id>
+ <remote-id type="github">romis2012/httpx-socks</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/hypercorn/Manifest b/dev-python/hypercorn/Manifest
new file mode 100644
index 000000000000..d9fccb12cd04
--- /dev/null
+++ b/dev-python/hypercorn/Manifest
@@ -0,0 +1,4 @@
+AUX hypercorn-0.14.3-tomli.patch 3342 BLAKE2B 67b5b491e7b5b70f41748688b03a0ed2860d6b9dec280634d77b3323610723fd9c709e6b08dc094a7c4fe30673cc9dd159010f7ec695e2bfcdd19509eb52fb34 SHA512 7b4b8599d054a32895866132b1318b3ccd7899d455e09cbd7d3b4bb5f7c340dd78b7dc25bd40507c5af42bc713c193fa7aa503733019a312c945188da9e93dbc
+DIST hypercorn-0.14.3.gh.tar.gz 154930 BLAKE2B da827d586307ace6ef9ddb8ca4046ebc5c745df1d48152ed78b948751a7d472c73d5f8310e58266158af4739e14f2960a46c2e7fc7f12bf7629a3edb3821b58f SHA512 f0d69ab1883379058112907547e6f89a4a7114d7f4851b92f0c465d73def9cc15508e3981bda7e66ce3c00e896f7fb221b3dcd8bee6a51d8429572b678b7ade8
+EBUILD hypercorn-0.14.3-r1.ebuild 1089 BLAKE2B bd3c59f5d8ae0b4f0a81adedd899c9d58f402243c3c075a932f0dc8d32b129d339d5997055aeb78746aca05d25db9ba98f8964752f2cf6789f4a48fd5edd65e2 SHA512 65ac0f41f96fe4f0e76319ddfefae183beb6e058193c8b0edde09bc9d97c49234e501177b9c2a3bcb0ef82a6d2da98c3c1f4932ff0d887c9a4f19a57a7c12937
+MISC metadata.xml 394 BLAKE2B ed2b00d93cd09682484b86b44f0e6cf0af2ebe7725c47afc5bdbc57b519b251fb0537c36d460ab4b427eeaddc4e61cd8970e3e91c3361279138171f838198fe8 SHA512 642d8e2b74e9ad6c79ee233589392202135328a37b04b29144aedd66f44a34bcdb36d38f5b7dee3c0e3ce2693f2b47cb86a9617d5c32ead5f3462ca1d047da0b
diff --git a/dev-python/hypercorn/files/hypercorn-0.14.3-tomli.patch b/dev-python/hypercorn/files/hypercorn-0.14.3-tomli.patch
new file mode 100644
index 000000000000..a438680423a9
--- /dev/null
+++ b/dev-python/hypercorn/files/hypercorn-0.14.3-tomli.patch
@@ -0,0 +1,106 @@
+From 676612c73d3c231f823f88ea0995e80522db6178 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Mon, 19 Dec 2022 15:27:41 +0100
+Subject: [PATCH] Use tomllib/tomli for .toml support
+
+Replace the unmaintained and non-conformant `toml` library with
+the built-in `tomllib` module in Python 3.11+, with fallback to `tomli`
+(featuring the same ABI) in Python 3.10 and older.
+---
+ pyproject.toml | 2 +-
+ src/hypercorn/config.py | 10 +++++++---
+ src/hypercorn/logging.py | 10 +++++++---
+ tox.ini | 1 -
+ 4 files changed, 15 insertions(+), 8 deletions(-)
+
+diff --git a/pyproject.toml b/pyproject.toml
+index 71ceaff..1334fcf 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -30,7 +30,7 @@ h11 = "*"
+ h2 = ">=3.1.0"
+ priority = "*"
+ pydata_sphinx_theme = { version = "*", optional = true }
+-toml = "*"
++tomli = { version = "*", python = "<3.11" }
+ trio = { version = ">=0.11.0", optional = true }
+ typing_extensions = { version = ">=3.7.4", python = "<3.8" }
+ uvloop = { version = "*", markers = "platform_system != 'Windows'", optional = true }
+diff --git a/src/hypercorn/config.py b/src/hypercorn/config.py
+index f9a9d66..ecfa1bd 100644
+--- a/src/hypercorn/config.py
++++ b/src/hypercorn/config.py
+@@ -6,6 +6,7 @@ import logging
+ import os
+ import socket
+ import stat
++import sys
+ import types
+ import warnings
+ from dataclasses import dataclass
+@@ -22,7 +23,10 @@ from time import time
+ from typing import Any, AnyStr, Dict, List, Mapping, Optional, Tuple, Type, Union
+ from wsgiref.handlers import format_date_time
+
+-import toml
++if sys.version_info >= (3, 11):
++ import tomllib
++else:
++ import tomli as tomllib
+
+ from .logging import Logger
+
+@@ -355,8 +359,8 @@ class Config:
+ filename: The filename which gives the path to the file.
+ """
+ file_path = os.fspath(filename)
+- with open(file_path) as file_:
+- data = toml.load(file_)
++ with open(file_path, "rb") as file_:
++ data = tomllib.load(file_)
+ return cls.from_mapping(data)
+
+ @classmethod
+diff --git a/src/hypercorn/logging.py b/src/hypercorn/logging.py
+index 3c2c657..8ca6105 100644
+--- a/src/hypercorn/logging.py
++++ b/src/hypercorn/logging.py
+@@ -9,7 +9,11 @@ from http import HTTPStatus
+ from logging.config import dictConfig, fileConfig
+ from typing import Any, IO, Mapping, Optional, TYPE_CHECKING, Union
+
+-import toml
++if sys.version_info >= (3, 11):
++ import tomllib
++else:
++ import tomli as tomllib
++
+
+ if TYPE_CHECKING:
+ from .config import Config
+@@ -65,8 +69,8 @@ class Logger:
+ with open(config.logconfig[5:]) as file_:
+ dictConfig(json.load(file_))
+ elif config.logconfig.startswith("toml:"):
+- with open(config.logconfig[5:]) as file_:
+- dictConfig(toml.load(file_))
++ with open(config.logconfig[5:], "rb") as file_:
++ dictConfig(tomllib.load(file_))
+ else:
+ log_config = {
+ "__file__": config.logconfig,
+diff --git a/tox.ini b/tox.ini
+index 675992b..0f636fb 100644
+--- a/tox.ini
++++ b/tox.ini
+@@ -47,7 +47,6 @@ basepython = python3.10
+ deps =
+ mypy
+ pytest
+- types-toml
+ commands =
+ mypy src/hypercorn/ tests/
+
+--
+2.39.0
+
diff --git a/dev-python/hypercorn/hypercorn-0.14.3-r1.ebuild b/dev-python/hypercorn/hypercorn-0.14.3-r1.ebuild
new file mode 100644
index 000000000000..7d1d7ee7f19e
--- /dev/null
+++ b/dev-python/hypercorn/hypercorn-0.14.3-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A ASGI Server based on Hyper libraries and inspired by Gunicorn"
+HOMEPAGE="
+ https://github.com/pgjones/hypercorn/
+ https://pypi.org/project/hypercorn/
+"
+SRC_URI="
+ https://github.com/pgjones/hypercorn/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/h11[${PYTHON_USEDEP}]
+ >=dev-python/h2-3.1.0[${PYTHON_USEDEP}]
+ dev-python/priority[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.{8..10})
+ >=dev-python/wsproto-0.14.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ local PATCHES=(
+ "${FILESDIR}"/${P}-tomli.patch
+ )
+
+ sed -i -e 's:--no-cov-on-fail::' pyproject.toml || die
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/hypercorn/metadata.xml b/dev-python/hypercorn/metadata.xml
new file mode 100644
index 000000000000..1d8855d3b9ff
--- /dev/null
+++ b/dev-python/hypercorn/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">hypercorn</remote-id>
+ <remote-id type="github">pgjones/hypercorn</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-socks/Manifest b/dev-python/python-socks/Manifest
index b1d3f060a98d..4fe591bc27fb 100644
--- a/dev-python/python-socks/Manifest
+++ b/dev-python/python-socks/Manifest
@@ -1,3 +1,5 @@
DIST python-socks-2.0.3.gh.tar.gz 40697 BLAKE2B c1e6f72763d1bd767af78ea1188e411814a6d41f703488dd67165d5a9b9ce1e2f9070b35a46cd72859b65c10519cdb02c91d1702a97c2d82cb5891b46187d02a SHA512 9d51e61d03b4a46e94a66fc037ac759715db2e2c5d631aaf6088a0363ad13140c00da44a513088a40c0f149b9d4ee2bb4165f59f76c3956f0aede8104772fc5d
+DIST python-socks-2.1.0.gh.tar.gz 31251 BLAKE2B b32b35c746066c10fa1e52677e42058e6196eb1c19cfc120a670e86daf8f920a4d6be3d1d92f984b68d635496da992b33f196277a1b22b254fe045988a15d2f1 SHA512 66da2da1d8103570e44d0a2ace03c24695b7319c562d7f96242c713b9d03ea693a2ece3cf6869cea686c330a9fb05aa35a443bad5a638d843b4fc7b24a8e6a82
EBUILD python-socks-2.0.3.ebuild 1177 BLAKE2B 7002fa042421d7e5c7b9304df69c8cdf33367865794d0451e69ce884681c44b5747a75d7c989c074c67a8d7fcbf0f67bdac5a7bf71af5d36021997515ee1f75d SHA512 a7dda1248c6fa29c4fadc83a170f57ea1d1fc3326ba7a6bb6fed26cbc74d62308bbb1092af439a5248eb88518b14d49b4d078a7ba415fff82e8412402f6fc6eb
+EBUILD python-socks-2.1.0.ebuild 1187 BLAKE2B 0bdc2c6bd34398eaad0528f3ba3b63eede179763f1dc8a9dd89cfac05b44e30190b70b266c12eaca74eb54a9a24b97f401335b931b036d06527d8e1c9520cbf1 SHA512 7900eb19699d291dbe34d5eaf40d46014e601ce8f99d57dd0a8f79687fb6b30731e1f91a8f40e8ef19027e23359605ac8ca67ce90c0bf83e55c064de785b515e
MISC metadata.xml 380 BLAKE2B 2209abdbafd26baae585840e774843c37e0c6103fa93d75e8c1ddbc8dd1b96f269a3e76f14c39a55294d4d642d7fbe9f87c6b1a0b64152c671590a9e0a6ef959 SHA512 ccbb1a5c9fd05ae1da346f4f92efe156921f7adf9f5544635a407ba4a8154c896bda2e445e05e70a8e46c2829b8d4a38d3bf5d73804a3641c811acd2be62099a
diff --git a/dev-python/python-socks/python-socks-2.1.0.ebuild b/dev-python/python-socks/python-socks-2.1.0.ebuild
new file mode 100644
index 000000000000..ead55902eb67
--- /dev/null
+++ b/dev-python/python-socks/python-socks-2.1.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="SOCKS4, SOCKS5, HTTP tunneling functionality for Python"
+HOMEPAGE="
+ https://github.com/romis2012/python-socks/
+ https://pypi.org/project/python-socks/
+"
+SRC_URI="
+ https://github.com/romis2012/python-socks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# curio is not packaged
+# asyncio is the only backend we have, so dep on its deps unconditionally
+# TODO: revisit
+RDEPEND="
+ dev-python/async-timeout[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/anyio-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/async-timeout-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/flask-1.1.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18.3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-trio-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/tiny-proxy-0.1.1[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.16.0[${PYTHON_USEDEP}]
+ >=dev-python/trustme-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/yarl-1.4.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/starlette/Manifest b/dev-python/starlette/Manifest
index 19029b38f878..27d9363741a4 100644
--- a/dev-python/starlette/Manifest
+++ b/dev-python/starlette/Manifest
@@ -4,5 +4,5 @@ DIST starlette-0.23.1.gh.tar.gz 2830865 BLAKE2B b1eaf59421d413179ad294b240babb9b
EBUILD starlette-0.21.0-r1.ebuild 1076 BLAKE2B 07737c708f018e5939835a4b79c0d1d0c9cf0d4c767fb4822d79f3e13431b14d51306482fff8cf93ca68fc26bbf459113e0deea96f2b9fd714e816235b4752f5 SHA512 812b6b1b721bbf7e042539e0cf5e84843b96747eda02bb8c1d391b324dd1fcf6ac9cfa6d1bbbd7c22388c2e3d3baf2aeaf88484ee0b45f51c5de005cd267e09f
EBUILD starlette-0.21.0.ebuild 1240 BLAKE2B 73a618cfc352aa36f8286914ad4eaf0f086f236e621685ad17fcf3db4510d9732100f113f8fc7739afe21c0d02f1feb33ed0c30297cc184f5f57cbce4863eb3a SHA512 716075254c375f33b18e0c66c4d6de84c0a5c278c1616ed971f3a9aa33731e6a42599cb0019a97afcfb3375577af89a308191dacf2ac48d95e71c043d65cedc8
EBUILD starlette-0.23.0.ebuild 1076 BLAKE2B 07737c708f018e5939835a4b79c0d1d0c9cf0d4c767fb4822d79f3e13431b14d51306482fff8cf93ca68fc26bbf459113e0deea96f2b9fd714e816235b4752f5 SHA512 812b6b1b721bbf7e042539e0cf5e84843b96747eda02bb8c1d391b324dd1fcf6ac9cfa6d1bbbd7c22388c2e3d3baf2aeaf88484ee0b45f51c5de005cd267e09f
-EBUILD starlette-0.23.1.ebuild 1076 BLAKE2B 07737c708f018e5939835a4b79c0d1d0c9cf0d4c767fb4822d79f3e13431b14d51306482fff8cf93ca68fc26bbf459113e0deea96f2b9fd714e816235b4752f5 SHA512 812b6b1b721bbf7e042539e0cf5e84843b96747eda02bb8c1d391b324dd1fcf6ac9cfa6d1bbbd7c22388c2e3d3baf2aeaf88484ee0b45f51c5de005cd267e09f
-MISC metadata.xml 324 BLAKE2B cbdb5983f2620f296eed8d81541e6ffbb084fdbcb698e52a6d86a64122834184e71ac423c21fa81d395be5505cb497be9172cd28d8fc633b6d31b844c480f741 SHA512 02c4d176ccc9c1b12e94f25c0de9792b6dc087a5d897bff8a46b2053951afad28b5c40f181ece8209acb3a8db1ec9e21a29af06b55f66efbc0d8f325d6958123
+EBUILD starlette-0.23.1.ebuild 1082 BLAKE2B a9f4b16abdd03d8128c1ba491a310b32fc308a6c83068409baf769b0347f7fee249136344cfe65ab8fd49e1671d519a90ef27df3d8fc5cdcafa62ffdd060ca45 SHA512 671221171315f0cb1b6cefd456f94b19fc61474e2a74d0a00dd31e6d56ed3edf8440060f3aa639eb5dc449cf1d43403ebac989dab30c5a24ba6ab89d33a5aae8
+MISC metadata.xml 371 BLAKE2B 0ccaa4659e63162b565359a1cae05764bea66d708a5f4af1a4716ba9ba23faa39ab4f5a806c0a9783f3f42282ee9b98e22a92f2b308b8dfe97bbf9c770a8add1 SHA512 0fc326941861260becd4129c8a351e89ba0f98f9a3ce9b5d50812f0eaf667743ab0d403889aa1b0a2d9fcedbe0212ba879d165ec8edd115686d4768e6b1326ca
diff --git a/dev-python/starlette/metadata.xml b/dev-python/starlette/metadata.xml
index 55eaddf99b38..5673753cc718 100644
--- a/dev-python/starlette/metadata.xml
+++ b/dev-python/starlette/metadata.xml
@@ -7,5 +7,6 @@
<stabilize-allarches/>
<upstream>
<remote-id type="github">encode/starlette</remote-id>
+ <remote-id type="pypi">starlette</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/starlette/starlette-0.23.1.ebuild b/dev-python/starlette/starlette-0.23.1.ebuild
index ca1a5dd0fabe..6c1a85931160 100644
--- a/dev-python/starlette/starlette-0.23.1.ebuild
+++ b/dev-python/starlette/starlette-0.23.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
inherit distutils-r1
diff --git a/dev-python/tiny-proxy/Manifest b/dev-python/tiny-proxy/Manifest
new file mode 100644
index 000000000000..ff280c672ef7
--- /dev/null
+++ b/dev-python/tiny-proxy/Manifest
@@ -0,0 +1,3 @@
+DIST tiny-proxy-0.1.1.gh.tar.gz 14940 BLAKE2B eba17082bf832127c36468db37d9214e45d236c9c1fa7e357e05269df8671f4a06992e03224147642221220aeb89d91479332038e09bf1aa22ce1f0c0316ff20 SHA512 aaf677d18058e6c7c1133398e03d7b0d8b9b4e500fc89174bb3dda1145eb0382492b227f892f672d7a558a30f1d4b92b20eef62922e0e6983f93fcd17850d825
+EBUILD tiny-proxy-0.1.1.ebuild 916 BLAKE2B c6f35882f880a51e352c59f7e20e9b66c2661eda4720799d915be162ebf12711305b20426ab105b7700cf4d5fe2fe9f273714b5ad24f30a5ae6535a64f3bf046 SHA512 9a1de7aba3bae1c3a5e58de049b89ada672593699dceabef57cd45420c3798133a8f02876fb7b3e54558997607bce061f2b61430e2cef230659938399af20b59
+MISC metadata.xml 398 BLAKE2B 0a9e806f68be7be9aba302538ed91e6e1079fad058c5759377f6ee7f044ca30ccc166ba17f885b94812e202e722f20fc71a3bb7a7a53f2e56753c93f9751f80d SHA512 02fc556e42d27fc680260bd185794d90b7c94378e325f4e136fad00f4fb83ac7b33b3bc68d3d9d13b669346f006e84d7c0be429880a603c8e4238e9f0b973e4f
diff --git a/dev-python/tiny-proxy/metadata.xml b/dev-python/tiny-proxy/metadata.xml
new file mode 100644
index 000000000000..8d3bfbf924c7
--- /dev/null
+++ b/dev-python/tiny-proxy/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">tiny-proxy</remote-id>
+ <remote-id type="github">romis2012/tiny-proxy</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/tiny-proxy/tiny-proxy-0.1.1.ebuild b/dev-python/tiny-proxy/tiny-proxy-0.1.1.ebuild
new file mode 100644
index 000000000000..ffc6171b0572
--- /dev/null
+++ b/dev-python/tiny-proxy/tiny-proxy-0.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple proxy server (SOCKS4(a), SOCKS5(h), HTTP tunnel)"
+HOMEPAGE="
+ https://github.com/romis2012/tiny-proxy/
+ https://pypi.org/project/tiny-proxy/
+"
+SRC_URI="
+ https://github.com/romis2012/tiny-proxy/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ <dev-python/anyio-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/anyio-3.6.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/aiohttp-3.8.1[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.23.0[${PYTHON_USEDEP}]
+ >=dev-python/httpx-socks-0.7.4[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18.3[${PYTHON_USEDEP}]
+ >=dev-python/trustme-0.9.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest