summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin262781 -> 263281 bytes
-rw-r--r--dev-python/sphinx-argparse/Manifest3
-rw-r--r--dev-python/sphinx-argparse/metadata.xml12
-rw-r--r--dev-python/sphinx-argparse/sphinx-argparse-0.4.0.ebuild22
-rw-r--r--dev-python/sphinx-copybutton/Manifest3
-rw-r--r--dev-python/sphinx-copybutton/metadata.xml15
-rw-r--r--dev-python/sphinx-copybutton/sphinx-copybutton-0.5.2.ebuild22
-rw-r--r--dev-python/sphinx-inline-tabs/Manifest3
-rw-r--r--dev-python/sphinx-inline-tabs/metadata.xml15
-rw-r--r--dev-python/sphinx-inline-tabs/sphinx-inline-tabs-2023.4.21.ebuild21
-rw-r--r--dev-python/sphinxcontrib-autoprogram/Manifest2
-rw-r--r--dev-python/sphinxcontrib-autoprogram/sphinxcontrib-autoprogram-0.1.8.ebuild2
12 files changed, 118 insertions, 2 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index 5b2291e87733..1dfafa1f182c 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/sphinx-argparse/Manifest b/dev-python/sphinx-argparse/Manifest
new file mode 100644
index 000000000000..c14c0e736c12
--- /dev/null
+++ b/dev-python/sphinx-argparse/Manifest
@@ -0,0 +1,3 @@
+DIST sphinx_argparse-0.4.0.tar.gz 15020 BLAKE2B 73118f56ff82d52f04066b9d500aebc77eb5a0fecd03fa69f382c0f2afc0cbffdd395da707cf37b59f039e93935f8d5c3fe0e0f7a2820d3b6509dd78b37b0d74 SHA512 b96050da6c02f87c54f9dc9146bed955e99258df740b467575a2b3e9919fa8c4c6d30a736dab24360086bfc0d7d09c4bc7a818700af2c7846eed3a3b99053d65
+EBUILD sphinx-argparse-0.4.0.ebuild 522 BLAKE2B ad95ac27322b1696efbb3f7738cea5013aa2b560293def077db8001d3302cd38fa4c87222cfc17a66243f63b5957c06f70c3cc523ef8709a533b5cc143d10f8e SHA512 a3f52e076a33980a487abdec13e9a1c82bfc2b9d328bc5c553a0191c5e5f18b68b6f089e4793565bfe72ee31f0ad0c4c515a6e794f2572bbc36d8511061bc18c
+MISC metadata.xml 391 BLAKE2B 972912b11d5fe4f5a7853047a53f1eb1520593df0c80a32d56a332814329994ac931bd7afc03917ad914b31a26ae5c0545ae7b4528afa9d43a3c7ef9a7fab083 SHA512 9b969ffd5114c71e2d7a6c42e234a5346f5c3778bb33f5ee7c0abb3a79c97efde003c54e2c8c49091d765bd79fc903cd02ce34fef85ebfa68c77c8344b38e6e4
diff --git a/dev-python/sphinx-argparse/metadata.xml b/dev-python/sphinx-argparse/metadata.xml
new file mode 100644
index 000000000000..34557e466493
--- /dev/null
+++ b/dev-python/sphinx-argparse/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ashb/sphinx-argparse</remote-id>
+ <remote-id type="pypi">sphinx-argparse</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinx-argparse/sphinx-argparse-0.4.0.ebuild b/dev-python/sphinx-argparse/sphinx-argparse-0.4.0.ebuild
new file mode 100644
index 000000000000..2b28e7ab59e5
--- /dev/null
+++ b/dev-python/sphinx-argparse/sphinx-argparse-0.4.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=poetry
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension that automatically documents argparse commands and options"
+HOMEPAGE="https://pypi.org/project/sphinx-argparse/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/commonmark[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/sphinx-copybutton/Manifest b/dev-python/sphinx-copybutton/Manifest
new file mode 100644
index 000000000000..019d22ad58ed
--- /dev/null
+++ b/dev-python/sphinx-copybutton/Manifest
@@ -0,0 +1,3 @@
+DIST sphinx-copybutton-0.5.2.tar.gz 23039 BLAKE2B 5a440865610dbcfc8abc8a10c38832439d5f588a26a8641374cada3cc181a0ba2a19e62b287a296c1879f25342ce8aae1ade080126f837e5ad9291c152a30c6e SHA512 83f61526d8a20f70b0de63a5bad89ed4ae4f3cf5cd589f1a1e2e91f08f4d45a05acf780a4cf3703d4490ab93c9c9bb18c11d3170b8011c2254aab0334940ab2d
+EBUILD sphinx-copybutton-0.5.2.ebuild 502 BLAKE2B dc432e7a9bb7e158373e821b69322b038783ed07eb564b8cb77066593ebbd19c91dbe56f273dc1f3e8b42037135bc29d07c2317072af249b0d04c80048810e71 SHA512 a208190a6199fb6606a89dad6763da6acf75eea1bf226d1bb705610435689164ac5ed86c5eccb4d8b75804c632ac24e63c95dde170977fa87a24f87c1e92ebff
+MISC metadata.xml 561 BLAKE2B 9b79bc70ff34e5be3453d71f1d9547f2c83096e9d7a32eb2dcf38d9868d766a7f7bceb6df1f28a6ac375a47ec2c7ff98008a99ef5233e85bcc3199f48f607e9a SHA512 3b1d64928d68a420b99470ecddcaaf3b36d8ddf3009d44e0580a15937c126e275938a5835d2900e2d30101034a2b2ba0fb1bb58cbda68fcf3cb84aaf36d50b25
diff --git a/dev-python/sphinx-copybutton/metadata.xml b/dev-python/sphinx-copybutton/metadata.xml
new file mode 100644
index 000000000000..343dee9179fb
--- /dev/null
+++ b/dev-python/sphinx-copybutton/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alexxy@gentoo.org</email>
+ <name>Alexey Shvetsov</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">executablebooks/sphinx-copybutton</remote-id>
+ <remote-id type="pypi">sphinx-copybutton</remote-id>
+ <doc>https://sphinx-copybutton.readthedocs.io</doc>
+ <bugs-to>https://github.com/executablebooks/sphinx-copybutton/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinx-copybutton/sphinx-copybutton-0.5.2.ebuild b/dev-python/sphinx-copybutton/sphinx-copybutton-0.5.2.ebuild
new file mode 100644
index 000000000000..297c59d28f0d
--- /dev/null
+++ b/dev-python/sphinx-copybutton/sphinx-copybutton-0.5.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYPI_NO_NORMALIZE=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A small sphinx extension to add a \"copy\" button to code blocks"
+HOMEPAGE="https://pypi.org/project/sphinx-copybutton/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/sphinx-6.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/sphinx-inline-tabs/Manifest b/dev-python/sphinx-inline-tabs/Manifest
new file mode 100644
index 000000000000..54ec767b7a9e
--- /dev/null
+++ b/dev-python/sphinx-inline-tabs/Manifest
@@ -0,0 +1,3 @@
+DIST sphinx_inline_tabs-2023.4.21.tar.gz 42664 BLAKE2B e7f00bb220a194d6aad2285af793b540233d3a4122c82c34c28d03e62fa463252dff7624470f3abf4e5cd9028c9abfabc0b663fc56acee809bcd10d1bc886038 SHA512 d5c856821ca3d2b251733fe200465679dc875d66719851f89b6e38fd1898e40a2bbc97975b6bbdb7bf769fb67038bbb8dd94282504adb0977c57e8d1cf3fde5c
+EBUILD sphinx-inline-tabs-2023.4.21.ebuild 447 BLAKE2B dfac877983852162bc0d92fa616b4452a4b2a159c4c21dcd3798e147dca2c00be19fae40a1bbe02391c4f55346b43baab609bde726b453abca5cdc67f11524c2 SHA512 1d4d705d29deac4f12ccee2273f3cadb54d790f74579a0692f253fc6e47a88acae00c22729f3e8ef5bcfa40d09c9b645e53c42e84b66bdd3702dc6d8e5b4fd6b
+MISC metadata.xml 553 BLAKE2B 3ce0da208e9abb45c8ef8be913c3f9253de38a71accacfc0edf9e01b94b2d2bf4a8979ce2613b4f756f749d5b28cc0c3de6fafe7fc42d778a4d617c23cb39192 SHA512 2b0fa9391c56137c743d5fe4cf4bffb98ea7a6ae526f4afecda82180aeafc49c21e6edbd3630bb1c4094e115720e54c79059945b525633cbde34fddc268b42f0
diff --git a/dev-python/sphinx-inline-tabs/metadata.xml b/dev-python/sphinx-inline-tabs/metadata.xml
new file mode 100644
index 000000000000..aac31acf568d
--- /dev/null
+++ b/dev-python/sphinx-inline-tabs/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alexxy@gentoo.org</email>
+ <name>Alexey Shvetsov</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">pradyunsg/sphinx-inline-tabs</remote-id>
+ <remote-id type="pypi">sphinx-inline-tabs</remote-id>
+ <doc>https://sphinx-inline-tabs.readthedocs.io</doc>
+ <bugs-to>https://github.com/pradyunsg/sphinx-inline-tabs/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinx-inline-tabs/sphinx-inline-tabs-2023.4.21.ebuild b/dev-python/sphinx-inline-tabs/sphinx-inline-tabs-2023.4.21.ebuild
new file mode 100644
index 000000000000..ad6169c8bad4
--- /dev/null
+++ b/dev-python/sphinx-inline-tabs/sphinx-inline-tabs-2023.4.21.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A sphinx extension for inline tabs"
+HOMEPAGE="https://pypi.org/project/sphinx-inline-tabs/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/sphinx-6.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/sphinxcontrib-autoprogram/Manifest b/dev-python/sphinxcontrib-autoprogram/Manifest
index 8098e37b07ac..e9ebd68641c3 100644
--- a/dev-python/sphinxcontrib-autoprogram/Manifest
+++ b/dev-python/sphinxcontrib-autoprogram/Manifest
@@ -1,3 +1,3 @@
DIST sphinxcontrib-autoprogram-0.1.8.tar.gz 18656 BLAKE2B a1334b0d9717f59ffb67c8a60e03b34c1fb0168cc86500ee14c06c44bef5bec1b484997d00be6586832e21e8a97662628636766558af9f79d40eb3da0ae21122 SHA512 a73d52a6195e3b637758b36f86afe07090bab09a655a86dbde3fefaee59f634c3fc880d436c3b14d9d7d4fb58f74765bd13457d0fc9192f1ffd4d654dc6efcd5
-EBUILD sphinxcontrib-autoprogram-0.1.8.ebuild 615 BLAKE2B eb7278b1fe25b318c9c243b21c5ccf49cfb093a616960b2a3390cb2be5fc511f6923a7e5a37455bb3821b656193914f3000bbc2fc4eb67c2a5875ee8b528a374 SHA512 424e6640d7b9c3a50423ca88b75893385730ae48a8765da9c411ac8ed34f88be726a28024c69cf7c7ac9d718442bfb5e4f3b7a2826dd0402a94fdc8f5aa950ef
+EBUILD sphinxcontrib-autoprogram-0.1.8.ebuild 622 BLAKE2B 6c2fdcae77b0518f02dfceb82ffa57f3780977081e83aa4025fc5b611e287abb25d437b781ff2668d07e27cf32038c95d850d69988785dbb350941aeb0024de4 SHA512 9466c0baa63385d2be71d946bea4a357d4d36bfd653a7ee550b337d1c50d37bb6b2ef0713be9ce12920b19fe9ec6869468fcb97442ae895f0d8499a1d3174d98
MISC metadata.xml 437 BLAKE2B 9e39af7803966fa76096217ad37df0ce8ff795bbfad2a20a0bc58485d4292626f7ad334c0e2918993f3c6a03a791c8f7ea7e4a3e68e75fd8bab3c5b4a7a00bd8 SHA512 7a3a8412639455ff004479bc6862312fdf17cde00905c4fc7a2eab839b6a26ad09facc879519b024d33d04ac62c16ed60e35719e89a7a75f3452ad55c0dc0dc5
diff --git a/dev-python/sphinxcontrib-autoprogram/sphinxcontrib-autoprogram-0.1.8.ebuild b/dev-python/sphinxcontrib-autoprogram/sphinxcontrib-autoprogram-0.1.8.ebuild
index db8164e96833..115a4f879a5d 100644
--- a/dev-python/sphinxcontrib-autoprogram/sphinxcontrib-autoprogram-0.1.8.ebuild
+++ b/dev-python/sphinxcontrib-autoprogram/sphinxcontrib-autoprogram-0.1.8.ebuild
@@ -17,7 +17,7 @@ HOMEPAGE="
LICENSE="BSD-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~arm64 ~x86"
RDEPEND="
dev-python/sphinx[${PYTHON_USEDEP}]