summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin260930 -> 260932 bytes
-rw-r--r--dev-python/greenlet/Manifest1
-rw-r--r--dev-python/greenlet/files/greenlet-1.1.2-fix-py3.11.patch223
-rw-r--r--dev-python/mkdocs-material/Manifest2
-rw-r--r--dev-python/mkdocs-material/mkdocs-material-8.5.4.ebuild2
-rw-r--r--dev-python/nautilus-python/Manifest2
-rw-r--r--dev-python/nautilus-python/nautilus-python-4.0.ebuild51
-rw-r--r--dev-python/reportlab/Manifest1
-rw-r--r--dev-python/reportlab/files/reportlab-3.5.48-usr-lib-LLD.patch34
9 files changed, 55 insertions, 261 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index 2dbb018a1cea..a15b29e9b9cc 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/greenlet/Manifest b/dev-python/greenlet/Manifest
index 790355709bd5..d7d68eb7ace6 100644
--- a/dev-python/greenlet/Manifest
+++ b/dev-python/greenlet/Manifest
@@ -1,4 +1,3 @@
-AUX greenlet-1.1.2-fix-py3.11.patch 7811 BLAKE2B 96312cf875837e5873e7eb56e6b499250fc97afc8851bcc83a2b6151af91761c9bd680428b4ca1dfa849c3fe9749013e59c5e2993109e89576bd2cff97496c3a SHA512 679313c0f43219782842eec3162124dddadbf422ca9cfac7249961cbb650e96c1ccb1c3a113ad9df08e1a3eb1f109d6efdb9efddd575c37152b7f6c82c73ae80
DIST greenlet-1.1.3.tar.gz 91624 BLAKE2B 88ba03f7a5acc7de2ab757a04667de9774ec8979b0f3d45131f8174a4ea9a608e359e4d8ce2f7e57c58ce4844e58a082d35d983fd583fc6f53ffa38363fb7863 SHA512 9ece4a4e758de963c96c7cbd33aec33fa11ddd3d46b8dc4194e14d534f8f68787df551cb1e3be57fc8a65fbd8d5daf8fee59567927f6f272535dd7c720baa4f4
EBUILD greenlet-1.1.3.ebuild 747 BLAKE2B f64d2e21bc30913380aeaf4535952500bf7dfc6bd1a0af51ac9333275815a478340a7bd540cadd089f382aaafb13b1fcbb4a8e0a018363283084824fd8235d17 SHA512 f70b927579576a915dba885d9c41bd45bdfada37c253bc0d90ddeba7c038a973c3b663719314930187cf0bc13189900dcd204877412f907499117684361395d9
MISC metadata.xml 322 BLAKE2B 57f3f966edd48a761d9ff80514dcd8e2439eb83fd79c1df2dd6610b9c03366a70be02134b6fa3e2d06ceeaafc1e5ed594efbcbcaea015043ff7bfdf54bd52e53 SHA512 2e119f8948096d416c6aa1db1203a37820a353dfe704f596243f805b5a6892498bb82a59b1fe59a51a1086d1b24c79a90de265bd06170e3b1bbd836bdee1915d
diff --git a/dev-python/greenlet/files/greenlet-1.1.2-fix-py3.11.patch b/dev-python/greenlet/files/greenlet-1.1.2-fix-py3.11.patch
deleted file mode 100644
index 475fcd82fb34..000000000000
--- a/dev-python/greenlet/files/greenlet-1.1.2-fix-py3.11.patch
+++ /dev/null
@@ -1,223 +0,0 @@
-From: Victor Stinner <vstinner@python.org>
-Subject: [PATCH] Closes #305: Add Python 3.11 support
-
-* Add GREENLET_PY311 macro
-* PyGreenlet structure:
-
- * Add 3 members for the "data stack": 'datastack_chunk',
- 'datastack_top' and 'datastack_limit'.
- * Add 'current_frame' member.
-
-* Rename CFrame to _PyCFrame
-* tox.ini: Add py311 environment.
-
-Changes partially backport from the master branch:
-commit 63e1099acc3677e614532bea0fa2e1967b69125f.
-
-Co-Authored-By: Miro HronĨok <miro@hroncok.cz>
-
-https://github.com/python-greenlet/greenlet/pull/306
---- a/src/greenlet/greenlet.c
-+++ b/src/greenlet/greenlet.c
-@@ -170,9 +170,11 @@ green_clear_exc(PyGreenlet* g)
- {
- #if GREENLET_PY37
- g->exc_info = NULL;
-- g->exc_state.exc_type = NULL;
- g->exc_state.exc_value = NULL;
-+#if !GREENLET_PY311
-+ g->exc_state.exc_type = NULL;
- g->exc_state.exc_traceback = NULL;
-+#endif
- g->exc_state.previous_item = NULL;
- #else
- g->exc_type = NULL;
-@@ -525,8 +527,13 @@ g_switchstack(void)
- { /* save state */
- PyGreenlet* current = ts_current;
- PyThreadState* tstate = PyThreadState_GET();
-+#if GREENLET_PY311
-+ current->recursion_depth = (tstate->recursion_limit
-+ - tstate->recursion_remaining);
-+#else
- current->recursion_depth = tstate->recursion_depth;
- current->top_frame = tstate->frame;
-+#endif
- #if GREENLET_PY37
- current->context = tstate->context;
- #endif
-@@ -551,6 +558,15 @@ g_switchstack(void)
- */
- current->cframe = tstate->cframe;
- ts__g_switchstack_use_tracing = tstate->cframe->use_tracing;
-+#if GREENLET_PY311
-+ current->current_frame = tstate->cframe->current_frame;
-+ current->datastack_chunk = tstate->datastack_chunk;
-+ current->datastack_top = tstate->datastack_top;
-+ current->datastack_limit = tstate->datastack_limit;
-+ PyFrameObject *frame = PyThreadState_GetFrame(tstate);
-+ Py_XDECREF(frame); /* PyThreadState_GetFrame gives us a new reference. */
-+ current->top_frame = frame;
-+#endif
- #endif
- }
-
-@@ -574,9 +590,6 @@ g_switchstack(void)
- PyGreenlet* target = ts_target;
- PyGreenlet* origin = ts_current;
- PyThreadState* tstate = PyThreadState_GET();
-- tstate->recursion_depth = target->recursion_depth;
-- tstate->frame = target->top_frame;
-- target->top_frame = NULL;
-
- #if GREENLET_PY37
- tstate->context = target->context;
-@@ -607,7 +620,18 @@ g_switchstack(void)
- */
- tstate->cframe->use_tracing = ts__g_switchstack_use_tracing;
- #endif
--
-+#if GREENLET_PY311
-+ tstate->recursion_remaining = (tstate->recursion_limit
-+ - target->recursion_depth);
-+ tstate->cframe->current_frame = target->current_frame;
-+ tstate->datastack_chunk = target->datastack_chunk;
-+ tstate->datastack_top = target->datastack_top;
-+ tstate->datastack_limit = target->datastack_limit;
-+#else
-+ tstate->recursion_depth = target->recursion_depth;
-+ tstate->frame = target->top_frame;
-+#endif
-+ target->top_frame = NULL;
- assert(ts_origin == NULL);
- Py_INCREF(target);
- ts_current = target;
-@@ -810,7 +834,7 @@ static int GREENLET_NOINLINE(g_initialstub)(void* mark)
- We want to defer copying the state info until we're sure
- we need it and are in a stable place to do so.
- */
-- CFrame trace_info;
-+ _PyCFrame trace_info;
- #endif
- /* save exception in case getattr clears it */
- PyErr_Fetch(&exc, &val, &tb);
-@@ -875,7 +899,12 @@ static int GREENLET_NOINLINE(g_initialstub)(void* mark)
- }
- self->top_frame = NULL;
- green_clear_exc(self);
-+#if GREENLET_PY311
-+ self->recursion_depth = (PyThreadState_GET()->recursion_limit
-+ - PyThreadState_GET()->recursion_remaining);
-+#else
- self->recursion_depth = PyThreadState_GET()->recursion_depth;
-+#endif
-
- /* restore arguments in case they are clobbered */
- ts_target = self;
-@@ -1006,13 +1035,13 @@ green_new(PyTypeObject* type, PyObject* args, PyObject* kwds)
- it uses the ``root_cframe`` just to have something to put there.
- However, once the greenlet is actually switched to for the first
- time, ``g_initialstub`` (which doesn't actually "return" while the
-- greenlet is running) stores a new CFrame on its local stack, and
-+ greenlet is running) stores a new _PyCFrame on its local stack, and
- copies the appropriate values from the currently running CFrame;
-- this is then made the CFrame for the newly-minted greenlet.
-+ this is then made the _PyCFrame for the newly-minted greenlet.
- ``g_initialstub`` then proceeds to call ``glet.run()``, which
-- results in ``PyEval_...`` adding the CFrame to the list. Switches
-+ results in ``PyEval_...`` adding the _PyCFrame to the list. Switches
- continue as normal. Finally, when the greenlet finishes, the call to
-- ``glet.run()`` returns and the CFrame is taken out of the linked
-+ ``glet.run()`` returns and the _PyCFrame is taken out of the linked
- list and the stack value is now unused and free to expire.
- */
- ((PyGreenlet*)o)->cframe = &PyThreadState_GET()->root_cframe;
-@@ -1121,9 +1150,11 @@ green_traverse(PyGreenlet* self, visitproc visit, void* arg)
- Py_VISIT(self->context);
- #endif
- #if GREENLET_PY37
-- Py_VISIT(self->exc_state.exc_type);
- Py_VISIT(self->exc_state.exc_value);
-+#if !GREENLET_PY311
-+ Py_VISIT(self->exc_state.exc_type);
- Py_VISIT(self->exc_state.exc_traceback);
-+#endif
- #else
- Py_VISIT(self->exc_type);
- Py_VISIT(self->exc_value);
-@@ -1159,9 +1190,11 @@ green_clear(PyGreenlet* self)
- Py_CLEAR(self->context);
- #endif
- #if GREENLET_PY37
-- Py_CLEAR(self->exc_state.exc_type);
- Py_CLEAR(self->exc_state.exc_value);
-+#if !GREENLET_PY311
-+ Py_CLEAR(self->exc_state.exc_type);
- Py_CLEAR(self->exc_state.exc_traceback);
-+#endif
- #else
- Py_CLEAR(self->exc_type);
- Py_CLEAR(self->exc_value);
-@@ -1253,9 +1286,11 @@ green_dealloc(PyGreenlet* self)
- Py_CLEAR(self->context);
- #endif
- #if GREENLET_PY37
-- Py_CLEAR(self->exc_state.exc_type);
- Py_CLEAR(self->exc_state.exc_value);
-+#if !GREENLET_PY311
-+ Py_CLEAR(self->exc_state.exc_type);
- Py_CLEAR(self->exc_state.exc_traceback);
-+#endif
- #else
- Py_CLEAR(self->exc_type);
- Py_CLEAR(self->exc_value);
---- a/src/greenlet/greenlet.h
-+++ b/src/greenlet/greenlet.h
-@@ -14,6 +14,15 @@ extern "C" {
- /* This is deprecated and undocumented. It does not change. */
- #define GREENLET_VERSION "1.0.0"
-
-+#if PY_VERSION_HEX >= 0x30B00A6
-+# define GREENLET_PY311 1
-+ /* _PyInterpreterFrame moved to the internal C API in Python 3.11 */
-+# include <internal/pycore_frame.h>
-+#else
-+# define GREENLET_PY311 0
-+# define _PyCFrame CFrame
-+#endif
-+
- typedef struct _greenlet {
- PyObject_HEAD
- char* stack_start;
-@@ -25,6 +34,12 @@ typedef struct _greenlet {
- PyObject* run_info;
- struct _frame* top_frame;
- int recursion_depth;
-+#if GREENLET_PY311
-+ _PyInterpreterFrame *current_frame;
-+ _PyStackChunk *datastack_chunk;
-+ PyObject **datastack_top;
-+ PyObject **datastack_limit;
-+#endif
- PyObject* weakreflist;
- #if PY_VERSION_HEX >= 0x030700A3
- _PyErr_StackItem* exc_info;
-@@ -39,7 +54,7 @@ typedef struct _greenlet {
- PyObject* context;
- #endif
- #if PY_VERSION_HEX >= 0x30A00B1
-- CFrame* cframe;
-+ _PyCFrame* cframe;
- #endif
- } PyGreenlet;
-
---- a/tox.ini
-+++ b/tox.ini
-@@ -1,6 +1,6 @@
- [tox]
- envlist =
-- py27,py35,py36,py37,py38,py39,py310,docs
-+ py27,py35,py36,py37,py38,py39,py310,py311,docs
-
- [testenv]
- commands =
diff --git a/dev-python/mkdocs-material/Manifest b/dev-python/mkdocs-material/Manifest
index 89cfde6be711..8052eb668eb8 100644
--- a/dev-python/mkdocs-material/Manifest
+++ b/dev-python/mkdocs-material/Manifest
@@ -5,5 +5,5 @@ DIST mkdocs-material-8.5.4.gh.tar.gz 10348088 BLAKE2B fbccb523f79b3dc3ed43641e5a
EBUILD mkdocs-material-8.4.0.ebuild 1044 BLAKE2B bae6282cd8a771c6c6d9f11205442841ba82f970b1a0ce8490902931670a45fa0ff1b8ba08d2d4c9b819ab43a668b9acbbc4f84aa7c35f854519cd609b2472f8 SHA512 7aaf4b2f7e3f75e579300424d9d8c2418c96a96ca61c085b53ae15f152abbe142dbf13924b24d36eddf1321f6de1dc6d3d5a018e19612b2245cd860eb03818c6
EBUILD mkdocs-material-8.4.3.ebuild 1046 BLAKE2B a1354ffb639fa1d967358867a01440e15f966ad4884c761e48ba14eb08a874ba1ec3bf1df1eeb1d214d16aae5b089cfc5254dbb4817b32a34b432d03a2eeebe8 SHA512 e3d4630057818c974fee925e51e8f38bc39cf5d86aa989158f97d024ac4e0c0cd4daeaa57242edf20429d9a6bea02a0019fcfa68b60c36d85f461c781fe3a54a
EBUILD mkdocs-material-8.5.2.ebuild 1045 BLAKE2B f973f72b347a875d6fe5e90915e7749217957554a6edbaee65ec27290db1de9b3631a6efd3ea5fa09680edede53351241fe33de203568cca45cd8d835dcce955 SHA512 bc18c7d13133c5a0c57475c90e97840cbd8d9ce3b067e29df10bed31da00b39b71f25caf7602e07316117d6c7dfacbda3a6216a027cb15f094f02cdd90be4a02
-EBUILD mkdocs-material-8.5.4.ebuild 1045 BLAKE2B f973f72b347a875d6fe5e90915e7749217957554a6edbaee65ec27290db1de9b3631a6efd3ea5fa09680edede53351241fe33de203568cca45cd8d835dcce955 SHA512 bc18c7d13133c5a0c57475c90e97840cbd8d9ce3b067e29df10bed31da00b39b71f25caf7602e07316117d6c7dfacbda3a6216a027cb15f094f02cdd90be4a02
+EBUILD mkdocs-material-8.5.4.ebuild 1044 BLAKE2B ca7e11f33898b1de7d0d9004c027988055d7ccab30ef37710f57c450617cdb1b582ec9bb457121d2e0241f4c544351bc8a79d164c03a271d5c54f903f0cbbb8f SHA512 03acb0053a5195d6b041f39c5d85c5efe31354c41da222ff529000163390b6311f11941c571d1035bae2da2a8db4292d4a6f560595b31d59b3939fd96fafc414
MISC metadata.xml 1037 BLAKE2B 6997d0f85e31152c58092081b697d8934c54f933e188082eb55e5e9f252f57274f673e1d8e5b657907da2d1658f969cd67bdb32bdc05324746f211b718f3a4b2 SHA512 ccd4f4aa6e6e780d0aff5894b260eedb602d29cc25427c202561525d27de4a31d1e13f59267d8d732d0e12f3ca0485996bca6ef2a114e96b030259899e8ad47c
diff --git a/dev-python/mkdocs-material/mkdocs-material-8.5.4.ebuild b/dev-python/mkdocs-material/mkdocs-material-8.5.4.ebuild
index 0cb9c4691195..143d5bbba5e4 100644
--- a/dev-python/mkdocs-material/mkdocs-material-8.5.4.ebuild
+++ b/dev-python/mkdocs-material/mkdocs-material-8.5.4.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_USE_PEP517=hatchling
PYTHON_COMPAT=( python3_{8..11} )
DOCS_BUILDER="mkdocs"
diff --git a/dev-python/nautilus-python/Manifest b/dev-python/nautilus-python/Manifest
index 03089d7b5164..bf6e7141c350 100644
--- a/dev-python/nautilus-python/Manifest
+++ b/dev-python/nautilus-python/Manifest
@@ -1,4 +1,6 @@
AUX nautilus-python-1.2.3-gcc10-fnocommon.patch 6095 BLAKE2B ca0f7c2f46d3fc265cf2649c3f9f58d8bcf88212cd62065cb6f30adf2094e206eafb48354bc25bcc1afb887703b8d05d2a83020ff6382021edef130d5509ef38 SHA512 267171aadd5fcc825ca42e91f94dba72260017cc0aa4bc12874fef4773d46c6b47c1fc093e5043b3c77161cf2a51b78e6882ac8cc60c800c870d325108ce15c4
DIST nautilus-python-1.2.3.tar.xz 269320 BLAKE2B 3d355bb8c0e67c488bb818d55c2bc97d8d4bfa14aeed8d6cb80d999a4b91ef5dc2f576d3dcca0e44ac004830ae326a93110aeb0cbe1987f100475cbee1b59ba2 SHA512 9c6a1a4bbf74a8c9c7d94a74c6994f0b1fc9de522c9f05d0ccbcdf3d60b1073dcf8058739ac0ee16f54b2632f2b9dd994bbe2bcd98cc165db543567bb1545443
+DIST nautilus-python-4.0.tar.xz 32184 BLAKE2B cc910de82e54cd687d23541a0b283a70dc5a0626acebf8787110ae1b5a4c080741c0879968816e217a4da968a77169d79b6614dd055f1ae57999a9a49f2553cb SHA512 f70f825b821f266caafd1b347066de01462b8256ec126072042d09dd7fd6c9324847d5ddab65671589d0a411f8b8fed428dbc94806ac679d646861c66c3a0dd5
EBUILD nautilus-python-1.2.3-r1.ebuild 1067 BLAKE2B 9995af23756cf61fbf3f3d71f075586006b5e5fda87fba40d9069cabf07732521b1378f8466cd53c5296855f62b91d391bf2aff6f6c0d5b3d5bcef8321cf3149 SHA512 1af5acd1cc5ea788695d2d0259353512b204e5776535f5e2bd0ef0ca15b386314ed16da3bbeabecc94bbe4d64cc43e6e0dd0426f15d7dcbf8662b59fb43af234
+EBUILD nautilus-python-4.0.ebuild 1189 BLAKE2B 80c157790acc7293a44e7848aa0d467f67f805573c97291c7ddf5504778d6c42de1390060595fada80ced58b2bd7ee8861b26413a8031c35f8b09fb55ad046ca SHA512 462daedd02333edb0267398671360ee77950d36fe72bef454be95e2055e88bcfafcf47edf6a9a24f4527c7b9caa70d9b34bd528f2bb1e74d5400f40ac11c5dcf
MISC metadata.xml 254 BLAKE2B de7a97001e5947704f42973c8a0c3a23c2d80afb976254f5fd21e9d372a946e055d4cdc3c0eaed010505f87929b56e8b1e650c945e2a302644adbc9440833be8 SHA512 c81da4f9b80e5691a167f4590906952e25356604ec17689c005be14efb394c0634776bbe84df936edde239480bdf46db41216b00da4a3a45f670e9ca18ab0132
diff --git a/dev-python/nautilus-python/nautilus-python-4.0.ebuild b/dev-python/nautilus-python/nautilus-python-4.0.ebuild
new file mode 100644
index 000000000000..3f8b8c7bea70
--- /dev/null
+++ b/dev-python/nautilus-python/nautilus-python-4.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit gnome2 meson python-single-r1
+
+DESCRIPTION="Python bindings for the Nautilus file manager"
+HOMEPAGE="https://projects.gnome.org/nautilus-python/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="gtk-doc"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Require pygobject:3 and USE=introspection on nautilus for sanity,
+# because no (user) plugins could work without them; meson.build
+# requires pygobject:3 and >=nautilus-43.0
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ >=gnome-base/nautilus-43.0[introspection]
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ gtk-doc? ( dev-util/gtk-doc )
+ >=dev-util/gtk-doc-am-1.14
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature gtk-doc docs)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ mv "${ED}/usr/share/doc/${PN}/"* "${ED}/usr/share/doc/${P}" || die
+ rm -d "${ED}/usr/share/doc/${PN}" || die
+
+ # Directory for systemwide extensions
+ keepdir /usr/share/nautilus-python/extensions
+}
diff --git a/dev-python/reportlab/Manifest b/dev-python/reportlab/Manifest
index 5a39c902780d..274f6ed0c369 100644
--- a/dev-python/reportlab/Manifest
+++ b/dev-python/reportlab/Manifest
@@ -1,4 +1,3 @@
-AUX reportlab-3.5.48-usr-lib-LLD.patch 1601 BLAKE2B 34ff1ce6b0cc2fa8ea3b2bec79ccab0eb7ccc28ed306b524b0fced1a37605c0c957090c39c5a0b71dd6d3c47c60cb7b714142a2f339170b7dcd965363ff2df66 SHA512 32fbd4410846ba4d0a3a8a5521f21f445f76ee75d0adde6ade210816901f1bcffc511efe3822c9b473d71b3541a716f9b2a3aa39181afb21de3aad9d13026476
AUX reportlab-3.6.11-correct-srclen-type-in-gstate__aapixbuf.patch 1502 BLAKE2B 79fba12b6219d0a9e3d25140359bd9589af0f501345797d74ed07d6efd0fe239b4ef2a357bb65d16c0544224022323418a4d3f57358433d776a4f2d41b7bbbb1 SHA512 696454cd280fe603ae014b829577cc3fd1b968478cf327528229cdf66dc0069fa2748cbc7b8519b26b170e9f01784523da2862dcc8623d24a8b7695fa3f4d42a
AUX reportlab-3.6.9-paths.patch 996 BLAKE2B a003ce69d7aff12e04fac914d44a0af58555da9858d96f23be26455836ee1105d76136cdfbe52b888f9779f1b8463fda9a04587b3ef045c8354d840f3f92caac SHA512 f71ebfdb07c87a7bd39a5578355a2a800654204e38f722106dcfbe848332eb1ef6ce8b6ffebe08fd0a07214c0fcfade69e0eee1f47b1055c877efc64e70e0bfc
DIST pfbfer-20070710.zip 677333 BLAKE2B 100214476a361a5e5d1f3da0999591345f6e3a3f8c6bc3f6a3e9eca734190c6259758a43302c6e41254d33491fe535eb7d5dd07aa9727c912424bebc31fc18df SHA512 6fd4a5d955464b10d13a7b748703450c1fe120d5ed09e8cfa1b4dfa9c183c59fe001df29433af551796b0df62544b7ddc364f9bb1bdcc2cd300434340ffcc4f2
diff --git a/dev-python/reportlab/files/reportlab-3.5.48-usr-lib-LLD.patch b/dev-python/reportlab/files/reportlab-3.5.48-usr-lib-LLD.patch
deleted file mode 100644
index 09ae9675eb58..000000000000
--- a/dev-python/reportlab/files/reportlab-3.5.48-usr-lib-LLD.patch
+++ /dev/null
@@ -1,34 +0,0 @@
---- a/setup.py
-+++ b/setup.py
-@@ -163,22 +163,6 @@
- if self.L is None:
- L = []
- I = []
-- if platform == "cygwin":
-- aDir(L, os.path.join("/usr/lib", "python%s" % sys.version[:3], "config"))
-- elif platform == "darwin":
-- # attempt to make sure we pick freetype2 over other versions
-- aDir(I, "/sw/include/freetype2")
-- aDir(I, "/sw/lib/freetype2/include")
-- # fink installation directories
-- aDir(L, "/sw/lib")
-- aDir(I, "/sw/include")
-- # darwin ports installation directories
-- aDir(L, "/opt/local/lib")
-- aDir(I, "/opt/local/include")
-- aDir(I, "/usr/local/include")
-- aDir(L, "/usr/local/lib")
-- aDir(I, "/usr/include")
-- aDir(L, "/usr/lib")
- aDir(I, "/usr/include/freetype2")
- prefix = sysconfig.get_config_var("prefix")
- if prefix:
-@@ -574,7 +558,7 @@
- SOURCES,
- include_dirs=[RENDERPM,LIBART_INC,GT1_DIR]+FT_INC_DIR,
- define_macros=FT_MACROS+[('LIBART_COMPILATION',None)]+debug_macros+[('LIBART_VERSION',LIBART_VERSION)],
-- library_dirs=[]+FT_LIB_DIR,
-+ library_dirs=[],
-
- # libraries to link against
- libraries=FT_LIB+LIBART_LIB,