summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin273888 -> 274042 bytes
-rw-r--r--dev-python/dbus-fast/Manifest3
-rw-r--r--dev-python/dbus-fast/dbus-fast-2.24.4.ebuild60
-rw-r--r--dev-python/dbus-fast/metadata.xml11
-rw-r--r--dev-python/pytest-bdd/Manifest2
-rw-r--r--dev-python/pytest-bdd/pytest-bdd-7.3.0.ebuild43
6 files changed, 74 insertions, 45 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index 7b82a2fd141c..e1fa6041a5f0 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/dbus-fast/Manifest b/dev-python/dbus-fast/Manifest
new file mode 100644
index 000000000000..5e40a23d73fb
--- /dev/null
+++ b/dev-python/dbus-fast/Manifest
@@ -0,0 +1,3 @@
+DIST dbus-fast-2.24.4.gh.tar.gz 178320 BLAKE2B 790935c94b8c5984993bbbc7741cca1ab6c232e8a58266030318c774dcbdd77b3712fbb5ab3b3c6197f86eb8c0be0d8626e9dfcabf50a1a485be8d80334721fe SHA512 e08a1b8c028cf33f7055621b502ffdffb1d9c79875b9f9d05afca401cdc583ae97bb029706002ad0e94e2ce8ccf3a992fe9cc9c023e87f64d04bb581b2e9f263
+EBUILD dbus-fast-2.24.4.ebuild 1365 BLAKE2B 0032297b029f8afe9f914a14031df0c6057123cb9b3e6b2c7ce8c43744eb4c7adbbae4e04d2443bc1239457020d21b84cf0f31d2bc80e4193f361289f9cb1db0 SHA512 941d40095e271baa9b69235ee9f9a2bd51e92e06691557cb0b3962d18ddd7bfb941de6dadee145681986cac43ee50241b34805425e69a6722c27fd860ac1d9a1
+MISC metadata.xml 358 BLAKE2B b3e64afbcae1f0bf903b248c0da287bf2c6c5921d347c56bb63edc7ee266628750cde9bfd50ba4f1b6cdda84ff705dc0ce090bb4872233032163726b352cc454 SHA512 e2bcdb48456b29576690ccdca08a701915aee1f5e8857c35f6e950198c124cec283ed6d03dcdae1a2669dcb0244e9a4a4b6ea43d193b06738b09e081e060b9fb
diff --git a/dev-python/dbus-fast/dbus-fast-2.24.4.ebuild b/dev-python/dbus-fast/dbus-fast-2.24.4.ebuild
new file mode 100644
index 000000000000..bf290b3322cf
--- /dev/null
+++ b/dev-python/dbus-fast/dbus-fast-2.24.4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="A faster version of dbus-next"
+HOMEPAGE="
+ https://github.com/bluetooth-devices/dbus-fast/
+ https://pypi.org/project/dbus-fast/
+"
+SRC_URI="
+ https://github.com/Bluetooth-Devices/dbus-fast/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ >=dev-python/cython-3[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-65.4.1[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pycairo-1.21.0[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.42.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.19[${PYTHON_USEDEP}]
+ >=dev-python/pytest-timeout-2.1.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export REQUIRE_CYTHON=1
+
+src_test() {
+ local dbus_params=(
+ $(dbus-daemon --session --print-address --fork --print-pid)
+ )
+ local -x DBUS_SESSION_BUS_ADDRESS=${dbus_params[0]}
+
+ virtx distutils-r1_src_test
+
+ kill "${dbus_params[1]}" || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # interface not found on this object: org.freedesktop.DBus.Debug.Stats
+ tests/client/test_signals.py::test_signals
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ nonfatal epytest -o addopts= -p asyncio || die
+}
diff --git a/dev-python/dbus-fast/metadata.xml b/dev-python/dbus-fast/metadata.xml
new file mode 100644
index 000000000000..584f534455fa
--- /dev/null
+++ b/dev-python/dbus-fast/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">bluetooth-devices/dbus-fast</remote-id>
+ <remote-id type="pypi">dbus-fast</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-bdd/Manifest b/dev-python/pytest-bdd/Manifest
index 929ca1d66259..90b879e5de82 100644
--- a/dev-python/pytest-bdd/Manifest
+++ b/dev-python/pytest-bdd/Manifest
@@ -1,5 +1,3 @@
-DIST pytest-bdd-7.3.0.gh.tar.gz 81595 BLAKE2B 80c5323ba3c50fae17bb57ec26b968ca7d7b673d2aeb2716dee02e3543916ca8b5752d9af56d3d250f3a4b0a857a3dc760de615f0650eaf379380fb24a5b7c2a SHA512 e7c309552714a77d47e437a825e661dbf201a6945e84f4b611b5c3da3d0b4ceb535bde4809fc9633b82a74e2b52cc69c7e14b27a27032c7e4400727498442e29
DIST pytest-bdd-8.1.0.gh.tar.gz 116529 BLAKE2B b282f42dbde9394f37e41682d44352d5895a30e2b88c20c46f8d9344f8069e25e2a7a2b6225ebd34a43b60d2392c7bc515f2ebd94bb26a0d350b7d188dd4d77e SHA512 6b03a509a8026ac242a4446caffc019b264f3528322eab8aa0ca2ce4c099bbc45640d63087a756d0d1d0daacdd2f396f121823ca500cef38391e9313a0f898ab
-EBUILD pytest-bdd-7.3.0.ebuild 1044 BLAKE2B 134bef00e9c40656709015f7e8ca045b1ff0b79be49c21e3924c36985e85ac10c1b282c9fc9ff85d34a47dfd1caf54e937fe728ff87a5d63a77e34566aff0b6d SHA512 2973d27c6499113e3703d57cd00bc571769ab00a72fc75170f97ac06a8e51c1d803341c072bbfde751fdf39c3cdae1f2a927f3cf4cc8d0c280ff1c7941885e0a
EBUILD pytest-bdd-8.1.0.ebuild 1091 BLAKE2B 1fbf59281edae85482edc0ce46660a2bf1a117bf9947740cad3d28b8cd1bb3b028796d912eefbc653b72e77ab21747d2ba58f2a18bde784ff46be663360f8b6c SHA512 a016b5bb080a8dd304eceded16fa87cdc5d9a5d69db099b9384aae8b7b219423028745c58e5073a65d6be3c42a0f49e38c7821d8942b482b70053a7ed39caf32
MISC metadata.xml 404 BLAKE2B b5bdea28ab998a54bd0b76e38c37a77af74d4ae149bfc5af47e7466b7c13ae6a5784be0ecc3e6cd8ccbbd5164dea02d704f596b7e00d22b0d640c4ad3dd13b41 SHA512 97800a5877bd8f3aa880a0cdff19cc89de983ec1a0cd9fbe2c74178b6fc214a0ca7fbb013b2ac490e1c4109f03ded7055e1517a3b57f6da0d79c9f5ea5864e77
diff --git a/dev-python/pytest-bdd/pytest-bdd-7.3.0.ebuild b/dev-python/pytest-bdd/pytest-bdd-7.3.0.ebuild
deleted file mode 100644
index 8123e325faa8..000000000000
--- a/dev-python/pytest-bdd/pytest-bdd-7.3.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 2021-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{10..13} )
-inherit distutils-r1
-
-DESCRIPTION="BDD library for the pytest runner"
-HOMEPAGE="https://pytest-bdd.readthedocs.io/"
-SRC_URI="
- https://github.com/pytest-dev/pytest-bdd/archive/refs/tags/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm64 ~x86"
-
-RDEPEND="
- dev-python/mako[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/parse[${PYTHON_USEDEP}]
- dev-python/parse-type[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-DOCS=( AUTHORS.rst CHANGES.rst README.rst )
-
-src_test() {
- # terminal_reporter test needs exact wrapping
- local -x COLUMNS=80
-
- # hooks output parsing may be affected by other pytest-*, e.g. tornasync
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_bdd.plugin
-
- distutils-r1_src_test
-}