summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin274146 -> 274162 bytes
-rw-r--r--dev-python/bibtexparser/Manifest4
-rw-r--r--dev-python/bibtexparser/bibtexparser-1.4.1.ebuild30
-rw-r--r--dev-python/bibtexparser/bibtexparser-1.4.2.ebuild1
-rw-r--r--dev-python/ipython/Manifest3
-rw-r--r--dev-python/ipython/files/ipython-8.30.0-python3.13-debugger-pdb-curframe.patch30
-rw-r--r--dev-python/ipython/ipython-8.30.0-r1.ebuild (renamed from dev-python/ipython/ipython-8.30.0.ebuild)2
-rw-r--r--dev-python/mido/Manifest2
-rw-r--r--dev-python/mido/mido-1.3.3.ebuild2
-rw-r--r--dev-python/nextinspace/Manifest5
-rw-r--r--dev-python/nextinspace/files/nextinspace-3.0.0-license.patch20
-rw-r--r--dev-python/nextinspace/nextinspace-3.0.0.ebuild39
-rw-r--r--dev-python/nextinspace/nextinspace-9999.ebuild10
-rw-r--r--dev-python/python-rtmidi/Manifest2
-rw-r--r--dev-python/python-rtmidi/python-rtmidi-1.5.8.ebuild2
15 files changed, 135 insertions, 17 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index c42a8c981c86..76a5d7beac25 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/bibtexparser/Manifest b/dev-python/bibtexparser/Manifest
index ab0a4c2f725d..187ea4ed121c 100644
--- a/dev-python/bibtexparser/Manifest
+++ b/dev-python/bibtexparser/Manifest
@@ -1,3 +1,5 @@
+DIST bibtexparser-1.4.1.gh.tar.gz 97146 BLAKE2B 8040532fe2153ff6ec664631a11b4f61548f99198c565bb554d0fe09d1fa54ee368c08be72bf7e86c5b6ca696deb0210496d4772243a05c5c9b28d73f52e6dc5 SHA512 f8e8f911eac38e98362bbbeff5b4af986e426911db9c54e93ec4a4eee1b1ceed630222c1a51454639566a6b5bad60c86a70b882a1c05084927fcbe7315e837ce
DIST bibtexparser-1.4.2.gh.tar.gz 81042 BLAKE2B 4522e46c371ae66af933ff6edc3cf1ce37336597c815facd8bbc62cc5b976c66bce45563af18f15a62c5ddf8ddda1bfbfa986eb16f21544aafaef3e22883cf4d SHA512 7aa58cb50c42773b8ae6d0448f817e83cc7445b8e65806430df17f9956219f440116cb227825da3423b40a5815921d1e42e407b236f6e917b3713eee5b8a989b
-EBUILD bibtexparser-1.4.2.ebuild 636 BLAKE2B ac972f22cd028aa5bfce7ef74382f412e7134f0d351f43052e4952fb5c32ca738eae643aeaeecdab17086127f6dd625590626628cd8e98e56f3b14fee6cf6bce SHA512 163d6d56086d95efbf216cd1544771c829158e70fd174635647a340d8aeb308fe9466886ebdca835439536895c0cc921c6dbea3f08275da39f1d53b2396d0fcb
+EBUILD bibtexparser-1.4.1.ebuild 642 BLAKE2B 9e19bb33fe34298b935531a441b541831b081c617f8acad8c37c1217fb0ec6801dd0b833bc4017c3e837ee78b4ee86627605a35a21fd53657f0e2b4254179647 SHA512 d1de97a37ce2ed779e99a39f544f4bdea7858880594f8123beb97a28a0d4b2b1774d590ec3e675835f77b2092a624553ac7161e304242239daf204bb7ec04b4d
+EBUILD bibtexparser-1.4.2.ebuild 606 BLAKE2B e5ba59b9796aee10141d61e7f62b8fc10ccde727838bc79908f3cb24eda090cca17b7a20f8dcb23fb77e401fb69e6574af6bac067164f6872f1a486cd2953bd7 SHA512 c1776f13a693890ccbce9608ba8eba640aa0a4e7ebed41adc6104da66a689f8dccc3b940e0d4b096504ca096d0c6833fce622b0addbf665380da1b973d05736c
MISC metadata.xml 420 BLAKE2B 931e6f1915be7d1b809bd2f59fec9f057fe3f6c6219ae3d5d8103a5e5155d13dc6decfbb5865d7a333247178371adae7f2712d12f0e001badb941d5fb2b8e6e7 SHA512 254ba66a5078b040ff86a77ae890c70f4d49374f2094b67c5046a8acc308901048fe8c46d1eb8d9716f13c0ac6a6c48625aa799837a1c586b2ce450a50704d33
diff --git a/dev-python/bibtexparser/bibtexparser-1.4.1.ebuild b/dev-python/bibtexparser/bibtexparser-1.4.1.ebuild
new file mode 100644
index 000000000000..cacc9487d938
--- /dev/null
+++ b/dev-python/bibtexparser/bibtexparser-1.4.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="A BibTeX parser written in Python"
+HOMEPAGE="
+ https://github.com/sciunto-org/python-bibtexparser/
+ https://pypi.org/project/bibtexparser/
+"
+SRC_URI="
+ https://github.com/sciunto-org/python-bibtexparser/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/python-${P}"
+
+LICENSE="|| ( BSD LGPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/bibtexparser/bibtexparser-1.4.2.ebuild b/dev-python/bibtexparser/bibtexparser-1.4.2.ebuild
index 3d278134f652..1b959ae6721e 100644
--- a/dev-python/bibtexparser/bibtexparser-1.4.2.ebuild
+++ b/dev-python/bibtexparser/bibtexparser-1.4.2.ebuild
@@ -21,7 +21,6 @@ S="${WORKDIR}/python-${P}"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
RDEPEND="
>=dev-python/pylatexenc-2.10[${PYTHON_USEDEP}]
diff --git a/dev-python/ipython/Manifest b/dev-python/ipython/Manifest
index 97e96cd480ee..b8edf0912131 100644
--- a/dev-python/ipython/Manifest
+++ b/dev-python/ipython/Manifest
@@ -1,3 +1,4 @@
+AUX ipython-8.30.0-python3.13-debugger-pdb-curframe.patch 1380 BLAKE2B 7f31588b848719fe44fc4356f368a84b65d8333fc46af269110592af1dd5765fa940070c89c37ff410607db7111f2dadcdd360499667a42da2d918d480ae7340 SHA512 5a6d99e8213af5eaffb0667567f68aa60f35291c6d502584ceff2fd32b58d681ea3d4c766ed35c747a1de8bcc8827b04fb97de3ca13d93f2dea3136aa3af70cf
DIST ipython-8.30.0.tar.gz 5592205 BLAKE2B e935305ce08ba287bb811a3efe7ae88821485f726c4c45815f4c39c1a51bb59ab439d256fbb91ddd71d12512fb58c913e4120663d6035b4644da67b3eee9b91c SHA512 36432ed736ce06f47b3ccb6172e6c03a15bfa51a2e38b80d5b579687abad0c03181684b218750f320b185fe3f96baf159eb9c9184c40ddfca78fdd9683233a9b
-EBUILD ipython-8.30.0.ebuild 4477 BLAKE2B c7a4c98aaf5fc6772a48b9595938eedd71eb556db714f18687e004b248a2e001f5ec7193bfb5e55bd053aee1c362b22dc657cc2cd35b3a01668a5f0aeb7a020d SHA512 0fd135542966e2764d42040f6cae40b973c9612a09fe00c94c68c3bc7eff19011b51e6cb01bce313b680c02fc1a8da75fc7a1700f28588806f650d79dc54c893
+EBUILD ipython-8.30.0-r1.ebuild 4562 BLAKE2B 5539d8d30a6aa356b440c9e501fab1b9720d486b1a76a396ba25b7f395d4196bcab187c2316b245c907ba5e18fc7b871a006a81cef35c4db289af409c71bc884 SHA512 9c0c899132f931a90c5b169c46f67ec11c1ab1ceecd6dd4345dcfaf19e058c1e9a9c8e20e181a2b67a50e913ef366d73dafb2b939401a8f549f8eaad42f275f4
MISC metadata.xml 2802 BLAKE2B 2fb6773ad4ef10d531f978e3ed40f6d99cf1586ec6d7cf2bf7e60fd5d640d082a0946651e0a066993320ffeaace3426066ca24c325926b62125ae91816707128 SHA512 965c3e36e05475d9454af8219b84e080d4c83d775f8a7e20a4951a82246d672c46fd3cb1fff5f8664d0ce8e8fcb846de6f15abc4575db3a6b7d87209194bcecc
diff --git a/dev-python/ipython/files/ipython-8.30.0-python3.13-debugger-pdb-curframe.patch b/dev-python/ipython/files/ipython-8.30.0-python3.13-debugger-pdb-curframe.patch
new file mode 100644
index 000000000000..8e44fd3d0261
--- /dev/null
+++ b/dev-python/ipython/files/ipython-8.30.0-python3.13-debugger-pdb-curframe.patch
@@ -0,0 +1,30 @@
+FAILED IPython/core/tests/test_run.py::TestMagicRunPass::test_run_debug_twice - AttributeError: 'Pdb' object has no attribute 'curframe'. Did you mean: 'botframe'?
+FAILED IPython/core/tests/test_run.py::TestMagicRunPass::test_run_debug_twice_with_breakpoint - AttributeError: 'Pdb' object has no attribute 'curframe'. Did you mean: 'botframe'?
+https://bugs.gentoo.org/946568
+https://github.com/ipython/ipython/pull/14598
+https://github.com/ipython/ipython/commit/c1e945b5bc8fb673109cf32c4f238f6d5e0f5149.patch
+
+From c1e945b5bc8fb673109cf32c4f238f6d5e0f5149 Mon Sep 17 00:00:00 2001
+From: M Bussonnier <bussonniermatthias@gmail.com>
+Date: Sun, 8 Dec 2024 11:37:11 +0100
+Subject: [PATCH] Fix pdb issues in Python 3.13.1
+
+For some reason it is not always set, it was/is a bug in IPython to not
+check.
+---
+ IPython/core/debugger.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/IPython/core/debugger.py b/IPython/core/debugger.py
+index 1f0d7b2fba..76c42e0230 100644
+--- a/IPython/core/debugger.py
++++ b/IPython/core/debugger.py
+@@ -550,7 +550,7 @@ def _get_frame_locals(self, frame):
+ So if frame is self.current_frame we instead return self.curframe_locals
+
+ """
+- if frame is self.curframe:
++ if frame is getattr(self, "curframe", None):
+ return self.curframe_locals
+ else:
+ return frame.f_locals
diff --git a/dev-python/ipython/ipython-8.30.0.ebuild b/dev-python/ipython/ipython-8.30.0-r1.ebuild
index b67d14eb4763..8cae90959a59 100644
--- a/dev-python/ipython/ipython-8.30.0.ebuild
+++ b/dev-python/ipython/ipython-8.30.0-r1.ebuild
@@ -81,6 +81,8 @@ PDEPEND="
)
"
+PATCHES=( "${FILESDIR}"/${P}-python3.13-debugger-pdb-curframe.patch ) # bug #946568
+
python_prepare_all() {
# Rename the test directory to reduce sys.path pollution
# https://github.com/ipython/ipython/issues/12892
diff --git a/dev-python/mido/Manifest b/dev-python/mido/Manifest
index 16bdf0d5c524..89838d3f8078 100644
--- a/dev-python/mido/Manifest
+++ b/dev-python/mido/Manifest
@@ -1,3 +1,3 @@
DIST mido-1.3.3.tar.gz 124288 BLAKE2B 2119ffa5894067107ccf94a4ddcccde0365aedd942df0330e06c1a1a3645cfa8b9a1bf767a0e60616f50966cf7dfb5a1d6cc394c05269bb01ba0724573dd4164 SHA512 9a9b983b7d2cc6ea530f98df09bc84690dfc980467726217023991a680a7c3f294bb0ffac730e79dcc5a3e4afccacfb4423791df290a035260513a5f7cc26152
-EBUILD mido-1.3.3.ebuild 851 BLAKE2B 030c1711d3386833f9e756b81f97c83517572cd7dbc700402b5b02b946b184edf4bb37f711ec7ae5b2cf064c84c14d838aac266b34c55d05614da85e2bbe89a3 SHA512 9e67d6d27013df10f18bd83a398051c97b7b2b91e8ae6d36f569fbc3afcba9f2f4577e7d0cdbb45ceb4ff1f9682678b3055dc1bc85fc29d8f11ed14ce5cc96c5
+EBUILD mido-1.3.3.ebuild 851 BLAKE2B f63936b6b5a5b24c11398b95aec7dfd15641118b268340ec4b8fe100e7ef7264db2f193ef21a2c63ebea413a36f7c72579652cbfcb965492955c2916c6460bec SHA512 ce6435efe828454b8caf5e895fc2b4125ba58e849116eb4e1e167f9ade2fd63b44ac33830e0e8e2f19550a41d2a0d93758f37bdd5e67d776a6261583350c7a19
MISC metadata.xml 554 BLAKE2B 535b19a587a4756d9cf85991d9e17aabb195c1eb64a5b17f3604d2360a756b04223a94e97a98d79f63173031f1916a842ed483114cf134c1bfdd9cd36e2f2041 SHA512 f18d010f8b0aac0fdaccb72751c3091c853115a8d6cd8f68421fb5ff0ff538d799e28a86586fb819f77be43a7771621a376ad9698d6bbd1bd11c8a5bf1bd5133
diff --git a/dev-python/mido/mido-1.3.3.ebuild b/dev-python/mido/mido-1.3.3.ebuild
index 65e99af5f556..081d7f27cb5f 100644
--- a/dev-python/mido/mido-1.3.3.ebuild
+++ b/dev-python/mido/mido-1.3.3.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 pypi
diff --git a/dev-python/nextinspace/Manifest b/dev-python/nextinspace/Manifest
index 429293d12597..6b3472e71b98 100644
--- a/dev-python/nextinspace/Manifest
+++ b/dev-python/nextinspace/Manifest
@@ -1,5 +1,8 @@
AUX nextinspace-2.0.5-lazy_fixtures.patch 3050 BLAKE2B 7646d63df012528a9f2c55d9ce1cc54df654920879650d20b911710f6e23c04d16ccd12bd7ae1684e5c37bb6493f89babcc3b14f2ea83274650981b2da43de29 SHA512 010321c4375fee0a54f61e25e09497830d0a2cff6f5d895748ee64a46087c0ef60259afab88e8e1641cccb9c534a53a5284be8ada52df62504c259c668036045
+AUX nextinspace-3.0.0-license.patch 550 BLAKE2B c6d7e674a2d60bcbc9fa6c6c99b4357ca4d73841c515598292b0f604087622163b6edcf6abba138536d86ea961c0f06ee0310df7d316b28e60447a26fd93f0b7 SHA512 93f94567636224b894388d8bc299ab986b9e232261398005d49fec1845949e1ae22ceeed5b0caf84c07ad475982ef324704884472b8f83caf495f6ddaafad469
DIST nextinspace-2.0.5.gh.tar.gz 48406 BLAKE2B 6f6e2c95fc1a5a8175faca4df0a51de9996ca24847926dc35b94d0e4bd5c9de880ad757606309f622f41c825d0c2e46c587f255573b4df70fe35c937148af9d7 SHA512 c8f55446d9eea0409afb8a8ddb41001b18b55d9105d007b306717a3d932ea1b03ecb2363d0deb42ec8da1cc245b77ffb18cee6ec3474121c15c4c9b79ff80405
+DIST nextinspace-3.0.0.gh.tar.gz 55095 BLAKE2B 02140cbfaeca9fd4cb19fefd40448fc5ffbed19a8e5bcb448800b1c5917d7873be69e0aab5c4d96acf4dfb7fc57b780420de19dc38a523b5ca38c9847cfa0263 SHA512 fa1d20401b7ed910e0c65c9010062cf6d1ffe7e73c09b47f42b19ab1bfbb74612cb7405571e4db0404de81e66211799f38b6654763222643f66e63176e4a72ab
EBUILD nextinspace-2.0.5-r1.ebuild 1047 BLAKE2B 09178a3eb824ffec0b6b06b0365b59f8b1ee4f315814e8b75adc7449057286b26b2763e6212efba476759cf7fcda7c06029f22c36968e8aada0723baa7a4c36f SHA512 1dd66de23f2fee70ab0109eb1ec96423de7eeab100799aec48caa639c895838cbdb9426fd559cbbd4ae1c35233e1fd23626478ceee1df39d957a504b0a44a727
-EBUILD nextinspace-9999.ebuild 1056 BLAKE2B 06ee77916994bc6b5c8b000d854c0d94ad3c45418c4d65abfbf5f143624247b73fc5d619e5b76b35ccca5ac04b34762fb41172efbdf8f1f1a0cefc7328d091da SHA512 c7a7bf96f88ad8532a096bc13efae4cef06ef87733f9332bcdc51cc660ba28f0ddb8259f17c99442beac484a0b60e15b88b1ae7a33a4a119bbdc8f7d517cf609
+EBUILD nextinspace-3.0.0.ebuild 906 BLAKE2B 3a3e05cfb4a8e814d9d034d270ed87e0c06c28a949074e41505de7d1c09fb42314034e861fdfc1041c5fae0dfb61f5d9f6515318031c6750202017794ff42766 SHA512 4bc0487ca6559d25aa9587a6e46fcec465818349fd43bccaf01d2d29cce60de67aedd7578c44549731a3fff8925a25d200cb01a836034ee83e2aee638f31673d
+EBUILD nextinspace-9999.ebuild 906 BLAKE2B 3a3e05cfb4a8e814d9d034d270ed87e0c06c28a949074e41505de7d1c09fb42314034e861fdfc1041c5fae0dfb61f5d9f6515318031c6750202017794ff42766 SHA512 4bc0487ca6559d25aa9587a6e46fcec465818349fd43bccaf01d2d29cce60de67aedd7578c44549731a3fff8925a25d200cb01a836034ee83e2aee638f31673d
MISC metadata.xml 842 BLAKE2B 474983307f5e6669ce25e6dc44c65597a59e0089a4c66ad0c531b2ab634c0505e0208c8b55ffe333af4641c227b1b3b5f71515cba441e91f2be3c53c5d53f2d7 SHA512 28aa458b6d9be33d07c615d842726789bb39ea0ed966b261417c33197e279474034e91afadeb2c91d9c9b80b4d54bd68d6ce5a89afc16891d3d8d007ee0e3d5e
diff --git a/dev-python/nextinspace/files/nextinspace-3.0.0-license.patch b/dev-python/nextinspace/files/nextinspace-3.0.0-license.patch
new file mode 100644
index 000000000000..0f1708777ff7
--- /dev/null
+++ b/dev-python/nextinspace/files/nextinspace-3.0.0-license.patch
@@ -0,0 +1,20 @@
+commit 6e03e0f5cc94f039df06506a340b70d38860b84b
+Author: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de>
+Date: Thu Dec 19 18:40:53 2024 +0100
+Upstream: https://github.com/gideonshaked/nextinspace/pull/18
+
+ Don't install LICENSE file in site-diretory
+
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -58,7 +58,9 @@ classifiers = [
+ "Programming Language :: Python :: 3 :: Only",
+ "Natural Language :: English"
+ ]
+-include = ["LICENSE"]
++include = [
++ { path = "LICENSE", format = "sdist" },
++]
+
+ [tool.poetry.dependencies]
+ python = "^3.10"
diff --git a/dev-python/nextinspace/nextinspace-3.0.0.ebuild b/dev-python/nextinspace/nextinspace-3.0.0.ebuild
new file mode 100644
index 000000000000..4017cac96b5e
--- /dev/null
+++ b/dev-python/nextinspace/nextinspace-3.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..13} )
+inherit distutils-r1
+
+DESCRIPTION="A command-line tool for seeing the latest in space"
+HOMEPAGE="https://github.com/gideonshaked/nextinspace"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gideonshaked/nextinspace.git"
+else
+ SRC_URI="https://github.com/gideonshaked/nextinspace/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/colorama-0.4.3[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.24[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-lazy-fixtures[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.8[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-license.patch"
+)
+
+distutils_enable_tests pytest
diff --git a/dev-python/nextinspace/nextinspace-9999.ebuild b/dev-python/nextinspace/nextinspace-9999.ebuild
index 07ed06c31eb5..4017cac96b5e 100644
--- a/dev-python/nextinspace/nextinspace-9999.ebuild
+++ b/dev-python/nextinspace/nextinspace-9999.ebuild
@@ -27,21 +27,13 @@ RDEPEND="
"
BDEPEND="
test? (
- ${RDEPEND}
dev-python/pytest-lazy-fixtures[${PYTHON_USEDEP}]
>=dev-python/requests-mock-1.8[${PYTHON_USEDEP}]
)
"
PATCHES=(
- "${FILESDIR}/${PN}-2.0.5-lazy_fixtures.patch"
+ "${FILESDIR}/${P}-license.patch"
)
distutils_enable_tests pytest
-
-src_prepare() {
- default
-
- # Don't install license files
- sed -e '/^include = \["LICENSE"\]$/d' -i pyproject.toml || die
-}
diff --git a/dev-python/python-rtmidi/Manifest b/dev-python/python-rtmidi/Manifest
index 9d27f2e706fd..17b8d0a9582a 100644
--- a/dev-python/python-rtmidi/Manifest
+++ b/dev-python/python-rtmidi/Manifest
@@ -1,4 +1,4 @@
AUX python-rtmidi-1.5.1-unbundle_rtmidi.patch 1455 BLAKE2B 2cc76ace5758131a069194e9d30c8288ed93a261d41a2b4cf0294e2b4fc7ebee9e0c43b4377143ae8074a03dcc2abf13fd85fdebeebd321efce00e25e43057b1 SHA512 92c11d878018ded30dffa0d06006f8471054321af8d9f58268d4d899121dac66712ddc3a53285c19293fb2d52d4d054b0d803c559e9c01cb8c8f161ce5f2c734
DIST python_rtmidi-1.5.8.tar.gz 368130 BLAKE2B 99fecb8cd003431b5fca31f436a77f27a50076a02ea7f92019800d0816c968f032bd31d236a13d67b2ee9ebdc341d16955675867a8dd345e76282131b781ef13 SHA512 0f2b949a2a53f813a891bc391ce0369fbbec0d6e898a9ace2925adc5714d791ce1f4df133edf34c87b3336cb3ab4ad70851a42124241ec1707f32f66a778dc18
-EBUILD python-rtmidi-1.5.8.ebuild 1558 BLAKE2B b8cbc30ab37b1a579ce96fc7813b71d02364a477c5e1fdc6bf99688b9d959bbad430df35621e2a849538d943833208f4c5bb51257d70e4143605477dfed44d66 SHA512 066c828f6bb2b7c9379844dcfb8f8033a5ee3b0274c7b2b6aa09b0c18707dcc0a396ea1b499d21ee12f03ea45b77ee7075d228338e6e143d4ac0a6eaa63abd45
+EBUILD python-rtmidi-1.5.8.ebuild 1558 BLAKE2B 13cf5be45e33281b60a27ccd851d7c4ebddf9a2c3114b078ff32c6afe392d9f8282e1ce89a2415fe06aeb80c4a3b2884469ff891234b4af7605f20574788ef66 SHA512 c6ba1e413821007c9dcb79b2a5b2d066683e63bf69c3ec74bfeb92aa81e22d515ef0b7e4f47f5837d242402bd65f3c3d0724eb7709a49c1fdfcb8618426539b0
MISC metadata.xml 310 BLAKE2B afc6a689e45eca44257a8e730434eee137f1d58e5d72d2d493c85529f78a17bb55c20eb251bf0f83233d6877f5625e91ad763ce0ae47b3312e31746d6ff9d2b1 SHA512 3cff05c38c519aa5ea68cf908d832e41cab790ad6b1c0d017fff39939e9b34a50a244a47cb038f9503ff78e1be648703383dc1cb20682a49062e850159fb3c20
diff --git a/dev-python/python-rtmidi/python-rtmidi-1.5.8.ebuild b/dev-python/python-rtmidi/python-rtmidi-1.5.8.ebuild
index 48e08a2d6ef5..a68171e7ea2c 100644
--- a/dev-python/python-rtmidi/python-rtmidi-1.5.8.ebuild
+++ b/dev-python/python-rtmidi/python-rtmidi-1.5.8.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
DOCS_BUILDER="sphinx"
DOCS_DEPEND="dev-python/myst-parser"
DOCS_DIR="docs"