summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin270702 -> 270856 bytes
-rw-r--r--dev-python/backports-tarfile/Manifest3
-rw-r--r--dev-python/backports-tarfile/backports-tarfile-1.0.0.ebuild39
-rw-r--r--dev-python/backports-tarfile/metadata.xml12
-rw-r--r--dev-python/jaraco-context/Manifest2
-rw-r--r--dev-python/jaraco-context/jaraco-context-5.3.0.ebuild58
-rw-r--r--dev-python/moto/Manifest2
-rw-r--r--dev-python/moto/moto-5.0.5.ebuild153
-rw-r--r--dev-python/rapidfuzz/Manifest2
-rw-r--r--dev-python/rapidfuzz/rapidfuzz-3.8.0.ebuild66
-rw-r--r--dev-python/send2trash/Manifest2
-rw-r--r--dev-python/send2trash/send2trash-1.8.3.ebuild23
12 files changed, 362 insertions, 0 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index 7f82a1530288..1aaa2c58f8bd 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/backports-tarfile/Manifest b/dev-python/backports-tarfile/Manifest
new file mode 100644
index 000000000000..50853b26a8d5
--- /dev/null
+++ b/dev-python/backports-tarfile/Manifest
@@ -0,0 +1,3 @@
+DIST backports.tarfile-1.0.0.tar.gz 32952 BLAKE2B 264f63406f0cbf053bcbbc2933317152cbe89e765b87449111cf3397b072d68b1671918a7e3549f9f96dfc62c540f36a7b4e263d5c3f3ea305093a992d68eb2b SHA512 c44907a9b5c9af5dbcc37ecd613dcd7e269b1eed71a757d4e6c32828cc703a3060943f67a0caf90680ade89df8a938b999ba64d30ebfb5b63fbb0c70a068d349
+EBUILD backports-tarfile-1.0.0.ebuild 990 BLAKE2B 6a88ebd6a49cef1b5e3943919d4f9b71f05e8899a4d1951ebec4f15e5e427602275589909ac73f228b13c51e593e1e8735f9743710c9d8262d745bf7cb07d27c SHA512 3e7264489a091700dbfde51eb543610aa86e935ea5e8b29972a6d9f6e2d7ccbf77f4b1741467a1a1ba754d4189f59224273c74610b9800d50b41853be9afcaa6
+MISC metadata.xml 387 BLAKE2B f9f0136e2308996c5c4dc5daac7bfd5b700e2249e11dbfc3417dc6bca363dfd2bf654d89392bf818a3963b14d1369052b06788e0367d61fdad36f5b3b2607b51 SHA512 27d9d5892c219d5346046aab5f157a66d8df942f5bbf1f40d06124b4263086ac96d7bac6745e0a0adc8a0e01df12b22b95dcecc4418e90fce6db981934332077
diff --git a/dev-python/backports-tarfile/backports-tarfile-1.0.0.ebuild b/dev-python/backports-tarfile/backports-tarfile-1.0.0.ebuild
new file mode 100644
index 000000000000..cbf154d77acd
--- /dev/null
+++ b/dev-python/backports-tarfile/backports-tarfile-1.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+# This is a backport from Python 3.12.
+PYTHON_COMPAT=( pypy3 python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Backport of CPython tarfile module (from Python 3.12)"
+HOMEPAGE="
+ https://github.com/jaraco/backports.tarfile/
+ https://pypi.org/project/backports.tarfile/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "backports.tarfile"
+ version = "${PV}"
+ description = "Backport of CPython tarfile module"
+ EOF
+}
diff --git a/dev-python/backports-tarfile/metadata.xml b/dev-python/backports-tarfile/metadata.xml
new file mode 100644
index 000000000000..63138bedd14d
--- /dev/null
+++ b/dev-python/backports-tarfile/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">jaraco/backports.tarfile</remote-id>
+ <remote-id type="pypi">backports.tarfile</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/jaraco-context/Manifest b/dev-python/jaraco-context/Manifest
index bf3457bf394f..e226e8942eff 100644
--- a/dev-python/jaraco-context/Manifest
+++ b/dev-python/jaraco-context/Manifest
@@ -1,5 +1,7 @@
DIST jaraco.context-4.3.0.tar.gz 9764 BLAKE2B 2905723ec54c6ae63b2088d677cd486dcdc06dfea06bb058eeb512da508b2ae74990894cb62f3751321cb4c813b66ffe9a3084b21eb0cb4236a9515969432dfc SHA512 8882229fa1a68f2733ec4103fbeaf47625b19790f4461ab18df4c1f1a99d4d26d10d7381ab68ba5df48616a1fdb2d5e4a767496a0e40658fd011ed9cd39255de
DIST jaraco.context-5.1.0.tar.gz 11626 BLAKE2B c6ac691c6493e0aed5d606784f8418e55fb0c6c8094aa75251ffb12008fb9b4fbfe0912e6ef316d7799d2c0f55be6ba542202f6b8b2bc93afa3a79da4224d35f SHA512 b92c72947060e2219c172c43104055d026f66b119676fcfa31dff34640539d34376b61d209291fffeb558e6051fb92a2a34390fbd3a72f87ee15c5926cb387e5
+DIST jaraco.context-5.3.0.tar.gz 13345 BLAKE2B d2f429335ea80a6b50ea9574adc45c25c0fc78e8ebb5edde218bcbbe7a2b27ae6b5c17453e71904240d0d873ebef36f7c7aeda4424d3fea2dd9aaf01af6fb4c5 SHA512 f63bf272c45ff5c43499621651b78841259040ac98d67c9db75fadebb1c497c1156e05f23bf7c91df3e91f1e070acb9f7dc665e7b242ba7b1ac1cf99a619494d
EBUILD jaraco-context-4.3.0.ebuild 1300 BLAKE2B 228bc1e5ea178aa1ae21ebafce07fb9ee0cf053ed7ce1284e678f8959dd77d2a75fd2fa4d5f3e0b5bd3576182249728a8e1eed3f4a92aae4244706c47ebee323 SHA512 2015e52ffefc6eced077c35e160b23dbd841f60a829cd7ca6e33c01e2a77f11516840e5f3bacae279d5ebe67c1ed514ae65ed88a9acd7a7ecd308aafb9cbb94d
EBUILD jaraco-context-5.1.0.ebuild 1308 BLAKE2B d67845c9452b82134b26cbb4615dd9fc6dba7d95c3c08b625111ace5a943036c2f1f17e66e176c4cd78bdd25c31acc7b78faf0782597fa7ae6fd5e30ce0b566a SHA512 be4d9f2975bee41261335eff1be4c37f968fbb17cdf681a6c331914742eab077b0f8eb3bbd627b4171160f8854cf55df824d5f66861be7e84e0b2154c7ae101f
+EBUILD jaraco-context-5.3.0.ebuild 1313 BLAKE2B 4baa34baa59bf09ce5dcedb56ce6d781e188bd79ea25f8b98e9e037c5d0311c6f42fad0fc5c66954326d4846d7fb3a2293a35bcdfa8b4704bb55be474ed282b3 SHA512 5e0be23bbf0655c2da7cf62da013fce11ab39782b65e21c69477fb1031da7fefcaac66520f50b7b93ad79e1883c0d76297d89ab87557c1b1f5cef86ef0600bd0
MISC metadata.xml 403 BLAKE2B 32344da5308b2bd5eef6ac6efc6299869f4f82ab67b51a23666eef697a803bcc94993ed67f3047e82ba5500d1b0c49ec1f9b32112855c21aa4b3015c09fa0144 SHA512 13dec82eb1581116d8800e60c99c328aa1bb409fec83044fa5e02838008e4bf5d81bc1defeb59bc353ff4032600bdc9213559bdb745fd6571f53e9edd9dd6737
diff --git a/dev-python/jaraco-context/jaraco-context-5.3.0.ebuild b/dev-python/jaraco-context/jaraco-context-5.3.0.ebuild
new file mode 100644
index 000000000000..63436dc2de39
--- /dev/null
+++ b/dev-python/jaraco-context/jaraco-context-5.3.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Context managers by jaraco"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.context/
+ https://pypi.org/project/jaraco.context/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/backports-tarfile[${PYTHON_USEDEP}]
+ ' 3.10 3.11)
+"
+BDEPEND="
+ test? (
+ dev-python/portend[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "jaraco.context"
+ version = "${PV}"
+ description = "Context managers by jaraco"
+ EOF
+}
+
+python_install() {
+ distutils-r1_python_install
+ # rename to workaround a bug in pkg_resources
+ # https://bugs.gentoo.org/834522
+ mv "${D}$(python_get_sitedir)"/jaraco{_,.}context-${PV}.dist-info || die
+}
diff --git a/dev-python/moto/Manifest b/dev-python/moto/Manifest
index ab207013ef67..2808434bff48 100644
--- a/dev-python/moto/Manifest
+++ b/dev-python/moto/Manifest
@@ -2,8 +2,10 @@ DIST moto-4.2.14.tar.gz 4933741 BLAKE2B 4c50a808dc8f27cfbcd0ba234d268084ee9a32f3
DIST moto-5.0.2.tar.gz 4948857 BLAKE2B 664da28791bbf65eae9f76f59fd62f9c53aeb615c714fb142684213fe90f6e1e071f30511dfa44e16b12abd6fcf97316d097f3b4b1008a0f1139e5a419f1bb87 SHA512 4fb03586171dfde6979022623047578634f9b8ec7ac34234bbfe3e60492c34a04b61547c4fb42f7734ad8284271cc238cc33692b746d52d004d33f0c6348852b
DIST moto-5.0.3.tar.gz 4984811 BLAKE2B cfa8f70ca403d995b97dc6b5e0e6bcdeb4383ce76c1a333a7b047dccbca2d9e46bf9622d36720eee6fc0c917292542b154a326df863b45451a3ce72038b6e1c4 SHA512 c509795a7b00eec6adf9107ac541f8d4300fb2bd75459e9fb5e57f55843430d3a05eab85bd4f12ee6dbf88602ca8c185165a0b46d11973ad18c12a8bfe44dacf
DIST moto-5.0.4.tar.gz 5174431 BLAKE2B 03fb18cb63e0c7ccc0239bb27388b3e1190c078828e229ac88fee9fb0b8113b2bfac0c2f9abda4d9e67fe44b37a12e0ba7a8f8fa5c3973f0fa82dbf8ed763048 SHA512 65209c85895780bcfdcdc13d4cc0c64862e28fd3aefa6e265c86af6a320f554d5a58cb46b6c059d1288edc902b8069dc81e38b025238ec4340c485943dab5202
+DIST moto-5.0.5.tar.gz 5188450 BLAKE2B 052cb9cbc5752ce46283f4d3fd43e92ba3a492437d19e6284eb6907dfc4dc84e50ac6b64f0c78df3f8b1dd8140008528bd00090e112f6642b9acebe8e268e8a0 SHA512 c3c57d79864e63abae128c6d683314d06b6ee9fd40e496485e8499196b54df5e7281abb0d0ca6f5f096685799041552becfd2404a0828964232246868c70adb9
EBUILD moto-4.2.14.ebuild 6511 BLAKE2B 7bd2d7dcdbf678785be8f87b079f1c7a6295ae10dd50a8460f5937f9cb962bac232de2aeca8c6bb029fb5446c3784c1a92df30453660ed50491bf49fb90e3b2e SHA512 498b5c82391981420595b5b25465e69fe9dee5afbfc4619b92b05f93f3585e2abaea8733f8a74cfbb3475b74e49c778383d2e78f22caae6d904603539e6a64e9
EBUILD moto-5.0.2.ebuild 7239 BLAKE2B 1e3e9e739e6c0b25b8d10f9e9480ed79c1bbca2174c7937e94fd13f4c806edd6caba7d21517f4f46d3016ae6f7be6e86a66d2ab79f23575fbd8018fd6b47c5d7 SHA512 3aa421a3d0863eed95670eaed7ecdc1cdbcf08c6bddf15ef79258558a053bda4b7ec532ccd2a043252f4798ced5c11ef0fb5edf381b01710c18f1beafe040044
EBUILD moto-5.0.3.ebuild 7240 BLAKE2B 86cd668a544d8ff9ead710a566bc2b8397c3b8fe8ae55ca5c9559802006b2a02d64d5944fc737453c8d06f05b72069461105a75e95330ea4fbe8af9ab9c3b48c SHA512 df682627c9b6ca6d1e176ffed169bdc39c2347f91cbd263358c381ae1ea50ab1de592b91187b9616c2f9a5c82112da4aeb9901668a6ccc14282834bf43f4bb6e
EBUILD moto-5.0.4.ebuild 7326 BLAKE2B ea43d658b0e9f0c08b1a35e94100250c17f31b1f09819a97f70cbed4bee3b9e075f49e6a0552ccf914879431beed44b58a9e63549428b3ee2233a4eb20176fc2 SHA512 1d950a5ac73c3a7a24aa42dcfac9d711cd48def1812e3687c531df13080d92c0b3ca2f4ff35bd263ca0a748f174795bce3a1c7d0e7b7bef33a96eb7ac39e9de9
+EBUILD moto-5.0.5.ebuild 7281 BLAKE2B d6c83c06249aa1e16e03d452500625a75491e228ca59eba6b59be8a4d32c8b848b2cdf855fab865d14dcebd1e401a8a7b8dc7586fcf778012706eae442cc2747 SHA512 a5bea0363c61d08ff6de29482b52e33e2512f9041eb982737e7f64a8581cd0d2d2a76c949baf8d9ec1bce2e7076f9dbb4c0073dbb45e891ef3d2265a305cf0b5
MISC metadata.xml 553 BLAKE2B 1669d17d3e655aa3fb41a489229a5fbfa6a9cfb23c667e98fbbef931992c7e9645581b9ea12011601093586cba491a5557d68e5256edb9f387c4db362346edf9 SHA512 48ae3bd9be8c3bfb68f7022d0e7bb422c2a06157967809be302067facf91db825023859d18ccea89109931538b0e93181d54a31fcc967628df61a9a3112edd3d
diff --git a/dev-python/moto/moto-5.0.5.ebuild b/dev-python/moto/moto-5.0.5.ebuild
new file mode 100644
index 000000000000..31ff40e7e342
--- /dev/null
+++ b/dev-python/moto/moto-5.0.5.ebuild
@@ -0,0 +1,153 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Mock library for boto"
+HOMEPAGE="
+ https://github.com/getmoto/moto/
+ https://pypi.org/project/moto/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-xray-sdk-0.93[${PYTHON_USEDEP}]
+ dev-python/boto3[${PYTHON_USEDEP}]
+ >=dev-python/botocore-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/cfn-lint-0.40.0[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.3.1[${PYTHON_USEDEP}]
+ dev-python/cookies[${PYTHON_USEDEP}]
+ >=dev-python/docker-3.0.0[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-cors[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.5[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.10.1[${PYTHON_USEDEP}]
+ >=dev-python/jsondiff-1.1.2[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-3.0.7[${PYTHON_USEDEP}]
+ >=dev-python/openapi-spec-validator-0.5.0[${PYTHON_USEDEP}]
+ dev-python/pyaml[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-jose[${PYTHON_USEDEP}]
+ >=dev-python/responses-0.15.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5[${PYTHON_USEDEP}]
+ dev-python/sshpubkeys[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zipp[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_firehose/test_firehose_put.py::test_put_record_http_destination
+ tests/test_firehose/test_firehose_put.py::test_put_record_batch_http_destination
+ # broken code (local variable used referenced before definition)
+ tests/test_appsync/test_appsync_schema.py
+ # Needs network (or docker?) but not marked as such, bug #807031
+ # TODO: report upstream
+ tests/test_awslambda/test_lambda_layers_invoked.py::test_invoke_local_lambda_layers
+ tests/test_batch/test_batch_jobs.py::test_cancel_pending_job
+ tests/test_batch/test_batch_jobs.py::test_cancel_running_job
+ tests/test_batch/test_batch_jobs.py::test_container_overrides
+ tests/test_batch/test_batch_jobs.py::test_dependencies
+ tests/test_batch/test_batch_jobs.py::test_failed_dependencies
+ tests/test_batch/test_batch_jobs.py::test_failed_job
+ tests/test_batch/test_batch_jobs.py::test_submit_job_array_size
+ tests/test_batch/test_batch_jobs.py::test_terminate_job
+ tests/test_batch/test_batch_jobs.py::test_terminate_nonexisting_job
+ tests/test_cloudformation/test_cloudformation_custom_resources.py::test_create_custom_lambda_resource__verify_cfnresponse_failed
+
+ tests/test_cloudformation/test_cloudformation_stack_integration.py::test_lambda_function
+ tests/test_core/test_docker.py::test_docker_is_running_and_available
+ tests/test_core/test_request_passthrough.py
+ tests/test_core/test_responses_module.py::TestResponsesMockWithPassThru::test_aws_and_http_requests
+ tests/test_core/test_responses_module.py::TestResponsesMockWithPassThru::test_http_requests
+ tests/test_events/test_events_lambdatriggers_integration.py::test_creating_bucket__invokes_lambda
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events0-ObjectCreated:Put]"
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events1-ObjectCreated:Put]"
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events3-ObjectCreated:Put]"
+ # TODO
+ tests/test_sqs/test_sqs_integration.py::test_invoke_function_from_sqs_queue
+ tests/test_sqs/test_sqs_integration.py::test_invoke_function_from_sqs_fifo_queue
+ # require py_partiql_parser
+ tests/test_s3/test_s3_select.py
+ tests/test_dynamodb/test_dynamodb_statements.py
+ # require joserfc
+ tests/test_apigateway/test_apigateway.py::test_update_authorizer_configuration
+ tests/test_apigateway/test_apigateway.py::test_create_authorizer
+ tests/test_apigateway/test_apigateway.py::test_delete_authorizer
+ tests/test_cognitoidp/test_cognitoidp_exceptions.py::TestCognitoUserDeleter::test_authenticate_with_signed_out_user
+ No
+ tests/test_cognitoidp/test_cognitoidp_exceptions.py::TestCognitoUserPoolDuplidateEmails::test_use_existing_email__when_email_is_
+ -
+ tests/test_cognitoidp/test_cognitoidp_exceptions.py::TestCognitoUserPoolDuplidateEmails::test_use_existing_email__when_username_
+ -
+ tests/test_cognitoidp/test_cognitoidp_replay.py::TestCreateUserPoolWithPredeterminedID::test_different_seed
+ No
+ tests/test_cognitoidp/test_cognitoidp_replay.py::TestCreateUserPoolWithPredeterminedID::test_same_seed
+ tests/test_cognitoidp/test_server.py::test_sign_up_user_without_authentication
+ tests/test_cognitoidp/test_server.py::test_admin_create_user_without_authentication
+ )
+ local EPYTEST_IGNORE=(
+ # require joserfc
+ tests/test_cognitoidp/test_cognitoidp.py
+ # require antlr4 (which doesn't support py3.12)
+ tests/test_stepfunctions/parser
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x TZ=UTC
+
+ local serial_tests=(
+ # these tests set up credentials that are needed by the tests below
+ tests/test_core/test_importorder.py
+ # these tests apparently rely on some other test setting credentials
+ # up for them, so they need to be run separately, after the above
+ tests/test_awslambda_simple/test_lambda_simple.py::test_run_function{,_no_log}
+ tests/test_dynamodb/exceptions/test_dynamodb_exceptions.py
+ tests/test_dynamodb/exceptions/test_dynamodb_transactions.py::test_transaction_with_empty_key
+ tests/test_dynamodb/test_dynamodb.py::test_transact_write_items_failure__return_item
+ tests/test_dynamodb/test_dynamodb.py::test_transact_write_items_put_conditional_expressions
+ tests/test_dynamodb/test_dynamodb_update_expressions.py::test_update_different_map_elements_in_single_request
+ tests/test_events/test_events.py::test_start_replay_send_to_log_group
+ tests/test_lakeformation/test_resource_tags_integration.py
+ tests/test_redshiftdata
+ tests/test_resourcegroupstaggingapi/test_server.py::test_resourcegroupstaggingapi_list
+ tests/test_s3/test_s3.py::test_delete_bucket_cors
+ tests/test_s3/test_s3.py::test_delete_objects_percent_encoded
+ tests/test_s3/test_s3.py::test_delete_versioned_bucket_returns_metadata
+ tests/test_s3/test_s3_copyobject.py::test_copy_key_boto3_with_args
+ tests/test_s3/test_s3_copyobject.py::test_copy_key_boto3_with_args__using_multipart
+ tests/test_s3/test_s3_file_handles.py::TestS3FileHandleClosuresUsingMocks
+ tests/test_s3/test_s3_list_object_versions.py
+ tests/test_s3/test_s3_tagging.py
+ tests/test_s3control/test_s3control_access_points.py::test_delete_access_point
+ tests/test_utilities/test_threaded_server.py::TestThreadedMotoServer::test_server_can_handle_multiple_services
+ tests/test_utilities/test_threaded_server.py::TestThreadedMotoServer::test_server_is_reachable
+ )
+
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ EPYTEST_DESELECT+=( "${serial_tests[@]}" )
+ epytest -m 'not network'
+}
diff --git a/dev-python/rapidfuzz/Manifest b/dev-python/rapidfuzz/Manifest
index 7f7c3be85452..ae9ccf3acdc2 100644
--- a/dev-python/rapidfuzz/Manifest
+++ b/dev-python/rapidfuzz/Manifest
@@ -1,5 +1,7 @@
DIST rapidfuzz-3.6.2.tar.gz 1556623 BLAKE2B aef59f1d03309535015e0fb27688613630c0e2c459f464223d4ef8dbbb0241f991ae2b9c9d81890f7cd063f33ad7e6193a6f9c98c5287010402b402e1f343b1e SHA512 83ba27ec1c68d10c568ee629519709113aac3136e73da55d46dcfd3b0f1eac2ebe8631376ca10d2b5fde892d690d79f5a8ce5fd0114502d1f3576756b0960db7
DIST rapidfuzz-3.7.0.tar.gz 1569549 BLAKE2B fca22e86c002eeef7763487168d072941bbaefc7fa9cb9d5ae3d3f49e3a4487d69917da6663436cfc73ca38c67f2fc3a985e82dd64fe430aabc3708efada8513 SHA512 058fee9dc4d6934bf7b0e10eb8cc39303b6b4b67562c3b2244ec9035b1d5c3301aaf1570aa26099a6f3a6c0e7b52c387a01fcd62be28f55ab755377d053eb7f5
+DIST rapidfuzz-3.8.0.tar.gz 1591944 BLAKE2B e1702ec1b3da02cb77ee5bda6775e9f22b16122f798c6884fb1f17b61f1a62f4c493c9d6ffb1af54517eec2167b59782edd5ae0b31ed0caade673d81557e4ea3 SHA512 ae41b27386ef865ca8063591564e1f1a874bdfc838387bd51fd766adbc71d4eeab6122d6ef927ddd5603e2f5e914023741382a52caf3292f0e1dcd4392e9714c
EBUILD rapidfuzz-3.6.2.ebuild 1629 BLAKE2B 8fe035b6a492ce9aa9ce00b13b96dab43d5c022dd7ad749291ac200defad858e0cb4902cbf64080809c25faa5f4e878103b5121d0bf9aca89da327d9e25ea1b5 SHA512 0ba392552a461ffe573cb99b318b600000e0e8edd5d8b9b2fd2470195bfa2520c31c2563c270c7dd91ed2251b5c14e701f105d06b7996f6b325ecdbfa6b545ef
EBUILD rapidfuzz-3.7.0.ebuild 1636 BLAKE2B 05b0140e907e45c2e54c873cffc6f8b12f36acd5d61b72f0c0d492163a3ce58809395ffea45bbc0ac445b85951a600c776af46b5e2a8e147a3e387e43e5eba68 SHA512 0fb0fe112b49ca1a9713bd03afb83590a5aba9960b06e4ea5c80a14168603ba4a12dc3d60400fd04e097b7a29dd3dc7a48c942e21aaf4ab30e83831ef893054e
+EBUILD rapidfuzz-3.8.0.ebuild 1636 BLAKE2B 05b0140e907e45c2e54c873cffc6f8b12f36acd5d61b72f0c0d492163a3ce58809395ffea45bbc0ac445b85951a600c776af46b5e2a8e147a3e387e43e5eba68 SHA512 0fb0fe112b49ca1a9713bd03afb83590a5aba9960b06e4ea5c80a14168603ba4a12dc3d60400fd04e097b7a29dd3dc7a48c942e21aaf4ab30e83831ef893054e
MISC metadata.xml 372 BLAKE2B 79ce98b986a4193ec72cfc1ef0a1e1970e2e6333da3dc0abdc24de4148932c4f81e68a4d85cedf308d79ee5fe61c1d2573889fe4f89025b7b4848caf4380596c SHA512 014b2de4c7eb3976799f76ca01c59585be12ff0718cb8378ce0aabf40113d8fd402e0a8ef26fd8924ee0840fa7e99677e5e31698180a0537a0627c464c29e34e
diff --git a/dev-python/rapidfuzz/rapidfuzz-3.8.0.ebuild b/dev-python/rapidfuzz/rapidfuzz-3.8.0.ebuild
new file mode 100644
index 000000000000..07d8d11d86eb
--- /dev/null
+++ b/dev-python/rapidfuzz/rapidfuzz-3.8.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+# custom wrapper over setuptools
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 multiprocessing pypi
+
+DESCRIPTION="Rapid fuzzy string matching in Python using various string metrics"
+HOMEPAGE="
+ https://github.com/rapidfuzz/RapidFuzz/
+ https://pypi.org/project/rapidfuzz/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# all these are header-only libraries
+DEPEND="
+ >=dev-cpp/taskflow-3.0.0
+ >=dev-cpp/rapidfuzz-cpp-3.0.2
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/cython-3[${PYTHON_USEDEP}]
+ dev-python/rapidfuzz-capi[${PYTHON_USEDEP}]
+ >=dev-python/scikit-build-0.16.2[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # sterilize build flags
+ sed -i -e '/CMAKE_INTERPROCEDURAL_OPTIMIZATION/d' CMakeLists.txt || die
+ # remove bundled libraries
+ rm -r extern || die
+ # force recythonization
+ find src -name '*.cxx' -delete || die
+
+ distutils-r1_src_prepare
+
+ export RAPIDFUZZ_BUILD_EXTENSION=1
+}
+
+python_compile() {
+ distutils-r1_python_compile
+
+ # scikit-build is broken and reuses the same build
+ # https://github.com/scikit-build/scikit-build/issues/633
+ rm -r _skbuild || die
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p xdist -n "$(makeopts_jobs)" --dist=worksteal
+}
diff --git a/dev-python/send2trash/Manifest b/dev-python/send2trash/Manifest
index 015c5725c147..b6c837a0e9fe 100644
--- a/dev-python/send2trash/Manifest
+++ b/dev-python/send2trash/Manifest
@@ -1,3 +1,5 @@
DIST Send2Trash-1.8.2.tar.gz 17487 BLAKE2B 3362a7e0c70f0e3f0f7a64676174d6c6f28290079590e08e4a746c0e19f96deca028aa521df58afa7f0ab47d78f286df01f98e903dfd771063af0ff40b4f6c08 SHA512 378107c8175e8d08566258daa13d3000e66ec03f732698180a2eb7f862c39d3c458be66ecf3f8864f559b961e29b777b8e7f5169468219e19723def62a69bb9c
+DIST Send2Trash-1.8.3.tar.gz 17394 BLAKE2B 55f382ae81b2279214023daad3a7a8ac0d5f55ebbbe9a2c7af02d35b980f3342ecc5f9b4e734d3c233b65a1fdd058ed856b7a96f3685ebbf1eb4c7dd9d37e159 SHA512 81b9d6ce00830414daac0e1cafe2b69d42b750146f45e64c27750ee8f6d81f771145852a96bf51afa944d8c31959b8c9ac1b5e05c8793732039b690107789d93
EBUILD send2trash-1.8.2.ebuild 554 BLAKE2B 8ae061a18204379f0965cd04dbbb82083b4810f38a418ab13066bd6eddc624e34d533b7e57323465ebfd7e3199959c3593994c13f557f6e21a691dec4fc81902 SHA512 d32e3492985e53094bf5b6dbc58c349e88d9001169f8194809c990072f0acd4f0e20a394f472a5544b1c1bc418ef173732962efaf9228e3767b84b260a35b92b
+EBUILD send2trash-1.8.3.ebuild 562 BLAKE2B 579e8bd368f57f0ac5df15574305f4e704312615a9813adb08068edf2c886cb5054978ec51575847caa09b0cc39833eece44aa64bd4d33fe2e8cc732b3f6f875 SHA512 1149bcdaa2d30429926d7755904f78dee9572317e5d999906d6b14c4fdbc4684e4f6ea48481a9642718b968fdf66791ab63cb62f363a36a67316115e09e498f4
MISC metadata.xml 411 BLAKE2B bc650bdcb346ddb4c94fff51727b5ae9f2ae1cb62d0fe52709b531fd779fb4b5342f8c200a924816763b3b21354849b320a92050d62d243a48e862f46c997d9b SHA512 b5ba72495ce17919eedb91021749653ec411d1df1188520f95a4db28efbfc9c59d291c23e54014430be77fbf961a0662f25539805086b5b284b992520f5dcc22
diff --git a/dev-python/send2trash/send2trash-1.8.3.ebuild b/dev-python/send2trash/send2trash-1.8.3.ebuild
new file mode 100644
index 000000000000..816b76361a12
--- /dev/null
+++ b/dev-python/send2trash/send2trash-1.8.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=Send2Trash
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sends files to the Trash (or Recycle Bin)"
+HOMEPAGE="
+ https://github.com/arsenetar/send2trash/
+ https://pypi.org/project/Send2Trash/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest