summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin261399 -> 261401 bytes
-rw-r--r--dev-python/grpcio-testing/Manifest2
-rw-r--r--dev-python/grpcio-testing/grpcio-testing-1.51.0.ebuild24
-rw-r--r--dev-python/grpcio-tools/Manifest4
-rw-r--r--dev-python/grpcio-tools/grpcio-tools-1.43.0-r1.ebuild (renamed from dev-python/grpcio-tools/grpcio-tools-1.43.0.ebuild)4
-rw-r--r--dev-python/grpcio-tools/grpcio-tools-1.51.0.ebuild36
-rw-r--r--dev-python/grpcio/Manifest5
-rw-r--r--dev-python/grpcio/files/1.51.0-respect-cc.patch28
-rw-r--r--dev-python/grpcio/grpcio-1.43.0-r1.ebuild (renamed from dev-python/grpcio/grpcio-1.43.0.ebuild)2
-rw-r--r--dev-python/grpcio/grpcio-1.51.0.ebuild48
-rw-r--r--dev-python/piexif/Manifest1
-rw-r--r--dev-python/piexif/piexif-1.1.3-r2.ebuild39
12 files changed, 188 insertions, 5 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index 1303c62e02e0..7eefa9719c06 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/grpcio-testing/Manifest b/dev-python/grpcio-testing/Manifest
index c32ac9ea68ad..2487ce9711ef 100644
--- a/dev-python/grpcio-testing/Manifest
+++ b/dev-python/grpcio-testing/Manifest
@@ -1,3 +1,5 @@
DIST grpcio-testing-1.43.0.tar.gz 17693 BLAKE2B f75158a870b63c48d19e849f87e4682c13a1d500690ff0f39d0d609c3de2f3086765dc7fe15acd590667fcc8ab8ce5d149517be5cbbb685bc222619b23e367a8 SHA512 4ad3da7805e85c0869c5a8c992d1512942334edeef10812665bdfb4a81b3d07efff08686b93c501f43d12e0c6181717ddbea392f1751a229d7a5fe26f162fae2
+DIST grpcio-testing-1.51.0.tar.gz 22390 BLAKE2B 813ade1f3f44e3aeda7ca779f130897281036de111cb17f9297f267961a591e1fa3b88380ccbec42edd339487f1b3f1028dcd308c46ffd8fde5817e3909cfd41 SHA512 3fd9de9cd75aebcf1f6c3716bbacaf5cc9cc9aa74acb42dd128b5c158fa2d52549cdcc8f3ea9f2cb0b86d0b84c998acd55fa16e879ac9099a2348d889d35d837
EBUILD grpcio-testing-1.43.0.ebuild 488 BLAKE2B 3f303bf15b800b01c999ff7b283137facaa78d47adaf511ec456cab179c306f40ace6a0fb5f7684f66f3cbe2ba8f17c0f533b7620471bc562c5bcb4a0aa2bb6c SHA512 f65e2cc4411436daa412a0bc5dd073c8942dc456b7bf9daaa709eae338f94fc3cad577e4d0989ae841c2866c7b6140d417fdf289afb69d22b6c5c2a503508d5e
+EBUILD grpcio-testing-1.51.0.ebuild 578 BLAKE2B 8692b2b65a5293040571266cd4a74c18e7725591f960647603722c75f4624016503de58de217af185219f1c8ce3b7219b20b6c40bb0bc077d51293c806c11dc3 SHA512 b1e41d3cb92a8e679e74a3db4176362e653d2cc6320f4e598dad9f237cc51ae6b9ad9c9f8d81cae479dfc079353917f2d344179b2838649787b3362426944333
MISC metadata.xml 378 BLAKE2B bd4fcbd45d6b8892ced059de5457506a61573264ec9533ffa06f3076e0c72908e3565930e8cf200f87def824d26fb8e184dd358ad04e02b5642f7cc24b087e9f SHA512 73109d9926eb1dfa38add772e095d8765a8cfee436168cf6bb4541ed58cf441dbb84075c72d2d33e4535af3661948ace21657b7814456a5f708d6d612faa3386
diff --git a/dev-python/grpcio-testing/grpcio-testing-1.51.0.ebuild b/dev-python/grpcio-testing/grpcio-testing-1.51.0.ebuild
new file mode 100644
index 000000000000..b65b69efba23
--- /dev/null
+++ b/dev-python/grpcio-testing/grpcio-testing-1.51.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Testing utilities for gRPC Python"
+HOMEPAGE="https://grpc.io"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ ~dev-python/grpcio-${PV}[${PYTHON_USEDEP}]
+ <dev-python/protobuf-python-5[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-4.21.3[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}"
diff --git a/dev-python/grpcio-tools/Manifest b/dev-python/grpcio-tools/Manifest
index 33a08568d861..6acc465b7acf 100644
--- a/dev-python/grpcio-tools/Manifest
+++ b/dev-python/grpcio-tools/Manifest
@@ -1,3 +1,5 @@
DIST grpcio-tools-1.43.0.tar.gz 2210483 BLAKE2B 5daab31940dc5a21fbfea0985f6056361375be1b45f1a00e9345dc25808050193e20c9316d2a2a18d9a5f503787506f6d76a3bdf95ac6b3b7525873076b9d1e0 SHA512 60a5fa62fc1a81b5a57b47aca212ed94913ca20c3c1055dac18101776177fc0b18cc480c7356332e3eb4cf7819634ddc53d2e77f7c4b582a0fa53e26053f3ed4
-EBUILD grpcio-tools-1.43.0.ebuild 791 BLAKE2B 04b759212d5f7e62e2fdad154a261cc071895e9bd3bb47ca84d44867a29135e0a234d7e56d5d561568bf964ec8b777f91a2fe9484bd36210fdb9d09b36428529 SHA512 aa28e6ee249ef8bfb85a751bd930aa6a7d0f47baf0e8867eaa4b652e299caa7ccd8ea26c4cb53dbb58dc42d5c7f52180fb2b1e3c93d69f206c48d23ab9ecf8a4
+DIST grpcio-tools-1.51.0.tar.gz 2254565 BLAKE2B 7486c7c62d691cb3cbaf02a68e73d6d94ee48396b26c4d46c22776396ba7d637c9b6738c00e19a99101e189e7092b2240adbf53ae9d32188dc813a9b0a49c25d SHA512 fa76fd970c399aed7639d6ce343834a5e7d76f2247cc99e59d0bf29844fb2f366bc9b8e2124d7c9dd9163953741c06015ded7f400b8e77d0cdad8ac291a7af83
+EBUILD grpcio-tools-1.43.0-r1.ebuild 794 BLAKE2B c63470e9b17d347cccacda2e860764af05504be7a2ce1eeb83649085b163c20e7fdd0e922aff1815c05305cc562acd0b1703d949be2e63eee5a66945d04087d7 SHA512 d0fea2bc1c4299de1ba3a08d38ded5a1fdbee91eaf092a91f438a5f222da4517d87eab874648b60f8c57462496fb28debf87208432598a8b098a717e31d8479d
+EBUILD grpcio-tools-1.51.0.ebuild 848 BLAKE2B f297dfc086be476f277dbb71c1669e6b79071c3bab0b7d0bd6062ad352fc78d8c58d76ca81229a7fa6450e0c74fb9bd846f0c6ab5ffc1c8ef516baa2a2465aa1 SHA512 516a01f3759377657ccb5173cbe855213e71eb10d237eedbf9995be84efb8e252914615e1b872d9bfc4560a70eda367e67ab0dcb72f2ccc3c3b980ccb2c3e821
MISC metadata.xml 376 BLAKE2B e5cdaf58121264aa01fca1e7466b497ebdfccebcebef9ff8a6eab4378e5031115c3cf64469dfdd0902b8b1f76ab2ccbe460239627d3d0590e6ddd772c04d7639 SHA512 a55fa742c61014334fb41be9dba20bc42caf767bdddbcc92e227ac643d368668603a3b4f4402cb2393e0ae4af0fcb74fd5a6784c3a7be17afed8c21ab338b0bb
diff --git a/dev-python/grpcio-tools/grpcio-tools-1.43.0.ebuild b/dev-python/grpcio-tools/grpcio-tools-1.43.0-r1.ebuild
index e37b35397828..f4e92a2243c2 100644
--- a/dev-python/grpcio-tools/grpcio-tools-1.43.0.ebuild
+++ b/dev-python/grpcio-tools/grpcio-tools-1.43.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -19,7 +19,7 @@ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
RDEPEND="
dev-python/cython[${PYTHON_USEDEP}]
~dev-python/grpcio-${PV}[${PYTHON_USEDEP}]
- dev-python/protobuf-python[${PYTHON_USEDEP}]
+ <dev-python/protobuf-python-4[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}"
diff --git a/dev-python/grpcio-tools/grpcio-tools-1.51.0.ebuild b/dev-python/grpcio-tools/grpcio-tools-1.51.0.ebuild
new file mode 100644
index 000000000000..bb067461a7b0
--- /dev/null
+++ b/dev-python/grpcio-tools/grpcio-tools-1.51.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 multiprocessing prefix
+
+DESCRIPTION="Protobuf code generator for gRPC"
+HOMEPAGE="https://grpc.io"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ ~dev-python/grpcio-${PV}[${PYTHON_USEDEP}]
+ <dev-python/protobuf-python-5[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-4.21.3[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ hprefixify setup.py
+}
+
+python_configure_all() {
+ export GRPC_PYTHON_BUILD_WITH_CYTHON=1
+ export GRPC_PYTHON_BUILD_EXT_COMPILER_JOBS="$(makeopts_jobs)"
+}
diff --git a/dev-python/grpcio/Manifest b/dev-python/grpcio/Manifest
index d5fddc32fb7d..bac8f48202aa 100644
--- a/dev-python/grpcio/Manifest
+++ b/dev-python/grpcio/Manifest
@@ -1,4 +1,7 @@
AUX 1.37.1-cc-flag-test-fix.patch 1053 BLAKE2B c2f6b0a506fc2d074e656db3081447b3a0521a2ed2bd14a19104b962e0ad45b0068116384403eaf199d2bb8027b4a260dfaa7ed274974ad0bb6ca56b9ad19e8b SHA512 72dc39d549a008d137db29aa446ab7fc0add575103e941a969bed0124ce3b285f27edc31ca06db71b2dd3232c77c280755de3d3ef257792ead0516122f0a9b3f
+AUX 1.51.0-respect-cc.patch 1156 BLAKE2B a952509c19c3da336f42f06595986e26e75487c6f0ebb75c1493ec98f57c14fe1859141f06f82bcbc6ef0cec762d99cda962ddeca204bf104691d2636a7d51a0 SHA512 c8e0cc7ff325f94c856bd9c22a17ada367f580c9eef9d465fce335ea7b6441ddcd33f36f730e61c02deac3099df65086a3772b8a2fae6a691614d87b72bc472e
DIST grpcio-1.43.0.tar.gz 21461955 BLAKE2B 406a341d24bf418a006b3f86c25254f3bb3981fd20123fd2d99d53d73e04b8da5500b7d871d8e3d96d1167a1306fd66a05cff418d1af8ff3eba9bb3faa34a199 SHA512 c4e9c7d20e53653c014d3c301f572df26ae84beb8d04fc3d763afcb695d232416ed8e7822f93bed1f9d8aab44f08aaaf36bf2f05aaa6bc3607428efbc0775cb1
-EBUILD grpcio-1.43.0.ebuild 1264 BLAKE2B f5ff9ef22d084e2a474625c9af4edc05a4c30e6105675d56afae15ddfcc404093f80e1bf6674bb014a5dae91545dbd65057e4d1987152f4f1a85cf84eb3d3d19 SHA512 03587c602015b0c7ec5e4a879e40fb6da27650d4aefa72294cceff8d6dd7afdfc15e6ea5f615206d0c45e8cd745d9590e232ea2fcc8f4a7436f6eb2c08d17ad0
+DIST grpcio-1.51.0.tar.gz 22142437 BLAKE2B 20acb52c89e41cd6e87ddb5554bcf79acc6fa18f4516c7be7a3fa1408ecb1e5800d6123bd7ac561093ca341344618de9701c3df75251e96cd9da5a3443568303 SHA512 3560e07df79143cb7a8a0a1f0dbaba2d164962ba712adf030a60654102bbd5ce6a08f88c133b81a3e471f1ec3d63de14f1b0567aa45bd641d958d3349ccef542
+EBUILD grpcio-1.43.0-r1.ebuild 1267 BLAKE2B aaa07edeb5e7b24d99f92d31b1a5380acfe7d2c76a2aabce73409cb6e7a5897b494cdba48e306eb504b95f812102e563d1d304e03bb3cd4fcbecb52e6ae93266 SHA512 43f3671a886d397e679a91f984155609973506ceba163e6a8bdbab1bb5edb188d5090fd135cd23cb0ae70eeb31184a17ba3c452f533421a5c1638f2edd248b70
+EBUILD grpcio-1.51.0.ebuild 1316 BLAKE2B 425e269452ca81b48222ccc29162370025907e0df88e3842d160744af70d36a8a93326da0d7667d48fb9953d8275d12779f2edf6410d81d3d902d25a39c21a6e SHA512 183ca216b6b438ceba60e791326d97bb67b8c269fe36611e0d690b30e49e0db7a6e2557035a71a3a11df33c6d937a9063d2f2cf4025f700c92080cc2f08d1a94
MISC metadata.xml 370 BLAKE2B bbd9d12e5aa11226329f88cdbe81b254078778ec32656c0e8e07728ae8e88a631031075111fa172ac7977164f928ab5b4d7a6fccdb05fe382bbbcfc3db0fcb48 SHA512 8452b06521b0d315bb7e2ceb8ded673383a5364e5b46c494083a7f92129d3ac1c607197679111157716dfc3c5d7bbb60459cd4f1d7c23d9fe2bb5b2ef2792383
diff --git a/dev-python/grpcio/files/1.51.0-respect-cc.patch b/dev-python/grpcio/files/1.51.0-respect-cc.patch
new file mode 100644
index 000000000000..8a2c8313aa8f
--- /dev/null
+++ b/dev-python/grpcio/files/1.51.0-respect-cc.patch
@@ -0,0 +1,28 @@
+From 209e9e0c21dd5bdf62d943dfd9caca40565734b5 Mon Sep 17 00:00:00 2001
+From: Georgy Yakovlev <gyakovlev@gentoo.org>
+Date: Mon, 28 Nov 2022 14:08:17 -0800
+Subject: [PATCH] respect CC variable
+
+https://github.com/grpc/grpc/pull/26480
+Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
+---
+ src/python/grpcio/commands.py | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/src/python/grpcio/commands.py b/src/python/grpcio/commands.py
+index 58ab57be47..6d8228ffa0 100644
+--- a/src/python/grpcio/commands.py
++++ b/src/python/grpcio/commands.py
+@@ -228,7 +228,8 @@ class BuildExt(build_ext.build_ext):
+ """
+ try:
+ # TODO(lidiz) Remove the generated a.out for success tests.
+- cc_test = subprocess.Popen(['cc', '-x', 'c', '-std=c++14', '-'],
++ cc = os.environ.get('CC', 'cc')
++ cc_test = subprocess.Popen([cc, '-x', 'c', '-std=c++14', '-'],
+ stdin=subprocess.PIPE,
+ stdout=subprocess.PIPE,
+ stderr=subprocess.PIPE)
+--
+2.38.1
+
diff --git a/dev-python/grpcio/grpcio-1.43.0.ebuild b/dev-python/grpcio/grpcio-1.43.0-r1.ebuild
index cbd51222c6c7..e27ff7b932cd 100644
--- a/dev-python/grpcio/grpcio-1.43.0.ebuild
+++ b/dev-python/grpcio/grpcio-1.43.0-r1.ebuild
@@ -19,7 +19,7 @@ RDEPEND="
>=dev-libs/openssl-1.1.1:0=[-bindist(-)]
>=dev-libs/re2-0.2021.11.01:=
>=dev-python/cython-0.28.3[${PYTHON_USEDEP}]
- dev-python/protobuf-python[${PYTHON_USEDEP}]
+ <dev-python/protobuf-python-4[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
net-dns/c-ares:=
sys-libs/zlib:=
diff --git a/dev-python/grpcio/grpcio-1.51.0.ebuild b/dev-python/grpcio/grpcio-1.51.0.ebuild
new file mode 100644
index 000000000000..316ccdb61a70
--- /dev/null
+++ b/dev-python/grpcio/grpcio-1.51.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 multiprocessing prefix
+
+DESCRIPTION="High-performance RPC framework (python libraries)"
+HOMEPAGE="https://grpc.io"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-libs/openssl-1.1.1:0=[-bindist(-)]
+ >=dev-libs/re2-0.2021.11.01:=
+ >=dev-python/cython-0.28.3[${PYTHON_USEDEP}]
+ <dev-python/protobuf-python-5[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-4.21.3[${PYTHON_USEDEP}]
+ net-dns/c-ares:=
+ sys-libs/zlib:=
+"
+
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/1.51.0-respect-cc.patch" )
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ hprefixify setup.py
+}
+
+python_configure_all() {
+ # os.environ.get('GRPC_BUILD_WITH_BORING_SSL_ASM', True)
+ export GRPC_BUILD_WITH_BORING_SSL_ASM=
+ export GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY=1
+ export GRPC_PYTHON_BUILD_SYSTEM_CARES=1
+ export GRPC_PYTHON_BUILD_SYSTEM_OPENSSL=1
+ export GRPC_PYTHON_BUILD_WITH_SYSTEM_RE2=1
+ export GRPC_PYTHON_BUILD_SYSTEM_ZLIB=1
+ export GRPC_PYTHON_BUILD_WITH_CYTHON=1
+ export GRPC_PYTHON_BUILD_EXT_COMPILER_JOBS="$(makeopts_jobs)"
+}
diff --git a/dev-python/piexif/Manifest b/dev-python/piexif/Manifest
index e24c38997012..f76362722190 100644
--- a/dev-python/piexif/Manifest
+++ b/dev-python/piexif/Manifest
@@ -1,4 +1,5 @@
AUX piexif-1.1.3-tests-pillow-7.2.0.patch 1382 BLAKE2B c7ea03ffe0708b975d64602910bf9c228f0093d9cb717a1b1b9f3e7b6358b94f3bcbd6da8f9bac12fe2ee0745d17defccd196bdd8ec018fea50b7d131e148616 SHA512 be1ee541e3bb6c219d6fd9ab68e9143c2131f695a2001d36a0d63b0566d71a542a09d58dc0bcbdb8c1353297156ea7853d483b9a44407cb31c30acc4252310bf
DIST piexif-1.1.3.zip 1011134 BLAKE2B b27d4419cf545f6205b13c5646dff9fc7b1ce6e5de538f6a7189e6cadb54d301e11cbf0feaed8b073cbf16de95d67c621b68657b35fc0ba2025281ee64be4e51 SHA512 df5f7793c39911af58bbae76cf998e2a7bc820b84dcf9808ee8f6a38f766f824fef28392ef88387e18b10c270c4b27881be310f0368076b6fb65379a11a93270
EBUILD piexif-1.1.3-r1.ebuild 827 BLAKE2B cae7df00b4c42c480ceaa0b6cfae4e39d42ab44c1779b88d4ca19241ac0ccee8846a614c8ee1bb705e35e60a4a9482b587453f7b58709579031d76775ce99dbf SHA512 f34dde462ce0954cdafd78ca71a87e64451a8af44e3a74cab1fe578385e9c81b03beb4446db4e63d0d8d2e8a20104bc30b18aba8574c3824044b08b3a2d95152
+EBUILD piexif-1.1.3-r2.ebuild 860 BLAKE2B ff796d57fb9a1fa4e4d015446f98ec78b70b98bffc324a023db63738cbb4809c1bd647dcb7e5428250d9791dd2a414ba05d2674820726b72576ce4e6cf24af09 SHA512 170b66ec51721262d1ffcb05d6c4715a98d67eb2fc444930f793589aab25c940e035f0ffbac9f914d26082e8e8b2e1c1a7f96994bb7bb404ce0f76c80193b5d6
MISC metadata.xml 364 BLAKE2B 2ef968ac973776979f74c1ff510b657d691d7cfd1b963b04faed752e4dedfea8f325357b95ea9abede883a8ead27016bd2b657be119902fa21f9bef6ea2ebb0c SHA512 c62c0ee0303599f10b04701183db691da926fb3176f5ad5efcf58782c50280e03dcf5772ab1d033d3dc96730a2ad87c19ce9749a9c0ce2dd3dfdde76d2466eb7
diff --git a/dev-python/piexif/piexif-1.1.3-r2.ebuild b/dev-python/piexif/piexif-1.1.3-r2.ebuild
new file mode 100644
index 000000000000..44ecb4c39ee1
--- /dev/null
+++ b/dev-python/piexif/piexif-1.1.3-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit edos2unix distutils-r1
+
+DESCRIPTION="Exif manipulation with pure Python"
+HOMEPAGE="https://github.com/hMatoba/Piexif
+ https://pypi.org/project/piexif/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ app-arch/unzip
+ test? ( dev-python/pillow[jpeg,${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+PATCHES=(
+ # From https://github.com/hMatoba/Piexif/pull/109
+ "${FILESDIR}"/${P}-tests-pillow-7.2.0.patch
+)
+
+src_prepare() {
+ edos2unix tests/s_test.py # to be able to patch it
+ default
+}
+
+python_test() {
+ "${PYTHON}" setup.py test || die
+}