summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin259013 -> 259014 bytes
-rw-r--r--dev-python/ipyparallel/Manifest1
-rw-r--r--dev-python/ipyparallel/files/ipyparallel-8.3.0-additional-test-timeouts.patch46
-rw-r--r--dev-python/pip/Manifest2
-rw-r--r--dev-python/pip/files/pip-20.0.2-disable-system-install.patch29
-rw-r--r--dev-python/pip/files/pip-22.2.1-no-coverage.patch52
-rw-r--r--dev-python/pulsectl/Manifest2
-rw-r--r--dev-python/pulsectl/pulsectl-23.5.2.ebuild30
8 files changed, 32 insertions, 130 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index 9e1f71d0c728..486c30681ab5 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/ipyparallel/Manifest b/dev-python/ipyparallel/Manifest
index 4a833af81a04..756e0c46d8e9 100644
--- a/dev-python/ipyparallel/Manifest
+++ b/dev-python/ipyparallel/Manifest
@@ -1,5 +1,4 @@
AUX ipyparallel-7.1.0-test-timeouts.patch 2067 BLAKE2B 577b33b730f110775dbd61fe02d06834fe3c4eb3c730d6df16730bbc877402e9f4756b74691bb977c3892ff981d374a4d1b439bf2b682e76c496ce8502f26583 SHA512 2d0f9fb4966be06299b40cd2ad974b4f94cfedea84fcee38b900ce4596b15cd3963068fc374aa1c0e54765b92d68c5233965fd2d3696bba5474da24917d1f009
-AUX ipyparallel-8.3.0-additional-test-timeouts.patch 1707 BLAKE2B c3dc45f6b05fa7abf551d3b8a950e078a42a709a74d8fe8c45b88ab6afb7996f822550eadf46c54da18cb7596e25cc7ffc84b46e033803a665e323273669e0fe SHA512 9b7581e02571e498155a73ac573b8a994ed414f462cfdedc5a96d9d30dbdb7c44f9c1827f86232f2a0dc273f34901a46aa40a8822ebb11a74e0890660f2f77f4
DIST ipyparallel-8.6.1.tar.gz 6807935 BLAKE2B 23847974e9d5d1d06a64a6b01c845f539848c602b6ba6a22c64d8e0bd35a783ec3a09fc6618ae08490d35e49d497c1db61176f8c70065c4e61ec234a7fd00545 SHA512 e83447f9d52eed87e8513d2ee74d2d6b589a5c04b5bf6dfece6d87565dd9c5e46abd280eb5ab64266b2e759dec1007ab007d0b8232b6239768190bd6900f53ff
EBUILD ipyparallel-8.6.1.ebuild 2497 BLAKE2B c2a9729901bbeb2474322c18af5247d764f7b9eb0b14b6793656af89f2cc2306e4093b3389e5b6567b79e40762d8517af8559bd7e5be835618837bd764efc0ad SHA512 75af02db8f62c9429ab5e9bd7d05c3e013bde0ce1b7ac7671fc5fd838a364b51c292d3ae403f77d34034754e11ef1ca9a6dc4ad4565d57092b0af4a7cd0ab06c
MISC metadata.xml 531 BLAKE2B 92dd755dd3036f653f24eda893979487b8d5bbf3c369f3f10c3fc2e69ad6aef03cb6eca295bcb8c6f89f0838780c20132bfd2a33bb38b56b227e97258447c2e0 SHA512 fcd131d18b012d1511468777dd72e07ed28a514419923911082229c0256b9003d9afe2048b6c339cb5c94307026b52bc4e9b6781d45660178d18385d71af8f21
diff --git a/dev-python/ipyparallel/files/ipyparallel-8.3.0-additional-test-timeouts.patch b/dev-python/ipyparallel/files/ipyparallel-8.3.0-additional-test-timeouts.patch
deleted file mode 100644
index 22b2910d4d10..000000000000
--- a/dev-python/ipyparallel/files/ipyparallel-8.3.0-additional-test-timeouts.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-https://bugs.gentoo.org/834198
-
-diff --git a/ipyparallel/tests/test_view.py b/ipyparallel/tests/test_view.py
-index 5b5ca41..4c04d02 100644
---- a/ipyparallel/tests/test_view.py
-+++ b/ipyparallel/tests/test_view.py
-@@ -628,7 +628,7 @@ class TestView(ClusterTestCase):
- """exceptions in execute requests raise appropriately"""
- view = self.client[-1]
- ar = view.execute("1/0")
-- self.assertRaisesRemote(ZeroDivisionError, ar.get, 2)
-+ self.assertRaisesRemote(ZeroDivisionError, ar.get, 20)
-
- def test_remoteerror_render_exception(self):
- """RemoteErrors get nice tracebacks"""
-@@ -637,7 +637,7 @@ class TestView(ClusterTestCase):
- ip = get_ipython()
- ip.user_ns['ar'] = ar
- with capture_output() as io:
-- ip.run_cell("ar.get(2)")
-+ ip.run_cell("ar.get(20)")
-
- self.assertTrue('ZeroDivisionError' in io.stdout, io.stdout)
-
-@@ -649,7 +649,7 @@ class TestView(ClusterTestCase):
- ip.user_ns['ar'] = ar
-
- with capture_output() as io:
-- ip.run_cell("ar.get(2)")
-+ ip.run_cell("ar.get(20)")
-
- count = min(error.CompositeError.tb_limit, len(view))
-
-@@ -689,10 +689,10 @@ class TestView(ClusterTestCase):
- view = self.client[-1]
- ar = view.execute("%pylab inline")
- # at least check if this raised:
-- reply = ar.get(5)
-+ reply = ar.get(50)
- # include imports, in case user config
- ar = view.execute("plot(rand(100))", silent=False)
-- reply = ar.get(5)
-+ reply = ar.get(50)
- assert ar.wait_for_output(5)
- self.assertEqual(len(reply.outputs), 1)
- output = reply.outputs[0]
diff --git a/dev-python/pip/Manifest b/dev-python/pip/Manifest
index 89ab2fbd157e..e21e5e3c219d 100644
--- a/dev-python/pip/Manifest
+++ b/dev-python/pip/Manifest
@@ -1,5 +1,3 @@
-AUX pip-20.0.2-disable-system-install.patch 1298 BLAKE2B a384ee2114e59b8bc719fc14270cf6efbe8914854c404395beb1126db3278683b940e8fcfee83423d78e2aed6521e0bc57566ab0f5618f473262bbd9b7b0bffa SHA512 d2772105d4f4f880606e1e8ab3381af6768a96604a5fdcaa155dd42f8eea731c3a1b733b027d3e591d81f962ba14758b19da4a2c6c12946cd9a9d77c51ca4e78
-AUX pip-22.2.1-no-coverage.patch 1805 BLAKE2B 790a6736194d3ad7cadbb7965978f19c251a65b98b67c64726072f2baa24831f3e3788fdba560c247cde948183c6589b6edf18d5861468801e5729ba53c42995 SHA512 5fd775c0a1cb0f88c6c632a90294f11788916371b7d4bb8b378ed1530b461a9788f289a06d6619e66fcb45dd08a7063a749a608c5f12a778db84dfcbb5e79cba
AUX pip-23.1-no-coverage.patch 1836 BLAKE2B f8c95ed26d5a7cba2a516b8d134ddd9901fd7d39dc8bf174397ab2afab33e93c4af342195b5b4d7b0aedc642493f1ed2ee474c74e16e285f335dcdcf531b1777 SHA512 c63929cc5324b2a741a4c1ebb4990c376eb6a4c0f39370e456b674ce3cfbdf10471ec48cf9368fccba9264fd9d4a5667988116163e73772496f28d52986ff111
DIST pip-23.1.2.gh.tar.gz 9345911 BLAKE2B 511ac1a9405e377ccb2525e89676f4a63f138aa526d40e76f4d9681139d94db1f92772beab1a647654c17abc6bee09f52cf4c4f4484716874194565fda07d056 SHA512 b33070cb59a1258904a60b48ec8abfd9e316c5f87681fea13d89ddf6d516afac10965ae1db54fea299a0a72f98602ce02e8b3be46f239e857db84866045730e1
EBUILD pip-23.1.2.ebuild 4026 BLAKE2B a970df67010965d85241c5a5d5bc58410118629d261f8d8e26be7022656bdec423d0ff2957bde5b6f29351913eb5e83340161a8c682b46376fd24e4e524e4752 SHA512 b3b47eccb9aaabc58dbec65d9d16e7e3d6b78294c455184349d3cc5de2d0eaa9b94c0e1555d9f05a445237b759336e6b67e3aa94288107976d52649ec46010a1
diff --git a/dev-python/pip/files/pip-20.0.2-disable-system-install.patch b/dev-python/pip/files/pip-20.0.2-disable-system-install.patch
deleted file mode 100644
index e0b0034e407a..000000000000
--- a/dev-python/pip/files/pip-20.0.2-disable-system-install.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 3aee04cbb93c0e479b040e682b2aef676629c9a2 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Sat, 1 Feb 2020 09:14:46 +0100
-Subject: [PATCH] install: Raise an error to avoid breaking python-exec
-
-Running pip without --target, --prefix, --root, or --user will result
-in packages being installed systemwide. This has a tendency to break
-python-exec if setuptools gets installed or upgraded.
----
- src/pip/_internal/commands/install.py | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/src/pip/_internal/commands/install.py b/src/pip/_internal/commands/install.py
-index 8c2c32fd..41bac878 100644
---- a/src/pip/_internal/commands/install.py
-+++ b/src/pip/_internal/commands/install.py
-@@ -238,6 +238,9 @@ class InstallCommand(RequirementCommand):
- if options.upgrade:
- upgrade_strategy = options.upgrade_strategy
-
-+ if not options.use_user_site and not options.target_dir and not options.root_path and not options.prefix_path and not os.getenv('GENTOO_PIP_TESTING'):
-+ raise CommandError("(Gentoo) Please run pip with the --user option to avoid breaking python-exec")
-+
- cmdoptions.check_dist_restriction(options, check_target=True)
-
- install_options = options.install_options or []
---
-2.28.0
-
diff --git a/dev-python/pip/files/pip-22.2.1-no-coverage.patch b/dev-python/pip/files/pip-22.2.1-no-coverage.patch
deleted file mode 100644
index bd9523956ca8..000000000000
--- a/dev-python/pip/files/pip-22.2.1-no-coverage.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-From fe4438ee999938da3b6f67b4dd53d6676d67c3e7 Mon Sep 17 00:00:00 2001
-From: Arthur Zamarin <arthurzam@gentoo.org>
-Date: Fri, 29 Jul 2022 14:06:03 +0300
-Subject: [PATCH] Disable coverage testing support inside test venvs
-
----
- tests/conftest.py | 15 ---------------
- 1 file changed, 15 deletions(-)
-
-diff --git a/tests/conftest.py b/tests/conftest.py
-index c9ab292..e7c14df 100644
---- a/tests/conftest.py
-+++ b/tests/conftest.py
-@@ -403,13 +403,6 @@ def wheel_install(tmpdir_factory: pytest.TempPathFactory, common_wheels: Path) -
- return _common_wheel_editable_install(tmpdir_factory, common_wheels, "wheel")
-
-
--@pytest.fixture(scope="session")
--def coverage_install(
-- tmpdir_factory: pytest.TempPathFactory, common_wheels: Path
--) -> Path:
-- return _common_wheel_editable_install(tmpdir_factory, common_wheels, "coverage")
--
--
- def install_pth_link(
- venv: VirtualEnvironment, project_name: str, lib_dir: Path
- ) -> None:
-@@ -424,7 +417,6 @@ def virtualenv_template(
- tmpdir_factory: pytest.TempPathFactory,
- pip_src: Path,
- setuptools_install: Path,
-- coverage_install: Path,
- ) -> Iterator[VirtualEnvironment]:
-
- venv_type: VirtualEnvironmentType
-@@ -451,13 +443,6 @@ def virtualenv_template(
- [os.fspath(venv.bin / "python"), "setup.py", "-q", "develop"], cwd=pip_editable
- )
-
-- # Install coverage and pth file for executing it in any spawned processes
-- # in this virtual environment.
-- install_pth_link(venv, "coverage", coverage_install)
-- # zz prefix ensures the file is after easy-install.pth.
-- with open(venv.site / "zz-coverage-helper.pth", "a") as f:
-- f.write("import coverage; coverage.process_startup()")
--
- # Drop (non-relocatable) launchers.
- for exe in os.listdir(venv.bin):
- if not (
---
-2.35.1
-
diff --git a/dev-python/pulsectl/Manifest b/dev-python/pulsectl/Manifest
index 340fe028f103..8bfd700173fe 100644
--- a/dev-python/pulsectl/Manifest
+++ b/dev-python/pulsectl/Manifest
@@ -1,5 +1,7 @@
DIST pulsectl-22.3.2.tar.gz 40901 BLAKE2B 5b3eb752865e95cfbb70a7228409fea70b4c55c7297d652b4614df7ea4764dcb446f7a3e25bb89f6a55badbf6b300381c7c28c56f0a47e7faf1e63003f39d02c SHA512 7fc11c792a9e586d191a32831e0ef8896c40da1fdeddfd4467d7ec352e5e0ef0c910d7a2e8e82e1a381b16afefa17c9c9db4821be74d4694c934337b2a862f0c
DIST pulsectl-23.5.1.tar.gz 41131 BLAKE2B 4e24a0d79d2f5c5a365a23643019150693862a636115a0fcf26dbc64cf9d80a8637c1f03193f8d2513660e8f5268946ef287d01b93b7fd3a416dbb05b2c619f0 SHA512 69516e1d64cb2e27643de6fcb273b621ab89a03dd5c40eb71a7fa6b846da96f8f10baacf794c73edc3f60f65787c7050c16c234aa5b23169c2d5ae815232372a
+DIST pulsectl-23.5.2.tar.gz 41119 BLAKE2B 45239e9b6b3e19356f7c89acb673d9287e9e38099608e246c8334a5de82bf93d813688e376cf5aedb92e6b3368ce93bae1df630726a5ae568c83d774c942f848 SHA512 4f05edd994aac1964c358c50a95f564afb40fcc6ac410d5189525312c042057954d040dc41939b665347a39453244eccc138c4c7d628ef2da62034606716ecb9
EBUILD pulsectl-22.3.2.ebuild 577 BLAKE2B 87f6ee5e3c720f91b37598e8a966571c23163135416195fb87997fa741cb0d574bcc9f6014b6120a6d619e5afb104b46e298c485d38e97341ef1f06d3d3b1af8 SHA512 2d1112caf1ca3a5ef2b65c2f36a32d42cb38b72e378e6340ec30cdb014ee56d4818513b565e72c057cf6ee03cc12b57da93b1601366f7c2b56b7d86e61f3fef1
EBUILD pulsectl-23.5.1.ebuild 577 BLAKE2B 87f6ee5e3c720f91b37598e8a966571c23163135416195fb87997fa741cb0d574bcc9f6014b6120a6d619e5afb104b46e298c485d38e97341ef1f06d3d3b1af8 SHA512 2d1112caf1ca3a5ef2b65c2f36a32d42cb38b72e378e6340ec30cdb014ee56d4818513b565e72c057cf6ee03cc12b57da93b1601366f7c2b56b7d86e61f3fef1
+EBUILD pulsectl-23.5.2.ebuild 577 BLAKE2B 87f6ee5e3c720f91b37598e8a966571c23163135416195fb87997fa741cb0d574bcc9f6014b6120a6d619e5afb104b46e298c485d38e97341ef1f06d3d3b1af8 SHA512 2d1112caf1ca3a5ef2b65c2f36a32d42cb38b72e378e6340ec30cdb014ee56d4818513b565e72c057cf6ee03cc12b57da93b1601366f7c2b56b7d86e61f3fef1
MISC metadata.xml 558 BLAKE2B 6cdebbc1f507bbab92256bbac867a86468b733b40dacfdb71090738f5505ea6ac33b24cbeb06835e10d9845e3fd9189a6c34625176f12c9dc7f4a1511069e8fe SHA512 b15eaa0564bc6dadf8d46eab154d028b4cbde26fa099793aa23df8f82eba86a4125d173eca8a8d2d73359dc67171dca9d8716e1495168c7b6c8ff5c701a21577
diff --git a/dev-python/pulsectl/pulsectl-23.5.2.ebuild b/dev-python/pulsectl/pulsectl-23.5.2.ebuild
new file mode 100644
index 000000000000..a13a963b83ea
--- /dev/null
+++ b/dev-python/pulsectl/pulsectl-23.5.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python high-level interface and ctypes-based bindings for PulseAudio (libpulse)"
+HOMEPAGE="
+ https://github.com/mk-fg/python-pulse-control/
+ https://pypi.org/project/pulsectl/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-sound/pulseaudio
+"
+BDEPEND="
+ test? (
+ media-sound/pulseaudio-daemon
+ )
+"
+
+distutils_enable_tests unittest